gnu: Add Pfff.
[jackhill/guix/guix.git] / gnu / packages / conkeror.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
3 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages conkeror)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages gnuzilla))
27
28 (define-public conkeror
29 (package
30 (name "conkeror")
31 (version "1.0pre1.20150730")
32 (source (origin
33 (method url-fetch)
34 (uri
35 (string-append "http://repo.or.cz/w/conkeror.git/snapshot/"
36 "a1f7e879b129df5cf14ea4ce80a9c1407380ed58"
37 ".tar.gz")) ; tag: debian-1.0--pre-1+git150730-1
38 (sha256
39 (base32
40 "1q45hc30733gz3ca2ixvw0rzzcbi7rlay7gx7kvzjv17a030nyk0"))))
41 (build-system gnu-build-system)
42 (inputs `(("icecat" ,icecat)))
43 (arguments
44 `(#:tests? #f ;no tests
45 #:make-flags `("CC=gcc"
46 ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
47 #:phases
48 (modify-phases %standard-phases
49 (delete 'configure)
50 (add-after
51 'install 'install-app-launcher
52 (lambda* (#:key inputs outputs #:allow-other-keys)
53 ;; This overwrites the installed launcher, which execs xulrunner,
54 ;; with one that execs 'icecat --app'
55 (let* ((out (assoc-ref outputs "out"))
56 (datadir (string-append out "/share/conkeror"))
57 (launcher (string-append out "/bin/conkeror")))
58 (call-with-output-file launcher
59 (lambda (p)
60 (format p "#!~a/bin/bash
61 exec ~a/bin/icecat --app ~a \"$@\"~%"
62 (assoc-ref inputs "bash") ;implicit input
63 (assoc-ref inputs "icecat")
64 (string-append datadir
65 "/application.ini"))))
66 (chmod launcher #o555)))))))
67 (synopsis "Keyboard focused web browser with Emacs look and feel")
68 (description "Conkeror is a highly-programmable web browser based on
69 Mozilla XULRunner which is the base of all Mozilla products including Firefox.
70 Conkeror has a sophisticated keyboard system for running commands and
71 interacting with web page content, modelled after Emacs and Lynx. It is
72 self-documenting and extensible with JavaScript.
73
74 It comes with builtin support for several Web 2.0 sites like several Google
75 services (Search, Gmail, Maps, Reader, etc.), Del.icio.us, Reddit, Last.fm and
76 YouTube. For easier editing of form fields, it can spawn external editors.")
77 (home-page "http://conkeror.org")
78 ;; Conkeror is triple licensed.
79 (license (list
80 ;; MPL 1.1 -- this license is not GPL compatible
81 license:gpl2
82 license:lgpl2.1))))