gnu: gnupg: Update to 2.2.25.
[jackhill/guix/guix.git] / gnu / packages / patches / mutt-store-references.patch
1 By default 'mutt' embeds configure flags and the output of 'gcc -v',
2 which contains the store file name of Bash and GCC. This patch makes
3 sure we don't embed a reference to these in 'mutt'.
4
5 --- mutt-1.5.23/txt2c.sh 2015-06-26 22:56:56.500731643 +0200
6 +++ mutt-1.5.23/txt2c.sh 2015-06-26 22:57:26.664583900 +0200
7 @@ -21,6 +21,8 @@ txt2c_fallback () {
8 echo ";"
9 }
10
11 +echo "unsigned char $1[] = \"value of '$1' not kept\";"
12 +exit 0
13 ./txt2c test </dev/null >/dev/null 2>&1 &&
14 ./txt2c "$1" ||
15 txt2c_fallback "$1"
16