gnu: gnupg: Update to 2.2.25.
[jackhill/guix/guix.git] / gnu / packages / guile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
4 ;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
5 ;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
7 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
8 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
9 ;;; Copyright © 2016, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
11 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
12 ;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
13 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
14 ;;; Copyright © 2017, 2018 Amirouche <amirouche@hypermove.net>
15 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
16 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
17 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
18 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
19 ;;;
20 ;;; This file is part of GNU Guix.
21 ;;;
22 ;;; GNU Guix is free software; you can redistribute it and/or modify it
23 ;;; under the terms of the GNU General Public License as published by
24 ;;; the Free Software Foundation; either version 3 of the License, or (at
25 ;;; your option) any later version.
26 ;;;
27 ;;; GNU Guix is distributed in the hope that it will be useful, but
28 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
29 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
30 ;;; GNU General Public License for more details.
31 ;;;
32 ;;; You should have received a copy of the GNU General Public License
33 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
34
35 (define-module (gnu packages guile)
36 #:use-module ((guix licenses) #:prefix license:)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages autotools)
39 #:use-module (gnu packages base)
40 #:use-module (gnu packages bash)
41 #:use-module (gnu packages bdw-gc)
42 #:use-module (gnu packages compression)
43 #:use-module (gnu packages dbm)
44 #:use-module (gnu packages flex)
45 #:use-module (gnu packages gawk)
46 #:use-module (gnu packages gettext)
47 #:use-module (gnu packages hurd)
48 #:use-module (gnu packages libffi)
49 #:use-module (gnu packages libunistring)
50 #:use-module (gnu packages linux)
51 #:use-module (gnu packages m4)
52 #:use-module (gnu packages multiprecision)
53 #:use-module (gnu packages pkg-config)
54 #:use-module (gnu packages readline)
55 #:use-module (gnu packages sqlite)
56 #:use-module (gnu packages texinfo)
57 #:use-module (gnu packages version-control)
58 #:use-module (guix packages)
59 #:use-module (guix download)
60 #:use-module (guix git-download)
61 #:use-module (guix build-system gnu)
62 #:use-module (guix build-system guile)
63 #:use-module (guix deprecation)
64 #:use-module (guix utils)
65 #:use-module (ice-9 match)
66 #:use-module ((srfi srfi-1) #:prefix srfi-1:))
67
68 ;;; Commentary:
69 ;;;
70 ;;; GNU Guile, and modules and extensions.
71 ;;;
72 ;;; Code:
73
74 (define-public guile-1.8
75 (package
76 (name "guile")
77 (version "1.8.8")
78 (source (origin
79 (method url-fetch)
80 (uri (string-append "mirror://gnu/guile/guile-" version
81 ".tar.gz"))
82 (sha256
83 (base32
84 "0l200a0v7h8bh0cwz6v7hc13ds39cgqsmfrks55b1rbj5vniyiy3"))
85 (patches (search-patches "guile-1.8-cpp-4.5.patch"))))
86 (build-system gnu-build-system)
87 (arguments '(#:configure-flags '("--disable-error-on-warning")
88
89 ;; Insert a phase before `configure' to patch things up.
90 #:phases
91 (modify-phases %standard-phases
92 (add-before 'configure 'patch-stuff
93 (lambda* (#:key outputs #:allow-other-keys)
94 ;; Add a call to `lt_dladdsearchdir' so that
95 ;; `libguile-readline.so' & co. are in the
96 ;; loader's search path.
97 (substitute* "libguile/dynl.c"
98 (("lt_dlinit.*$" match)
99 (format #f
100 " ~a~% lt_dladdsearchdir(\"~a/lib\");~%"
101 match
102 (assoc-ref outputs "out"))))
103
104 ;; The usual /bin/sh...
105 (substitute* "ice-9/popen.scm"
106 (("/bin/sh") (which "sh")))
107 #t)))))
108
109 ;; When cross-compiling, a native version of Guile itself is needed.
110 (native-inputs (if (%current-target-system)
111 `(("self" ,this-package))
112 '()))
113
114 (inputs `(("gawk" ,gawk)
115 ("readline" ,readline)))
116
117 ;; Since `guile-1.8.pc' has "Libs: ... -lgmp -lltdl", these must be
118 ;; propagated.
119 (propagated-inputs `(("gmp" ,gmp)
120 ("libltdl" ,libltdl)))
121
122 (native-search-paths
123 (list (search-path-specification
124 (variable "GUILE_LOAD_PATH")
125 (files '("share/guile/site")))))
126
127 (synopsis "Scheme implementation intended especially for extensions")
128 (description
129 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
130 official extension language of the GNU system. It is an implementation of
131 the Scheme language which can be easily embedded in other applications to
132 provide a convenient means of extending the functionality of the application
133 without requiring the source code to be rewritten.")
134 (home-page "https://www.gnu.org/software/guile/")
135 (license license:lgpl2.0+)))
136
137 (define-public guile-2.0
138 (package
139 (name "guile")
140 (version "2.0.14")
141 (source (origin
142 (method url-fetch)
143 (uri (string-append "mirror://gnu/guile/guile-" version
144 ".tar.xz"))
145 (sha256
146 (base32
147 "10lxc6l5alf3lzbs3ihnbfy6dfcrsyf8667wa57f26vf4mk2ai78"))))
148 (build-system gnu-build-system)
149
150 ;; When cross-compiling, a native version of Guile itself is needed.
151 (native-inputs `(,@(if (%current-target-system)
152 `(("self" ,this-package))
153 '())
154 ("pkgconfig" ,pkg-config)))
155 (inputs `(("libffi" ,libffi)
156 ,@(libiconv-if-needed)
157
158 ;; We need Bash when cross-compiling because some of the scripts
159 ;; in bin/ refer to it. Use 'bash-minimal' because we don't need
160 ;; an interactive Bash with Readline and all.
161 ,@(if (target-mingw?) '() `(("bash" ,bash-minimal)))))
162 (propagated-inputs
163 `( ;; These ones aren't normally needed here, but since `libguile-2.0.la'
164 ;; reads `-lltdl -lunistring', adding them here will add the needed
165 ;; `-L' flags. As for why the `.la' file lacks the `-L' flags, see
166 ;; <http://thread.gmane.org/gmane.comp.lib.gnulib.bugs/18903>.
167 ("libunistring" ,libunistring)
168
169 ;; Depend on LIBLTDL, not LIBTOOL. That way, we avoid some the extra
170 ;; dependencies that LIBTOOL has, which is helpful during bootstrap.
171 ("libltdl" ,libltdl)
172
173 ;; The headers and/or `guile-2.0.pc' refer to these packages, so they
174 ;; must be propagated.
175 ("bdw-gc" ,libgc)
176 ("gmp" ,gmp)))
177
178 (outputs '("out" "debug"))
179
180 (arguments
181 `(#:configure-flags '("--disable-static") ; saves 3 MiB
182 #:phases
183 (modify-phases %standard-phases
184 ,@(if (hurd-system?)
185 '((add-after 'unpack 'disable-tests
186 (lambda _
187 ;; Hangs at: "Running 00-repl-server.test"
188 (rename-file "test-suite/tests/00-repl-server.test" "00-repl-server.test")
189 ;; Sometimes Hangs at: "Running 00-socket.test"
190 (rename-file "test-suite/tests/00-socket.test" "00-socket.test")
191 ;; FAIL: srfi-18.test: thread-sleep!: thread sleeps fractions of a second
192 (rename-file "test-suite/tests/srfi-18.test" "srfi-18.test")
193 ;; failed to remove 't-guild-compile-7215.go.tdL7yC
194 (substitute* "test-suite/standalone/Makefile.in"
195 (("test-guild-compile ") ""))
196 #t)))
197 '())
198 (add-before 'configure 'pre-configure
199 (lambda* (#:key inputs #:allow-other-keys)
200 ;; Tell (ice-9 popen) the file name of Bash.
201 (let ((bash (assoc-ref inputs "bash")))
202 (substitute* "module/ice-9/popen.scm"
203 ;; If bash is #f allow fallback for user to provide
204 ;; "bash" in PATH. This happens when cross-building to
205 ;; MinGW for which we do not have Bash yet.
206 (("/bin/sh")
207 ,@(if (target-mingw?)
208 '((if bash
209 (string-append bash "/bin/bash")
210 "bash"))
211 '((string-append bash "/bin/bash")))))
212 #t))))))
213
214 (native-search-paths
215 (list (search-path-specification
216 (variable "GUILE_LOAD_PATH")
217 (files '("share/guile/site/2.0")))
218 (search-path-specification
219 (variable "GUILE_LOAD_COMPILED_PATH")
220 (files '("lib/guile/2.0/site-ccache")))))
221
222 (synopsis "Scheme implementation intended especially for extensions")
223 (description
224 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
225 official extension language of the GNU system. It is an implementation of
226 the Scheme language which can be easily embedded in other applications to
227 provide a convenient means of extending the functionality of the application
228 without requiring the source code to be rewritten.")
229 (home-page "https://www.gnu.org/software/guile/")
230 (license license:lgpl3+)))
231
232 (define-public guile-2.2
233 (package (inherit guile-2.0)
234 (name "guile")
235 (version "2.2.7")
236 (source (origin
237 (method url-fetch)
238
239 ;; Note: we are limited to one of the compression formats
240 ;; supported by the bootstrap binaries, so no lzip here.
241 (uri (string-append "mirror://gnu/guile/guile-" version
242 ".tar.xz"))
243 (sha256
244 (base32
245 "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))
246 (modules '((guix build utils)))
247 (patches (search-patches
248 "guile-2.2-skip-oom-test.patch"))
249
250 ;; Remove the pre-built object files. Instead, build everything
251 ;; from source, at the expense of significantly longer build
252 ;; times (almost 3 hours on a 4-core Intel i5).
253 (snippet '(begin
254 (for-each delete-file
255 (find-files "prebuilt" "\\.go$"))
256 #t))))
257 (properties '((timeout . 72000) ;20 hours
258 (max-silent-time . 36000))) ;10 hours (needed on ARM
259 ; when heavily loaded)
260 (native-search-paths
261 (list (search-path-specification
262 (variable "GUILE_LOAD_PATH")
263 (files '("share/guile/site/2.2")))
264 (search-path-specification
265 (variable "GUILE_LOAD_COMPILED_PATH")
266 (files '("lib/guile/2.2/site-ccache")))))))
267
268 (define-deprecated guile-2.2/bug-fix guile-2.2)
269
270 (define-public guile-2.2.4
271 (package/inherit
272 guile-2.2
273 (version "2.2.4")
274 (source (origin
275 (inherit (package-source guile-2.2))
276 (uri (string-append "mirror://gnu/guile/guile-" version
277 ".tar.xz"))
278 (sha256
279 (base32
280 "07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))))))
281
282 (define-public guile-3.0
283 ;; This is the latest Guile stable version.
284 (package
285 (inherit guile-2.2)
286 (name "guile")
287 (version "3.0.2")
288 (source (origin
289 (inherit (package-source guile-2.2))
290 (uri (string-append "mirror://gnu/guile/guile-"
291 version ".tar.xz"))
292 (sha256
293 (base32
294 "12lziar4j27j9whqp2n18427q45y9ghq7gdd8lqhmj1k0lr7vi2k"))))
295 (arguments
296 ;; XXX: JIT-enabled Guile crashes in obscure ways on GNU/Hurd.
297 (if (hurd-target?)
298 (substitute-keyword-arguments (package-arguments guile-2.2)
299 ((#:configure-flags flags ''())
300 `(cons "--disable-jit" ,flags)))
301 (package-arguments guile-2.2)))
302 (native-search-paths
303 (list (search-path-specification
304 (variable "GUILE_LOAD_PATH")
305 (files '("share/guile/site/3.0")))
306 (search-path-specification
307 (variable "GUILE_LOAD_COMPILED_PATH")
308 (files '("lib/guile/3.0/site-ccache"
309 "share/guile/site/3.0")))))))
310
311 (define-public guile-3.0-latest
312 ;; TODO: Make this 'guile-3.0' on the next rebuild cycle.
313 (package
314 (inherit guile-3.0)
315 (version "3.0.4")
316 (source (origin
317 (inherit (package-source guile-3.0))
318 (uri (string-append "mirror://gnu/guile/guile-"
319 version ".tar.xz"))
320 (sha256
321 (base32
322 "0c8dkyvs6xbxp7rgnhkyakajzhakay7qn9kahj1mj49x5vf4fybb"))))))
323
324 (define-public guile-next
325 (deprecated-package "guile-next" guile-3.0))
326
327 (define-public guile-3.0/libgc-7
328 ;; Using libgc-7 avoid crashes that can occur, particularly when loading
329 ;; data in to the Guix Data Service:
330 ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40525
331 (hidden-package
332 (package
333 (inherit guile-3.0-latest)
334 (propagated-inputs
335 `(("bdw-gc" ,libgc-7)
336 ,@(srfi-1:alist-delete "bdw-gc" (package-propagated-inputs guile-3.0)))))))
337
338 (define-public guile-3.0/fixed
339 ;; A package of Guile that's rarely changed. It is the one used in the
340 ;; `base' module, and thus changing it entails a full rebuild.
341 (package
342 (inherit guile-3.0)
343 (properties '((hidden? . #t) ;people should install 'guile-2.2'
344 (timeout . 72000) ;20 hours
345 (max-silent-time . 36000))))) ;10 hours (needed on ARM
346 ; when heavily loaded)
347
348 (define* (make-guile-readline guile #:optional (name "guile-readline"))
349 (package
350 (name name)
351 (version (package-version guile))
352 (source (package-source guile))
353 (build-system gnu-build-system)
354 (arguments
355 '(#:configure-flags '("--disable-silent-rules")
356 #:phases (modify-phases %standard-phases
357 (add-before 'build 'chdir
358 (lambda* (#:key outputs #:allow-other-keys)
359 (invoke "make" "-C" "libguile" "scmconfig.h")
360 (invoke "make" "-C" "lib")
361 (chdir "guile-readline")
362
363 (substitute* "Makefile"
364 (("../libguile/libguile-[[:graph:]]+\\.la")
365 ;; Remove dependency on libguile-X.Y.la.
366 "")
367 (("^READLINE_LIBS = (.*)$" _ libs)
368 ;; Link against the provided libguile.
369 (string-append "READLINE_LIBS = "
370 "-lguile-$(GUILE_EFFECTIVE_VERSION) "
371 libs "\n"))
372 (("\\$\\(top_builddir\\)/meta/build-env")
373 ;; Use the provided Guile, not the one from
374 ;; $(builddir).
375 "")
376
377 ;; Install modules to the 'site' directories.
378 (("^moddir = .*$")
379 "moddir = $(pkgdatadir)/site/$(GUILE_EFFECTIVE_VERSION)\n")
380 (("^ccachedir = .*$")
381 "ccachedir = $(pkglibdir)/$(GUILE_EFFECTIVE_VERSION)/site-ccache\n"))
382
383 ;; Load 'guile-readline.so' from the right place.
384 (substitute* "ice-9/readline.scm"
385 (("load-extension \"guile-readline\"")
386 (format #f "load-extension \
387 (string-append ~s \"/lib/guile/\" (effective-version) \"/extensions/guile-readline\")"
388 (assoc-ref outputs "out"))))
389 #t)))))
390 (home-page (package-home-page guile))
391 (native-inputs (package-native-inputs guile))
392 (inputs
393 `(,@(package-inputs guile) ;to placate 'configure'
394 ,@(package-propagated-inputs guile)
395 ("guile" ,guile)
396 ("readline" ,readline)))
397 (synopsis "Line editing support for GNU Guile")
398 (description
399 "This module provides line editing support via the Readline library for
400 GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
401 @code{activate-readline} procedure to enable it.")
402 (license license:gpl3+)))
403
404 (define-public guile-readline
405 (make-guile-readline guile-3.0))
406
407 (define-public guile2.2-readline
408 (make-guile-readline guile-2.2 "guile2.2-readline"))
409
410 (define (guile-variant-package-name prefix)
411 (lambda (name)
412 "Return NAME with PREFIX instead of \"guile-\", when applicable."
413 (if (string-prefix? "guile-" name)
414 (string-append prefix "-"
415 (string-drop name
416 (string-length "guile-")))
417 name)))
418
419 (define package-for-guile-2.0
420 ;; A procedure that rewrites the dependency tree of the given package to use
421 ;; GUILE-2.0 instead of GUILE-3.0.
422 (package-input-rewriting `((,guile-3.0 . ,guile-2.0))
423 (guile-variant-package-name "guile2.0")
424 #:deep? #f))
425
426 (define package-for-guile-2.2
427 (package-input-rewriting `((,guile-3.0 . ,guile-2.2))
428 (guile-variant-package-name "guile2.2")
429 #:deep? #f))
430
431 (define-syntax define-deprecated-guile3.0-package
432 (lambda (s)
433 "Define a deprecated package alias for \"guile3.0-something\"."
434 (syntax-case s ()
435 ((_ name)
436 (and (identifier? #'name)
437 (string-prefix? "guile3.0-" (symbol->string (syntax->datum
438 #'name))))
439 (let ((->guile (lambda (str)
440 (let ((base (string-drop str
441 (string-length "guile3.0-"))))
442 (string-append "guile-" base)))))
443 (with-syntax ((package-name (symbol->string (syntax->datum #'name)))
444 (package
445 (datum->syntax
446 #'name
447 (string->symbol
448 (->guile (symbol->string (syntax->datum
449 #'name))))))
450 (old-name
451 ;; XXX: This is the name generated by
452 ;; 'define-deprecated'.
453 (datum->syntax
454 #'name
455 (symbol-append '% (syntax->datum #'name)
456 '/deprecated))))
457 #'(begin
458 (define-deprecated name package
459 (deprecated-package package-name package))
460 (export old-name))))))))
461
462 (define-deprecated-guile3.0-package guile3.0-readline)
463
464 (define-public guile-for-guile-emacs
465 (let ((commit "15ca78482ac0dd2e3eb36dcb31765d8652d7106d")
466 (revision "1"))
467 (package (inherit guile-2.2)
468 (name "guile-for-guile-emacs")
469 (version (git-version "2.1.2" revision commit))
470 (source (origin
471 (method git-fetch)
472 (uri (git-reference
473 (url "git://git.savannah.gnu.org/guile.git")
474 (commit commit)))
475 (file-name (git-file-name name version))
476 (sha256
477 (base32
478 "1l7ik4q4zk7vq4m3gnwizc0b64b1mdr31hxqlzxs94xaf2lvi7s2"))))
479 (arguments
480 (substitute-keyword-arguments (package-arguments guile-2.2)
481 ((#:phases phases '%standard-phases)
482 `(modify-phases ,phases
483 (replace 'bootstrap
484 (lambda _
485 ;; Disable broken tests.
486 ;; TODO: Fix them!
487 (substitute* "test-suite/tests/gc.test"
488 (("\\(pass-if \"after-gc-hook gets called\"" m)
489 (string-append "#;" m)))
490 (substitute* "test-suite/tests/version.test"
491 (("\\(pass-if \"version reporting works\"" m)
492 (string-append "#;" m)))
493 ;; Warning: Unwind-only `out-of-memory' exception; skipping pre-unwind handler.
494 ;; FAIL: test-out-of-memory
495 (substitute* "test-suite/standalone/Makefile.am"
496 (("(check_SCRIPTS|TESTS) \\+= test-out-of-memory") ""))
497
498 (patch-shebang "build-aux/git-version-gen")
499 (invoke "sh" "autogen.sh")
500 #t))))))
501 (native-inputs
502 `(("autoconf" ,autoconf)
503 ("automake" ,automake)
504 ("libtool" ,libtool)
505 ("flex" ,flex)
506 ("texinfo" ,texinfo)
507 ("gettext" ,gettext-minimal)
508 ,@(package-native-inputs guile-2.2))))))
509
510 \f
511 ;;;
512 ;;; Extensions.
513 ;;;
514
515 (define-public guile-json-1
516 (package
517 (name "guile-json")
518 (version "1.3.2")
519 (home-page "https://github.com/aconchillo/guile-json")
520 (source (origin
521 (method url-fetch)
522 (uri (string-append "mirror://savannah/guile-json/guile-json-"
523 version ".tar.gz"))
524 (sha256
525 (base32
526 "0m6yzb169r6iz56k3nkncjaiijwi4p0x9ijn1p5ax3s77jklxy9k"))))
527 (build-system gnu-build-system)
528 (arguments
529 `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
530 (native-inputs `(("pkg-config" ,pkg-config)
531 ("guile" ,guile-2.2)))
532 (inputs `(("guile" ,guile-2.2)))
533 (synopsis "JSON module for Guile")
534 (description
535 "Guile-JSON supports parsing and building JSON documents according to the
536 specification. These are the main features:
537
538 @itemize
539 @item Strictly complies to @uref{http://json.org, specification}.
540 @item Build JSON documents programmatically via macros.
541 @item Unicode support for strings.
542 @item Allows JSON pretty printing.
543 @end itemize\n")
544
545 ;; Version 1.2.0 switched to GPLv3+ (from LGPLv3+).
546 (license license:gpl3+)))
547
548 ;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
549 ;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
550 ;; 'guile-json-3'.
551 (define-deprecated guile-json guile-json-1)
552 (export guile-json)
553
554 (define-public guile2.0-json
555 (package-for-guile-2.0 guile-json-1))
556
557 (define-public guile-json-3
558 ;; This version is incompatible with 1.x; see the 'NEWS' file.
559 (package
560 (inherit guile-json-1)
561 (name "guile-json")
562 (version "3.5.0")
563 (source (origin
564 (method url-fetch)
565 (uri (string-append "mirror://savannah/guile-json/guile-json-"
566 version ".tar.gz"))
567 (sha256
568 (base32
569 "0nj0684qgh6ppkbdyxqfyjwsv2qbyairxpi8fzrhsi3xnc7jn4im"))))
570 (native-inputs `(("pkg-config" ,pkg-config)
571 ("guile" ,guile-3.0)))
572 (inputs `(("guile" ,guile-3.0)))))
573
574 (define-public guile3.0-json
575 (deprecated-package "guile3.0-json" guile-json-3))
576
577 (define-public guile-json-4
578 (package
579 (inherit guile-json-3)
580 (name "guile-json")
581 (version "4.3.2")
582 (source (origin
583 (method url-fetch)
584 (uri (string-append "mirror://savannah/guile-json/guile-json-"
585 version ".tar.gz"))
586 (sha256
587 (base32
588 "0255c7f053z4p9mqzhpxwbfx3y47j9nfvlgnm8xasdclyzmjl9y2"))))))
589
590 (define-public guile2.2-json
591 (package-for-guile-2.2 guile-json-4))
592
593 ;; There are two guile-gdbm packages, one using the FFI and one with
594 ;; direct C bindings, hence the verbose name.
595
596 (define-public guile-gdbm-ffi
597 (package
598 (name "guile-gdbm-ffi")
599 (version "20120209.fa1d5b6")
600 (source (origin
601 (method git-fetch)
602 (uri (git-reference
603 (url "https://github.com/ijp/guile-gdbm")
604 (commit "fa1d5b6231d0e4d096687b378c025f2148c5f246")))
605 (file-name (string-append name "-" version "-checkout"))
606 (patches (search-patches
607 "guile-gdbm-ffi-support-gdbm-1.14.patch"))
608 (sha256
609 (base32
610 "1j8wrsw7v9w6qkl47xz0rdikg50v16nn6kbs3lgzcymjzpa7babj"))))
611 (build-system guile-build-system)
612 (arguments
613 '(#:phases (modify-phases %standard-phases
614 (add-after 'unpack 'move-examples
615 (lambda* (#:key outputs #:allow-other-keys)
616 ;; Move examples where they belong.
617 (let* ((out (assoc-ref outputs "out"))
618 (doc (string-append out "/share/doc/"
619 (strip-store-file-name out)
620 "/examples")))
621 (copy-recursively "examples" doc)
622 (delete-file-recursively "examples")
623 #t)))
624 (add-after 'unpack 'set-libgdbm-file-name
625 (lambda* (#:key inputs #:allow-other-keys)
626 (substitute* "gdbm.scm"
627 (("\\(dynamic-link \"libgdbm\"\\)")
628 (format #f "(dynamic-link \"~a/lib/libgdbm.so\")"
629 (assoc-ref inputs "gdbm"))))
630 #t)))))
631 (native-inputs
632 `(("guile" ,guile-3.0)))
633 (inputs
634 `(("gdbm" ,gdbm)))
635 (home-page "https://github.com/ijp/guile-gdbm")
636 (synopsis "Guile bindings to the GDBM library via Guile's FFI")
637 (description
638 "Guile bindings to the GDBM key-value storage system, using
639 Guile's foreign function interface.")
640 (license license:gpl3+)))
641
642 (define-public guile2.0-gdbm-ffi
643 (package-for-guile-2.0 guile-gdbm-ffi))
644
645 (define-public guile2.2-gdbm-ffi
646 (package-for-guile-2.2 guile-gdbm-ffi))
647
648 (define-deprecated-guile3.0-package guile3.0-gdbm-ffi)
649
650 (define-public guile-sqlite3
651 (package
652 (name "guile-sqlite3")
653 (version "0.1.2")
654 (home-page "https://notabug.org/guile-sqlite3/guile-sqlite3.git")
655 (source (origin
656 (method git-fetch)
657 (uri (git-reference
658 (url home-page)
659 (commit (string-append "v" version))))
660 (sha256
661 (base32
662 "1nryy9j3bk34i0alkmc9bmqsm0ayz92k1cdf752mvhyjjn8nr928"))
663 (file-name (string-append name "-" version "-checkout"))))
664 (build-system gnu-build-system)
665 (native-inputs
666 `(("autoconf" ,autoconf)
667 ("automake" ,automake)
668 ("guile" ,guile-3.0)
669 ("pkg-config" ,pkg-config)))
670 (inputs
671 `(("guile" ,guile-3.0)
672 ("sqlite" ,sqlite)))
673 (synopsis "Access SQLite databases from Guile")
674 (description
675 "This package provides Guile bindings to the SQLite database system.")
676 (license license:gpl3+)))
677
678 (define-public guile2.0-sqlite3
679 (package-for-guile-2.0 guile-sqlite3))
680
681 (define-public guile2.2-sqlite3
682 (package-for-guile-2.2 guile-sqlite3))
683
684 (define-deprecated-guile3.0-package guile3.0-sqlite3)
685
686 (define-public guile-bytestructures
687 (package
688 (name "guile-bytestructures")
689 (version "1.0.7")
690 (home-page "https://github.com/TaylanUB/scheme-bytestructures")
691 (source (origin
692 (method git-fetch)
693 (uri (git-reference
694 (url home-page)
695 (commit (string-append "v" version))))
696 (file-name (git-file-name name version))
697 (sha256
698 (base32
699 "0q0habjiy3h9cigb7q1br9kz6z212dn2ab31f6dgd3rrmsfn5rvb"))))
700 (build-system gnu-build-system)
701 (arguments
702 `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
703
704 #:phases (modify-phases %standard-phases
705 (add-after 'install 'install-doc
706 (lambda* (#:key outputs #:allow-other-keys)
707 (let* ((out (assoc-ref outputs "out"))
708 (package ,(package-full-name this-package "-"))
709 (doc (string-append out "/share/doc/" package)))
710 (install-file "README.md" doc)
711 #t))))))
712 (native-inputs
713 `(("autoconf" ,autoconf)
714 ("automake" ,automake)
715 ("pkg-config" ,pkg-config)
716 ("guile" ,guile-3.0)))
717 (inputs
718 `(("guile" ,guile-3.0)))
719 (synopsis "Structured access to bytevector contents for Guile")
720 (description
721 "Guile bytestructures offers a system imitating the type system
722 of the C programming language, to be used on bytevectors. C's type
723 system works on raw memory, and Guile works on bytevectors which are
724 an abstraction over raw memory. It's also more powerful than the C
725 type system, elevating types to first-class status.")
726 (license license:gpl3+)
727 (properties '((upstream-name . "bytestructures")))))
728
729 (define-public guile2.0-bytestructures
730 (package-for-guile-2.0 guile-bytestructures))
731
732 (define-public guile2.2-bytestructures
733 (package-for-guile-2.2 guile-bytestructures))
734
735 (define-deprecated-guile3.0-package guile3.0-bytestructures)
736
737 (define-public guile-git
738 (package
739 (name "guile-git")
740 (version "0.4.0")
741 (home-page "https://gitlab.com/guile-git/guile-git.git")
742 (source (origin
743 (method url-fetch)
744 (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
745 "2600bb0dfdfb00bfbe46811dccad51d8/guile-git-"
746 version ".tar.gz"))
747 (sha256
748 (base32
749 "1kxyg9x2aa1pg69cl48wysq0pbxvwfahy1xpl5ab6p8babhf7kic"))))
750 (build-system gnu-build-system)
751 (arguments
752 `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
753 (native-inputs
754 `(("pkg-config" ,pkg-config)
755 ("guile" ,guile-3.0)
756 ("guile-bytestructures" ,guile-bytestructures)))
757 (inputs
758 `(("guile" ,guile-3.0)
759 ("libgit2" ,libgit2)))
760 (propagated-inputs
761 `(("guile-bytestructures" ,guile-bytestructures)))
762 (synopsis "Guile bindings for libgit2")
763 (description
764 "This package provides Guile bindings to libgit2, a library to
765 manipulate repositories of the Git version control system.")
766 (license license:gpl3+)))
767
768 (define-public guile2.2-git
769 (package-for-guile-2.2 guile-git))
770
771 (define-public guile2.0-git
772 (package-for-guile-2.0 guile-git))
773
774 (define-deprecated-guile3.0-package guile3.0-git)
775
776 (define-public guile-zlib
777 (package
778 (name "guile-zlib")
779 (version "0.0.1")
780 (source
781 (origin
782 ;; XXX: Do not use "git-fetch" method here that would create and
783 ;; endless inclusion loop, because this package is used as an extension
784 ;; in the same method.
785 (method url-fetch)
786 (uri
787 (string-append "https://notabug.org/guile-zlib/guile-zlib/archive/"
788 version ".tar.gz"))
789 (file-name (string-append name "-" version ".tar.gz"))
790 (sha256
791 (base32
792 "1caz6cbl6sg5567nk68z88rshp0m26zmb0a9ry1jkc1ivpk0n47i"))))
793 (build-system gnu-build-system)
794 (arguments
795 '(#:make-flags
796 '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
797 (native-inputs
798 `(("autoconf" ,autoconf)
799 ("automake" ,automake)
800 ("pkg-config" ,pkg-config)
801 ,@(if (%current-target-system)
802 `(("guile" ,guile-3.0)) ;for 'guild compile' and 'guile-3.0.pc'
803 '())))
804 (inputs
805 `(("guile" ,guile-3.0)
806 ("zlib" ,zlib)))
807 (synopsis "Guile bindings to zlib")
808 (description
809 "This package provides Guile bindings for zlib, a lossless
810 data-compression library. The bindings are written in pure Scheme by using
811 Guile's foreign function interface.")
812 (home-page "https://notabug.org/guile-zlib/guile-zlib")
813 (license license:gpl3+)))
814
815 (define-public guile-lzlib
816 (package
817 (name "guile-lzlib")
818 (version "0.0.2")
819 (source
820 (origin
821 (method url-fetch)
822 (uri
823 (string-append "https://notabug.org/guile-lzlib/guile-lzlib/archive/"
824 version ".tar.gz"))
825 (file-name (string-append name "-" version ".tar.gz"))
826 (sha256
827 (base32
828 "11sggvncyx08ssp1s5xii4d6nskh1qwqihnbpzzvkrs7sivxn8w6"))))
829 (build-system gnu-build-system)
830 (arguments
831 '(#:make-flags
832 '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
833 (native-inputs
834 `(("autoconf" ,autoconf)
835 ("automake" ,automake)
836 ("pkg-config" ,pkg-config)
837 ,@(if (%current-target-system)
838 `(("guile" ,guile-3.0)) ;for 'guild compile' and 'guile-3.0.pc'
839 '())))
840 (inputs
841 `(("guile" ,guile-3.0)
842 ("lzlib" ,lzlib)))
843 (synopsis "Guile bindings to lzlib")
844 (description
845 "This package provides Guile bindings for lzlib, a C library for
846 in-memory LZMA compression and decompression. The bindings are written in
847 pure Scheme by using Guile's foreign function interface.")
848 (home-page "https://notabug.org/guile-lzlib/guile-lzlib")
849 (license license:gpl3+)))
850
851 ;;; guile.scm ends here