gnu: apr: Update to 1.5.2.
[jackhill/guix/guix.git] / gnu / packages / apr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages apr)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages autotools))
28
29 (define-public apr
30 (package
31 (name "apr")
32 (version "1.5.2")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://apache/apr/apr-"
36 version ".tar.bz2"))
37 (sha256
38 (base32
39 "0ypn51xblix5ys9xy7da3ngdydip0qqh9rdq8nz54w9aq8lys0vx"))
40 (patches
41 (list (search-patch "apr-skip-getservbyname-test.patch")))
42 (patch-flags '("-p0"))))
43 (build-system gnu-build-system)
44 (arguments
45 ;; Sometimes we end up with two processes concurrently trying to make
46 ;; 'libmod_test.la': <http://hydra.gnu.org/build/60266/nixlog/2/raw>.
47 ;; Thus, build sequentially.
48 '(#:parallel-build? #f
49 #:parallel-tests? #f))
50 (inputs `(("perl" ,perl)
51 ("libltdl" ,libltdl)))
52 (home-page "http://apr.apache.org/")
53 (synopsis "The Apache Portable Runtime Library")
54 (description
55 "The mission of the Apache Portable Runtime (APR) project is to create and
56 maintain software libraries that provide a predictable and consistent interface
57 to underlying platform-specific implementations. The primary goal is to provide
58 an API to which software developers may code and be assured of predictable if
59 not identical behaviour regardless of the platform on which their software is
60 built, relieving them of the need to code special-case conditions to work
61 around or take advantage of platform-specific deficiencies or features.")
62 (license asl2.0)))
63
64 (define-public apr-util
65 (package
66 (name "apr-util")
67 (version "1.5.4")
68 (source (origin
69 (method url-fetch)
70 (uri (string-append "mirror://apache/apr/apr-util-"
71 version ".tar.bz2"))
72 (sha256
73 (base32
74 "0bn81pfscy9yjvbmyx442svf43s6dhrdfcsnkpxz43fai5qk5kx6"))))
75 (build-system gnu-build-system)
76 (inputs
77 `(("apr" ,apr)))
78 (arguments
79 '(#:phases
80 (alist-replace
81 'configure
82 (lambda* (#:key inputs outputs #:allow-other-keys)
83 (let ((out (assoc-ref outputs "out"))
84 (apr (assoc-ref inputs "apr")))
85 (setenv "CONFIG_SHELL" (which "bash"))
86 (zero?
87 (system* "./configure"
88 (string-append "--prefix=" out)
89 (string-append "--with-apr=" apr)))))
90 %standard-phases)
91
92 ;; There are race conditions during 'make check'. Typically, the
93 ;; 'testall' executable is not built yet by the time 'make check' tries
94 ;; to run it. See
95 ;; <http://lists.gnu.org/archive/html/guix-devel/2014-03/msg00261.html>.
96 #:parallel-tests? #f))
97 (home-page "http://apr.apache.org/")
98 (synopsis "One of the Apache Portable Runtime Library companions")
99 (description
100 "APR-util provides a number of helpful abstractions on top of APR.")
101 (license asl2.0)))