gnu: xf86-video-sis: Fix FTBFS with xorg-server >= 1.20.
[jackhill/guix/guix.git] / gnu / packages / patches / xf86-video-sis-xorg-compat.patch
1 Remove use of interface no longer provided by xorg-server.
2
3 Patch taken from upstream:
4 https://cgit.freedesktop.org/xorg/driver/xf86-video-sis/commit/?id=4b1356a2b7fd06e9a05d134caa4033681c939737
5
6 diff --git a/src/sis_driver.c b/src/sis_driver.c
7 index 8f06164..513f68b 100644
8 --- a/src/sis_driver.c
9 +++ b/src/sis_driver.c
10 @@ -2738,7 +2738,7 @@ SiSPrintModes(ScrnInfoPtr pScrn)
11 float hsync, refresh = 0.0;
12 char *desc, *desc2, *prefix, *uprefix, *output;
13
14 - xf86DrvMsg(pScrn->scrnIndex, pScrn->virtualFrom, "Virtual size is %dx%d "
15 + xf86DrvMsg(pScrn->scrnIndex, X_INFO, "Virtual size is %dx%d "
16 "(pitch %d)\n", pScrn->virtualX, pScrn->virtualY,
17 pScrn->displayWidth);
18