gnu: libphidget: Add "debug" output.
[jackhill/guix/guix.git] / gnu / packages / readline.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages readline)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages ncurses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public readline
28 (let ((post-install-phase
29 '(lambda* (#:key outputs #:allow-other-keys)
30 (let* ((out (assoc-ref outputs "out"))
31 (lib (string-append out "/lib")))
32 ;; Make libraries writable so that `strip' can work.
33 ;; Failing to do that, it bails out with "Permission
34 ;; denied".
35 (for-each (lambda (f) (chmod f #o755))
36 (find-files lib "\\.so"))
37 (for-each (lambda (f) (chmod f #o644))
38 (find-files lib "\\.a"))))))
39 (package
40 (name "readline")
41 (version "6.2")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "mirror://gnu/readline/readline-"
45 version ".tar.gz"))
46 (sha256
47 (base32
48 "10ckm2bd2rkxhvdmj7nmbsylmihw0abwcsnxf8y27305183rd9kr"))))
49 (build-system gnu-build-system)
50 (propagated-inputs `(("ncurses" ,ncurses)))
51 (inputs `(("patch/link-ncurses"
52 ,(search-patch "readline-link-ncurses.patch"))))
53 (arguments `(#:patches (list (assoc-ref %build-inputs
54 "patch/link-ncurses"))
55 #:patch-flags '("-p0")
56 #:configure-flags
57 (list (string-append "LDFLAGS=-Wl,-rpath -Wl,"
58 (assoc-ref %build-inputs "ncurses")
59 "/lib"))
60
61 #:phases (alist-cons-after
62 'install 'post-install
63 ,post-install-phase
64 %standard-phases)))
65 (synopsis "Edit command lines while typing, with history support")
66 (description
67 "The GNU Readline library provides a set of functions for use by
68 applications that allow users to edit command lines as they are typed in.
69 Both Emacs and vi editing modes are available. The Readline library includes
70 additional functions to maintain a list of previously-entered command lines,
71 to recall and perhaps reedit those lines, and perform csh-like history
72 expansion on previous commands.
73
74 The history facilites are also placed into a separate library, the History
75 library, as part of the build process. The History library may be used
76 without Readline in applications which desire its capabilities.")
77 (license gpl3+)
78 (home-page "http://savannah.gnu.org/projects/readline/"))))