gnu: libphidget: Add "debug" output.
[jackhill/guix/guix.git] / gnu / packages / parted.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages parted)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages check)
25 #:use-module ((gnu packages gettext)
26 #:renamer (symbol-prefix-proc 'guix:))
27 #:use-module (gnu packages linux)
28 #:use-module (gnu packages readline))
29
30 (define-public parted
31 (package
32 (name "parted")
33 (version "3.1")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/parted/parted-"
38 version ".tar.xz"))
39 (sha256
40 (base32
41 "05fa4m1bky9d13hqv91jlnngzlyn7y4rnnyq6d86w0dg3vww372y"))))
42 (build-system gnu-build-system)
43 (arguments `(#:configure-flags '("--disable-device-mapper")
44 #:phases (alist-cons-before
45 'configure 'fix-mkswap
46 (lambda* (#:key inputs #:allow-other-keys)
47 (let ((util-linux (assoc-ref inputs
48 "util-linux")))
49 (substitute*
50 "tests/t9050-partition-table-types.sh"
51 (("mkswap")
52 (string-append util-linux "/sbin/mkswap")))))
53 %standard-phases)))
54 (inputs
55 ;; XXX: add 'lvm2'.
56 `(("check" ,check)
57 ("gettext" ,guix:gettext)
58 ("readline" ,readline)
59 ("util-linux" ,util-linux)))
60 (home-page "http://www.gnu.org/software/parted/")
61 (synopsis "Disk partition editor")
62 (description
63 "GNU Parted is an industrial-strength package for creating, destroying,
64 resizing, checking and copying partitions, and the file systems on them. This
65 is useful for creating space for new operating systems, reorganising disk
66 usage, copying data on hard disks and disk imaging.
67
68 It contains a library, libparted, and a command-line frontend, parted, which
69 also serves as a sample implementation and script backend.")
70 (license gpl3+)))