gnu: libphidget: Add "debug" output.
[jackhill/guix/guix.git] / gnu / packages / mp3.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mp3)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (gnu packages autotools)
23 #:use-module (gnu packages compression)
24 #:use-module (gnu packages oggvorbis)
25 #:use-module (gnu packages pcre)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
30
31 (define-public libmad
32 (package
33 (name "libmad")
34 (version "0.15.1b")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://sourceforge/mad/libmad/"
38 version "/libmad-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "14460zhacxhswnzb36qfpd1f2wbk10qvksvm6wyq5hpvdgnw7ymv"))))
43 (build-system gnu-build-system)
44 (arguments
45 `(#:phases
46 (alist-replace
47 'configure
48 (lambda* (#:key #:allow-other-keys #:rest args)
49 (let ((configure (assoc-ref %standard-phases 'configure)))
50 ;; remove option that is not supported by gcc any more
51 (substitute* "configure" ((" -fforce-mem") ""))
52 (apply configure args)))
53 %standard-phases)))
54 (synopsis "libmad, an MPEG audio decoder")
55 (description
56 "MAD (MPEG Audio Decoder) supports MPEG-1 and the MPEG-2 extension to
57 lower sampling frequencies, as well as the de facto MPEG 2.5 format.
58 All three audio layers — Layer I, Layer II, and Layer III (i.e. MP3) — are
59 fully implemented.
60
61 This package contains the library.")
62 (license license:gpl2+)
63 (home-page "http://www.underbit.com/products/mad/")))
64
65 (define-public libid3tag
66 (package
67 (name "libid3tag")
68 (version "0.15.1b")
69 (source (origin
70 (method url-fetch)
71 (uri (string-append "mirror://sourceforge/mad/libid3tag/"
72 version "/libid3tag-"
73 version ".tar.gz"))
74 (sha256
75 (base32
76 "0lb1w883dc46dajbdvnia5870brl5lvnlk7g7y58y9wpg5p4znk3"))))
77 (build-system gnu-build-system)
78 (inputs `(("zlib" ,zlib)))
79 (synopsis "libid3tag, a library for reading ID3 tags")
80 (description
81 "libid3tag is a library for reading ID3 tags, both ID3v1 and the various
82 versions of ID3v2")
83 (license license:gpl2+)
84 (home-page "http://www.underbit.com/products/mad/")))
85
86 (define-public id3lib
87 (package
88 (name "id3lib")
89 (version "3.8.3")
90 (source (origin
91 (method url-fetch)
92 (uri (string-append "mirror://sourceforge/id3lib/id3lib/"
93 version "/id3lib-"
94 version ".tar.gz"))
95 (sha256
96 (base32
97 "0yfhqwk0w8q2hyv1jib1008jvzmwlpsxvc8qjllhna6p1hycqj97"))))
98 (build-system gnu-build-system)
99 (arguments
100 `(#:phases
101 (alist-replace
102 'configure
103 (lambda* (#:key #:allow-other-keys #:rest args)
104 (let ((configure (assoc-ref %standard-phases 'configure)))
105 (substitute* "configure"
106 (("iomanip.h") "")) ; drop check for unused header
107 ;; see http://www.linuxfromscratch.org/patches/downloads/id3lib/
108 (substitute* "include/id3/id3lib_strings.h"
109 (("include <string>") "include <cstring>\n#include <string>"))
110 (substitute* "include/id3/writers.h"
111 (("//\\#include <string.h>") "#include <cstring>"))
112 (substitute* "examples/test_io.cpp"
113 (("dami;") "dami;\nusing namespace std;"))
114 (apply configure args)))
115 %standard-phases)))
116 (synopsis "a library for reading, writing, and manipulating ID3v1 and ID3v2 tags")
117 (description
118 "id3lib is a cross-platform software development library for reading,
119 writing, and manipulating ID3v1 and ID3v2 tags. It is an on-going project
120 whose primary goals are full compliance with the ID3v2 standard, portability
121 across several platforms, and providing a powerful and feature-rich API with
122 a highly stable and efficient implementation.")
123 (license license:lgpl2.0+)
124 (home-page "http://id3lib.sourceforge.net/")))
125
126 (define-public libmp3splt
127 (package
128 (name "libmp3splt")
129 (version "0.8.1a")
130 (source (origin
131 (method url-fetch)
132 (uri (string-append "mirror://sourceforge/mp3splt/libmp3splt/"
133 version "/libmp3splt-"
134 version ".tar.gz"))
135 (sha256
136 (base32
137 "0d20r1bd4fgp9kp7w3qixjgll34czck9dgw59mx2kbhb0mhh00d8"))))
138 (build-system gnu-build-system)
139 (inputs `(("libid3tag" ,libid3tag)
140 ("libmad" ,libmad)
141 ("libogg" ,libogg)
142 ("libtool" ,libtool)
143 ("libvorbid" ,libvorbis)
144 ("pkg-config" ,pkg-config)
145 ("pcre" ,pcre)))
146 (synopsis "libmp3splt, a library for splitting mp3 and ogg vorbis files")
147 (description
148 "Mp3splt is a utility to split mp3 and ogg vorbis files selecting a begin
149 and an end time position, without decoding. For splitting an album, one may
150 select split points and filenames manually or obtain them automatically from
151 CDDB (internet or a local file) or from .cue files. The tool also supports
152 automatic silence split, that can be used also to adjust cddb/cue splitpoints.
153
154 This package contains the library.")
155 (license license:gpl2+)
156 (home-page "http://mp3splt.sourceforge.net/mp3splt_page/home.php")))
157
158 (define-public mp3splt
159 (package
160 (name "mp3splt")
161 (version "2.5.1")
162 (source (origin
163 (method url-fetch)
164 (uri (string-append "mirror://sourceforge/mp3splt/mp3splt/"
165 version "/mp3splt-"
166 version ".tar.gz"))
167 (sha256
168 (base32
169 "106dnka56prlc9nsfh300f8841am2lmkwlzgl9lkr25mgnc35wwh"))))
170 (build-system gnu-build-system)
171 (inputs `(("libmp3splt" ,libmp3splt)))
172 (synopsis "mp3splt, a utiliy for splitting mp3 and ogg vorbis files")
173 (description
174 "Mp3splt is a utility to split mp3 and ogg vorbis files selecting a begin
175 and an end time position, without decoding. For splitting an album, one may
176 select split points and filenames manually or obtain them automatically from
177 CDDB (internet or a local file) or from .cue files. The tool also supports
178 automatic silence split, that can be used also to adjust cddb/cue splitpoints.
179
180 This package contains the binary.")
181 (license license:gpl2+)
182 (home-page "http://mp3splt.sourceforge.net/mp3splt_page/home.php")))
183
184 (define-public mpg321
185 (package
186 (name "mpg321")
187 (version "0.3.1")
188 (source (origin
189 (method url-fetch)
190 (uri (string-append "mirror://sourceforge/mpg321/"
191 version "/mpg321-" version ".tar.gz"))
192 (sha256
193 (base32
194 "0yamsqvj15nsxxnjs9mgyslzx7krgsfk3q1hk3g6l8w9bbbj770b"))))
195 (build-system gnu-build-system)
196 (arguments '(#:configure-flags '("--disable-alsa")))
197 (inputs
198 `(("zlib" ,zlib)
199 ("libmad" ,libmad)
200 ("libid3tag" ,libid3tag)
201 ("libao" ,ao)))
202 (home-page "http://mpg321.sourceforge.net/")
203 (synopsis "Command-line MP3 player")
204 (description "mpg321 is a command-line mp3 player. mpg321 is used for
205 frontends, as an mp3 player and as an mp3 to wave file decoder (primarily for
206 use with CD-recording software).")
207 (license license:gpl2)))