gnu: libphidget: Add "debug" output.
[jackhill/guix/guix.git] / gnu / packages / global.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages global)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages ncurses)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages))
27
28 (define-public global ; a global variable
29 (package
30 (name "global")
31 (version "6.2.8")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/global/global-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1l6g51kff5010gwmw08jbks1mssgddz7wggjvfsky3g000jkpvf1"))))
39 (build-system gnu-build-system)
40 (inputs `(("ncurses" ,ncurses)
41 ("libtool" ,libtool)))
42 (arguments
43 `(#:configure-flags
44 (list (string-append "--with-ncurses="
45 (assoc-ref %build-inputs "ncurses")))))
46 (home-page "http://www.gnu.org/software/global/")
47 (synopsis "Cross-environment source code tag system")
48 (description
49 "GNU GLOBAL is a source code tagging system that works the same way
50 across diverse environments (Emacs, vi, less, Bash, web browser, etc).
51 You can locate specified objects in source files and move there easily.
52 It is useful for hacking a large project containing many
53 subdirectories, many #ifdef and many main() functions. It is similar
54 to ctags or etags but is different from them at the point of
55 independence of any editor. It runs on a UNIX (POSIX) compatible
56 operating system like GNU and BSD.")
57 (license gpl3+)))