gnu: libphidget: Add "debug" output.
[jackhill/guix/guix.git] / gnu / packages / cpio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cpio)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public cpio
27 (package
28 (name "cpio")
29 (version "2.11")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/cpio/cpio-"
34 version ".tar.bz2"))
35 (sha256
36 (base32
37 "1gavgpzqwgkpagjxw72xgxz52y1ifgz0ckqh8g7cckz7jvyhp0mv"))))
38 (build-system gnu-build-system)
39 (arguments
40 `(#:patches (list (assoc-ref %build-inputs
41 "patch/gets"))))
42 (inputs
43 `(("patch/gets" ,(search-patch "cpio-gets-undeclared.patch"))))
44 (home-page "https://www.gnu.org/software/cpio/")
45 (synopsis "Manage cpio and tar file archives")
46 (description
47 "GNU Cpio copies files into or out of a cpio or tar archive. The
48 archive can be another file on the disk, a magnetic tape, or a pipe.
49
50 GNU Cpio supports the following archive formats: binary, old ASCII, new
51 ASCII, crc, HPUX binary, HPUX old ASCII, old tar, and POSIX.1 tar. The
52 tar format is provided for compatability with the tar program. By
53 default, cpio creates binary format archives, for compatibility with
54 older cpio programs. When extracting from archives, cpio automatically
55 recognizes which kind of archive it is reading and can read archives
56 created on machines with a different byte-order.")
57 (license gpl3+)))