gnu: libphidget: Add "debug" output.
[jackhill/guix/guix.git] / gnu / packages / bdb.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages bdb)
20 #:use-module (gnu packages)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public bdb
27 (package
28 (name "bdb")
29 (version "5.3.21")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "http://download.oracle.com/berkeley-db/db-" version
33 ".tar.gz"))
34 (sha256 (base32
35 "1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
36 (build-system gnu-build-system)
37 (arguments
38 '(#:tests? #f ; no check target available
39 #:phases
40 (alist-replace
41 'configure
42 (lambda* (#:key outputs #:allow-other-keys)
43 (let ((out (assoc-ref outputs "out")))
44 (zero?
45 (system* "./dist/configure"
46 (string-append "--prefix=" out)
47 (string-append "CONFIG_SHELL=" (which "bash"))
48 (string-append "SHELL=" (which "bash"))
49
50 ;; The compatibility mode is needed by some packages,
51 ;; notably iproute2.
52 "--enable-compat185"))))
53 %standard-phases)))
54 (synopsis "db, the Berkeley database")
55 (description
56 "Berkeley DB is an embeddable database allowing developers the choice of
57 SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
58 (license (bsd-style "file://LICENSE"
59 "See LICENSE in the distribution."))
60 (home-page "http://www.oracle.com/us/products/database/berkeley-db/overview/index.html")))