Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / guile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
4 ;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
5 ;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
7 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
8 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
9 ;;; Copyright © 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
11 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
12 ;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
13 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
14 ;;; Copyright © 2017, 2018 Amirouche <amirouche@hypermove.net>
15 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
16 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
17 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages guile)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages autotools)
38 #:use-module (gnu packages base)
39 #:use-module (gnu packages bash)
40 #:use-module (gnu packages bdw-gc)
41 #:use-module (gnu packages compression)
42 #:use-module (gnu packages dbm)
43 #:use-module (gnu packages flex)
44 #:use-module (gnu packages gawk)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages hurd)
47 #:use-module (gnu packages libffi)
48 #:use-module (gnu packages libunistring)
49 #:use-module (gnu packages linux)
50 #:use-module (gnu packages m4)
51 #:use-module (gnu packages multiprecision)
52 #:use-module (gnu packages pkg-config)
53 #:use-module (gnu packages readline)
54 #:use-module (gnu packages sqlite)
55 #:use-module (gnu packages texinfo)
56 #:use-module (gnu packages version-control)
57 #:use-module (guix packages)
58 #:use-module (guix download)
59 #:use-module (guix git-download)
60 #:use-module (guix build-system gnu)
61 #:use-module (guix build-system guile)
62 #:use-module (guix deprecation)
63 #:use-module (guix utils)
64 #:use-module (ice-9 match)
65 #:use-module ((srfi srfi-1) #:prefix srfi-1:))
66
67 ;;; Commentary:
68 ;;;
69 ;;; GNU Guile, and modules and extensions.
70 ;;;
71 ;;; Code:
72
73 (define-public guile-1.8
74 (package
75 (name "guile")
76 (version "1.8.8")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "mirror://gnu/guile/guile-" version
80 ".tar.gz"))
81 (sha256
82 (base32
83 "0l200a0v7h8bh0cwz6v7hc13ds39cgqsmfrks55b1rbj5vniyiy3"))
84 (patches (search-patches "guile-1.8-cpp-4.5.patch"))))
85 (build-system gnu-build-system)
86 (arguments '(#:configure-flags '("--disable-error-on-warning")
87
88 ;; Insert a phase before `configure' to patch things up.
89 #:phases
90 (modify-phases %standard-phases
91 (add-before 'configure 'patch-stuff
92 (lambda* (#:key outputs #:allow-other-keys)
93 ;; Add a call to `lt_dladdsearchdir' so that
94 ;; `libguile-readline.so' & co. are in the
95 ;; loader's search path.
96 (substitute* "libguile/dynl.c"
97 (("lt_dlinit.*$" match)
98 (format #f
99 " ~a~% lt_dladdsearchdir(\"~a/lib\");~%"
100 match
101 (assoc-ref outputs "out"))))
102
103 ;; The usual /bin/sh...
104 (substitute* "ice-9/popen.scm"
105 (("/bin/sh") (which "sh")))
106 #t)))))
107
108 ;; When cross-compiling, a native version of Guile itself is needed.
109 (native-inputs (if (%current-target-system)
110 `(("self" ,this-package))
111 '()))
112
113 (inputs `(("gawk" ,gawk)
114 ("readline" ,readline)))
115
116 ;; Since `guile-1.8.pc' has "Libs: ... -lgmp -lltdl", these must be
117 ;; propagated.
118 (propagated-inputs `(("gmp" ,gmp)
119 ("libltdl" ,libltdl)))
120
121 (native-search-paths
122 (list (search-path-specification
123 (variable "GUILE_LOAD_PATH")
124 (files '("share/guile/site")))))
125
126 (synopsis "Scheme implementation intended especially for extensions")
127 (description
128 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
129 official extension language of the GNU system. It is an implementation of
130 the Scheme language which can be easily embedded in other applications to
131 provide a convenient means of extending the functionality of the application
132 without requiring the source code to be rewritten.")
133 (home-page "https://www.gnu.org/software/guile/")
134 (license license:lgpl2.0+)))
135
136 (define-public guile-2.0
137 (package
138 (name "guile")
139 (version "2.0.14")
140 (source (origin
141 (method url-fetch)
142 (uri (string-append "mirror://gnu/guile/guile-" version
143 ".tar.xz"))
144 (sha256
145 (base32
146 "10lxc6l5alf3lzbs3ihnbfy6dfcrsyf8667wa57f26vf4mk2ai78"))))
147 (build-system gnu-build-system)
148
149 ;; When cross-compiling, a native version of Guile itself is needed.
150 (native-inputs `(,@(if (%current-target-system)
151 `(("self" ,this-package))
152 '())
153 ("pkgconfig" ,pkg-config)))
154 (inputs `(("libffi" ,libffi)
155 ,@(libiconv-if-needed)
156
157 ;; We need Bash when cross-compiling because some of the scripts
158 ;; in bin/ refer to it. Use 'bash-minimal' because we don't need
159 ;; an interactive Bash with Readline and all.
160 ,@(if (target-mingw?) '() `(("bash" ,bash-minimal)))))
161 (propagated-inputs
162 `( ;; These ones aren't normally needed here, but since `libguile-2.0.la'
163 ;; reads `-lltdl -lunistring', adding them here will add the needed
164 ;; `-L' flags. As for why the `.la' file lacks the `-L' flags, see
165 ;; <http://thread.gmane.org/gmane.comp.lib.gnulib.bugs/18903>.
166 ("libunistring" ,libunistring)
167
168 ;; Depend on LIBLTDL, not LIBTOOL. That way, we avoid some the extra
169 ;; dependencies that LIBTOOL has, which is helpful during bootstrap.
170 ("libltdl" ,libltdl)
171
172 ;; The headers and/or `guile-2.0.pc' refer to these packages, so they
173 ;; must be propagated.
174 ("bdw-gc" ,libgc)
175 ("gmp" ,gmp)))
176
177 (outputs '("out" "debug"))
178
179 (arguments
180 `(#:configure-flags '("--disable-static") ; saves 3 MiB
181 #:phases
182 (modify-phases %standard-phases
183 (add-before 'configure 'pre-configure
184 (lambda* (#:key inputs #:allow-other-keys)
185 ;; Tell (ice-9 popen) the file name of Bash.
186 (let ((bash (assoc-ref inputs "bash")))
187 (substitute* "module/ice-9/popen.scm"
188 ;; If bash is #f allow fallback for user to provide
189 ;; "bash" in PATH. This happens when cross-building to
190 ;; MinGW for which we do not have Bash yet.
191 (("/bin/sh")
192 ,@(if (target-mingw?)
193 '((if bash
194 (string-append bash "/bin/bash")
195 "bash"))
196 '((string-append bash "/bin/bash")))))
197 #t))))))
198
199 (native-search-paths
200 (list (search-path-specification
201 (variable "GUILE_LOAD_PATH")
202 (files '("share/guile/site/2.0")))
203 (search-path-specification
204 (variable "GUILE_LOAD_COMPILED_PATH")
205 (files '("lib/guile/2.0/site-ccache")))))
206
207 (synopsis "Scheme implementation intended especially for extensions")
208 (description
209 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
210 official extension language of the GNU system. It is an implementation of
211 the Scheme language which can be easily embedded in other applications to
212 provide a convenient means of extending the functionality of the application
213 without requiring the source code to be rewritten.")
214 (home-page "https://www.gnu.org/software/guile/")
215 (license license:lgpl3+)))
216
217 (define-public guile-2.2
218 (package (inherit guile-2.0)
219 (name "guile")
220 (version "2.2.7")
221 (source (origin
222 (method url-fetch)
223
224 ;; Note: we are limited to one of the compression formats
225 ;; supported by the bootstrap binaries, so no lzip here.
226 (uri (string-append "mirror://gnu/guile/guile-" version
227 ".tar.xz"))
228 (sha256
229 (base32
230 "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))
231 (modules '((guix build utils)))
232 (patches (search-patches
233 "guile-2.2-skip-oom-test.patch"))
234
235 ;; Remove the pre-built object files. Instead, build everything
236 ;; from source, at the expense of significantly longer build
237 ;; times (almost 3 hours on a 4-core Intel i5).
238 (snippet '(begin
239 (for-each delete-file
240 (find-files "prebuilt" "\\.go$"))
241 #t))))
242 (properties '((timeout . 72000) ;20 hours
243 (max-silent-time . 36000))) ;10 hours (needed on ARM
244 ; when heavily loaded)
245 (native-search-paths
246 (list (search-path-specification
247 (variable "GUILE_LOAD_PATH")
248 (files '("share/guile/site/2.2")))
249 (search-path-specification
250 (variable "GUILE_LOAD_COMPILED_PATH")
251 (files '("lib/guile/2.2/site-ccache")))))))
252
253 (define-deprecated guile-2.2/bug-fix guile-2.2)
254
255 (define-public guile-2.2.4
256 (package/inherit
257 guile-2.2
258 (version "2.2.4")
259 (source (origin
260 (inherit (package-source guile-2.2))
261 (uri (string-append "mirror://gnu/guile/guile-" version
262 ".tar.xz"))
263 (sha256
264 (base32
265 "07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))))))
266
267 (define-public guile-3.0
268 ;; This is the latest Guile stable version.
269 (package
270 (inherit guile-2.2)
271 (name "guile")
272 (version "3.0.1")
273 (source (origin
274 (inherit (package-source guile-2.2))
275 (uri (string-append "mirror://gnu/guile/guile-"
276 version ".tar.xz"))
277 (sha256
278 (base32
279 "1jakps3127h8g69ixgb4zwc8v2g29dmwql1vi3pwg30kzp8fm5nn"))
280 (patches
281 (append (search-patches "guile-3.0-crash.patch")
282 (origin-patches (package-source guile-2.2))))))
283 (native-search-paths
284 (list (search-path-specification
285 (variable "GUILE_LOAD_PATH")
286 (files '("share/guile/site/3.0")))
287 (search-path-specification
288 (variable "GUILE_LOAD_COMPILED_PATH")
289 (files '("lib/guile/3.0/site-ccache"
290 "share/guile/site/3.0")))))))
291
292 (define-public guile-next guile-3.0)
293
294 (define-public guile-3.0/fixed
295 ;; A package of Guile that's rarely changed. It is the one used in the
296 ;; `base' module, and thus changing it entails a full rebuild.
297 (package
298 (inherit guile-3.0)
299 (properties '((hidden? . #t) ;people should install 'guile-2.2'
300 (timeout . 72000) ;20 hours
301 (max-silent-time . 36000))))) ;10 hours (needed on ARM
302 ; when heavily loaded)
303
304 (define* (make-guile-readline guile #:optional (name "guile-readline"))
305 (package
306 (name name)
307 (version (package-version guile))
308 (source (package-source guile))
309 (build-system gnu-build-system)
310 (arguments
311 '(#:configure-flags '("--disable-silent-rules")
312 #:phases (modify-phases %standard-phases
313 (add-before 'build 'chdir
314 (lambda* (#:key outputs #:allow-other-keys)
315 (invoke "make" "-C" "libguile" "scmconfig.h")
316 (invoke "make" "-C" "lib")
317 (chdir "guile-readline")
318
319 (substitute* "Makefile"
320 (("../libguile/libguile-[[:graph:]]+\\.la")
321 ;; Remove dependency on libguile-X.Y.la.
322 "")
323 (("^READLINE_LIBS = (.*)$" _ libs)
324 ;; Link against the provided libguile.
325 (string-append "READLINE_LIBS = "
326 "-lguile-$(GUILE_EFFECTIVE_VERSION) "
327 libs "\n"))
328 (("\\$\\(top_builddir\\)/meta/build-env")
329 ;; Use the provided Guile, not the one from
330 ;; $(builddir).
331 "")
332
333 ;; Install modules to the 'site' directories.
334 (("^moddir = .*$")
335 "moddir = $(pkgdatadir)/site/$(GUILE_EFFECTIVE_VERSION)\n")
336 (("^ccachedir = .*$")
337 "ccachedir = $(pkglibdir)/$(GUILE_EFFECTIVE_VERSION)/site-ccache\n"))
338
339 ;; Load 'guile-readline.so' from the right place.
340 (substitute* "ice-9/readline.scm"
341 (("load-extension \"guile-readline\"")
342 (format #f "load-extension \
343 (string-append ~s \"/lib/guile/\" (effective-version) \"/extensions/guile-readline\")"
344 (assoc-ref outputs "out"))))
345 #t)))))
346 (home-page (package-home-page guile))
347 (native-inputs (package-native-inputs guile))
348 (inputs
349 `(,@(package-inputs guile) ;to placate 'configure'
350 ,@(package-propagated-inputs guile)
351 ("guile" ,guile)
352 ("readline" ,readline)))
353 (synopsis "Line editing support for GNU Guile")
354 (description
355 "This module provides line editing support via the Readline library for
356 GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
357 @code{activate-readline} procedure to enable it.")
358 (license license:gpl3+)))
359
360 (define-public guile-readline
361 (make-guile-readline guile-2.2))
362
363 (define-public guile3.0-readline
364 (make-guile-readline guile-next "guile3.0-readline"))
365
366 (define (guile-variant-package-name prefix)
367 (lambda (name)
368 "Return NAME with PREFIX instead of \"guile-\", when applicable."
369 (if (string-prefix? "guile-" name)
370 (string-append prefix "-"
371 (string-drop name
372 (string-length "guile-")))
373 name)))
374
375 (define package-for-guile-2.0
376 ;; A procedure that rewrites the dependency tree of the given package to use
377 ;; GUILE-2.0 instead of GUILE-2.2.
378 (package-input-rewriting `((,guile-2.2 . ,guile-2.0))
379 (guile-variant-package-name "guile2.0")))
380
381 (define package-for-guile-2.2
382 (package-input-rewriting `((,guile-3.0 . ,guile-2.2))
383 (guile-variant-package-name "guile2.2")))
384
385 (define-syntax define-deprecated-guile3.0-package
386 (lambda (s)
387 "Define a deprecated package alias for \"guile3.0-something\"."
388 (syntax-case s ()
389 ((_ name)
390 (and (identifier? #'name)
391 (string-prefix? "guile3.0-" (symbol->string (syntax->datum
392 #'name))))
393 (let ((->guile (lambda (str)
394 (let ((base (string-drop str
395 (string-length "guile3.0-"))))
396 (string-append "guile-" base)))))
397 (with-syntax ((package-name (symbol->string (syntax->datum #'name)))
398 (package
399 (datum->syntax
400 #'name
401 (string->symbol
402 (->guile (symbol->string (syntax->datum #'name)))))))
403 #'(begin
404 (define-deprecated name package
405 (deprecated-package package-name package))
406 (export name))))))))
407
408 (define-public guile-for-guile-emacs
409 (package (inherit guile-2.2)
410 (name "guile-for-guile-emacs")
411 (version "20150510.d8d9a8d")
412 (source (origin
413 (method git-fetch)
414 (uri (git-reference
415 (url "git://git.hcoop.net/git/bpt/guile.git")
416 (commit "d8d9a8da05ec876acba81a559798eb5eeceb5a17")))
417 (file-name (string-append name "-" version "-checkout"))
418 (sha256
419 (base32
420 "00sprsshy16y8pxjy126hr2adqcvvzzz96hjyjwgg8swva1qh6b0"))))
421 (arguments
422 `(;; Tests aren't passing for now.
423 ;; Obviously we should re-enable this!
424 #:tests? #f
425 ,@(package-arguments guile-2.2)))
426 (native-inputs
427 `(("autoconf" ,autoconf)
428 ("automake" ,automake)
429 ("libtool" ,libtool)
430 ("flex" ,flex)
431 ("texinfo" ,texinfo)
432 ("gettext" ,gettext-minimal)
433 ,@(package-native-inputs guile-2.2)))
434 ;; Same as in guile-2.0
435 (native-search-paths
436 (list (search-path-specification
437 (variable "GUILE_LOAD_PATH")
438 (files '("share/guile/site/2.0")))
439 (search-path-specification
440 (variable "GUILE_LOAD_COMPILED_PATH")
441 (files '("lib/guile/2.0/site-ccache"
442 "share/guile/site/2.0")))))))
443
444 \f
445 ;;;
446 ;;; Extensions.
447 ;;;
448
449 (define-public guile-json-1
450 (package
451 (name "guile-json")
452 (version "1.2.0")
453 (home-page "https://github.com/aconchillo/guile-json")
454 (source (origin
455 (method url-fetch)
456 (uri (string-append "mirror://savannah/guile-json/guile-json-"
457 version ".tar.gz"))
458 (sha256
459 (base32
460 "15gnb84d7hpazqhskkf3g9z4r6knw54wfj4ch5270kakz1lp70c9"))))
461 (build-system gnu-build-system)
462 (native-inputs `(("pkg-config" ,pkg-config)
463 ("guile" ,guile-2.2)))
464 (inputs `(("guile" ,guile-2.2)))
465 (synopsis "JSON module for Guile")
466 (description
467 "Guile-JSON supports parsing and building JSON documents according to the
468 specification. These are the main features:
469
470 @itemize
471 @item Strictly complies to @uref{http://json.org, specification}.
472 @item Build JSON documents programmatically via macros.
473 @item Unicode support for strings.
474 @item Allows JSON pretty printing.
475 @end itemize\n")
476
477 ;; Version 1.2.0 switched to GPLv3+ (from LGPLv3+).
478 (license license:gpl3+)))
479
480 ;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
481 ;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
482 ;; 'guile-json-3'.
483 (define-deprecated guile-json guile-json-1)
484 (export guile-json)
485
486 (define-public guile2.0-json
487 (package-for-guile-2.0 guile-json-1))
488
489 (define-public guile-json-3
490 ;; This version is incompatible with 1.x; see the 'NEWS' file.
491 (package
492 (inherit guile-json-1)
493 (name "guile-json")
494 (version "3.2.0")
495 (source (origin
496 (method url-fetch)
497 (uri (string-append "mirror://savannah/guile-json/guile-json-"
498 version ".tar.gz"))
499 (sha256
500 (base32
501 "14m6b6g2maw0mkvfm4x63rqb54vgbpn1gcqs715ijw4bikfzlqfz"))))
502 (native-inputs `(("pkg-config" ,pkg-config)
503 ("guile" ,guile-3.0)))
504 (inputs `(("guile" ,guile-3.0)))))
505
506 (define-public guile2.2-json
507 (package-for-guile-2.2 guile-json-3))
508
509 (define-public guile3.0-json
510 (deprecated-package "guile3.0-json" guile-json-3))
511
512 ;; There are two guile-gdbm packages, one using the FFI and one with
513 ;; direct C bindings, hence the verbose name.
514
515 (define-public guile-gdbm-ffi
516 (package
517 (name "guile-gdbm-ffi")
518 (version "20120209.fa1d5b6")
519 (source (origin
520 (method git-fetch)
521 (uri (git-reference
522 (url "https://github.com/ijp/guile-gdbm.git")
523 (commit "fa1d5b6231d0e4d096687b378c025f2148c5f246")))
524 (file-name (string-append name "-" version "-checkout"))
525 (patches (search-patches
526 "guile-gdbm-ffi-support-gdbm-1.14.patch"))
527 (sha256
528 (base32
529 "1j8wrsw7v9w6qkl47xz0rdikg50v16nn6kbs3lgzcymjzpa7babj"))))
530 (build-system guile-build-system)
531 (arguments
532 '(#:phases (modify-phases %standard-phases
533 (add-after 'unpack 'move-examples
534 (lambda* (#:key outputs #:allow-other-keys)
535 ;; Move examples where they belong.
536 (let* ((out (assoc-ref outputs "out"))
537 (doc (string-append out "/share/doc/"
538 (strip-store-file-name out)
539 "/examples")))
540 (copy-recursively "examples" doc)
541 (delete-file-recursively "examples")
542 #t)))
543 (add-after 'unpack 'set-libgdbm-file-name
544 (lambda* (#:key inputs #:allow-other-keys)
545 (substitute* "gdbm.scm"
546 (("\\(dynamic-link \"libgdbm\"\\)")
547 (format #f "(dynamic-link \"~a/lib/libgdbm.so\")"
548 (assoc-ref inputs "gdbm"))))
549 #t)))))
550 (native-inputs
551 `(("guile" ,guile-3.0)))
552 (inputs
553 `(("gdbm" ,gdbm)))
554 (home-page "https://github.com/ijp/guile-gdbm")
555 (synopsis "Guile bindings to the GDBM library via Guile's FFI")
556 (description
557 "Guile bindings to the GDBM key-value storage system, using
558 Guile's foreign function interface.")
559 (license license:gpl3+)))
560
561 (define-public guile2.0-gdbm-ffi
562 (package-for-guile-2.0 guile-gdbm-ffi))
563
564 (define-public guile2.2-gdbm-ffi
565 (package-for-guile-2.2 guile-gdbm-ffi))
566
567 (define-deprecated-guile3.0-package guile3.0-gdbm-ffi)
568
569 (define-public guile-sqlite3
570 (package
571 (name "guile-sqlite3")
572 (version "0.1.0")
573 (home-page "https://notabug.org/guile-sqlite3/guile-sqlite3.git")
574 (source (origin
575 (method git-fetch)
576 (uri (git-reference
577 (url home-page)
578 (commit (string-append "v" version))))
579 (sha256
580 (base32
581 "1nv8j7wk6b5n4p22szyi8lv8fs31rrzxhzz16gyj8r38c1fyp9qp"))
582 (file-name (string-append name "-" version "-checkout"))
583 (patches
584 (search-patches "guile-sqlite3-fix-cross-compilation.patch"))
585 (modules '((guix build utils)))
586 (snippet
587 '(begin
588 ;; Allow builds with Guile 3.0.
589 (substitute* "configure.ac"
590 (("^GUILE_PKG.*")
591 "GUILE_PKG([3.0 2.2 2.0])\n"))
592 #t))))
593 (build-system gnu-build-system)
594 (native-inputs
595 `(("autoconf" ,autoconf)
596 ("automake" ,automake)
597 ("guile" ,guile-3.0)
598 ("pkg-config" ,pkg-config)))
599 (inputs
600 `(("guile" ,guile-3.0)
601 ("sqlite" ,sqlite)))
602 (synopsis "Access SQLite databases from Guile")
603 (description
604 "This package provides Guile bindings to the SQLite database system.")
605 (license license:gpl3+)))
606
607 (define-public guile2.0-sqlite3
608 (package-for-guile-2.0 guile-sqlite3))
609
610 (define-public guile2.2-sqlite3
611 (package-for-guile-2.2 guile-sqlite3))
612
613 (define-deprecated-guile3.0-package guile3.0-sqlite3)
614
615 (define-public guile-bytestructures
616 (package
617 (name "guile-bytestructures")
618 (version "1.0.7")
619 (home-page "https://github.com/TaylanUB/scheme-bytestructures")
620 (source (origin
621 (method git-fetch)
622 (uri (git-reference
623 (url home-page)
624 (commit (string-append "v" version))))
625 (file-name (git-file-name name version))
626 (sha256
627 (base32
628 "0q0habjiy3h9cigb7q1br9kz6z212dn2ab31f6dgd3rrmsfn5rvb"))))
629 (build-system gnu-build-system)
630 (arguments
631 `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
632
633 #:phases (modify-phases %standard-phases
634 (add-after 'install 'install-doc
635 (lambda* (#:key outputs #:allow-other-keys)
636 (let* ((out (assoc-ref outputs "out"))
637 (package ,(package-full-name this-package "-"))
638 (doc (string-append out "/share/doc/" package)))
639 (install-file "README.md" doc)
640 #t))))))
641 (native-inputs
642 `(("autoconf" ,autoconf)
643 ("automake" ,automake)
644 ("pkg-config" ,pkg-config)
645 ("guile" ,guile-3.0)))
646 (inputs
647 `(("guile" ,guile-3.0)))
648 (synopsis "Structured access to bytevector contents for Guile")
649 (description
650 "Guile bytestructures offers a system imitating the type system
651 of the C programming language, to be used on bytevectors. C's type
652 system works on raw memory, and Guile works on bytevectors which are
653 an abstraction over raw memory. It's also more powerful than the C
654 type system, elevating types to first-class status.")
655 (license license:gpl3+)
656 (properties '((upstream-name . "bytestructures")))))
657
658 (define-public guile2.0-bytestructures
659 (package-for-guile-2.0 guile-bytestructures))
660
661 (define-public guile2.2-bytestructures
662 (package-for-guile-2.2 guile-bytestructures))
663
664 (define-deprecated-guile3.0-package guile3.0-bytestructures)
665
666 (define-public guile-git
667 (package
668 (name "guile-git")
669 (version "0.3.0")
670 (home-page "https://gitlab.com/guile-git/guile-git.git")
671 (source (origin
672 (method url-fetch)
673 (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
674 "4c563d8e7e1ff84396abe8ca7011bcaf/guile-git-"
675 version ".tar.gz"))
676 (sha256
677 (base32
678 "0c5i3d16hp7gp9rd78vk9zc45js8bphf92m4lbb5gyi4l1yl7kkm"))))
679 (build-system gnu-build-system)
680 (native-inputs
681 `(("pkg-config" ,pkg-config)
682 ("guile" ,guile-3.0)
683 ("guile-bytestructures" ,guile-bytestructures)))
684 (inputs
685 `(("guile" ,guile-3.0)
686 ("libgit2" ,libgit2)))
687 (propagated-inputs
688 `(("guile-bytestructures" ,guile-bytestructures)))
689 (synopsis "Guile bindings for libgit2")
690 (description
691 "This package provides Guile bindings to libgit2, a library to
692 manipulate repositories of the Git version control system.")
693 (license license:gpl3+)))
694
695 (define-public guile2.2-git
696 (package-for-guile-2.2 guile-git))
697
698 (define-public guile2.0-git
699 (let ((base (package-for-guile-2.0 guile-git)))
700 (package
701 (inherit base)
702 ;; Libgit2's Guile test driver requires (ice-9 textual-ports), which is
703 ;; not in Guile 2.0. Thus, keep LIBGIT2 as-is here (i.e., built against
704 ;; Guile 2.2).
705 (inputs `(("libgit2" ,libgit2)
706 ,@(srfi-1:alist-delete "libgit2"
707 (package-inputs base)))))))
708
709 (define-deprecated-guile3.0-package guile3.0-git)
710
711 ;;; guile.scm ends here
712