gnu: Move numerous "inputs" which should be "native-inputs".
[jackhill/guix/guix.git] / gnu / packages / rdf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages rdf)
20 #:use-module ((guix licenses) #:select (lgpl2.0+ lgpl2.1+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system cmake)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages curl)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages qt)
29 #:use-module (gnu packages xml))
30
31 (define-public raptor2
32 (package
33 (name "raptor2")
34 (version "2.0.11")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "http://download.librdf.org/source/" name
38 "-" version ".tar.gz"))
39 (sha256
40 (base32
41 "1z3i4fs32wcq5y9l7gdn7262h6r0ppdpvx4gw6jgsym8z083w0xf"))))
42 (build-system gnu-build-system)
43 (inputs
44 `(("curl" ,curl)
45 ("libxml2" ,libxml2)
46 ("libxslt" ,libxslt)
47 ("zlib" ,zlib)))
48 (home-page "http://librdf.org/raptor/")
49 (synopsis "RDF syntax library")
50 (description "Raptor is a C library providing a set of parsers and
51 serialisers that generate Resource Description Framework (RDF) triples
52 by parsing syntaxes or serialise the triples into a syntax. The supported
53 parsing syntaxes are RDF/XML, N-Quads, N-Triples 1.0 and 1.1, TRiG,
54 Turtle 2008 and 2013, RDFa 1.0 and 1.1, RSS tag soup including all versions
55 of RSS, Atom 1.0 and 0.3, GRDDL and microformats for HTML, XHTML and
56 XML. The serialising syntaxes are RDF/XML (regular, abbreviated, XMP),
57 Turtle 2013, N-Quads, N-Triples 1.1, Atom 1.0, RSS 1.0, GraphViz DOT,
58 HTML and JSON.")
59 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
60
61 (define-public soprano
62 (package
63 (name "soprano")
64 (version "2.9.3")
65 ;; 2.9.4 requires clucene, see
66 ;; http://www.mailinglistarchive.com/html/lfs-book@linuxfromscratch.org/2013-10/msg00285.html
67 ;; The stable clucene-0.9.21b fails one of its tests;
68 ;; in the unstable clucene-2.3.3.4 the binary cl_test is not found.
69 ;; In any case, the library seems to be unmaintained.
70 (source (origin
71 (method url-fetch)
72 (uri (string-append "mirror://sourceforge/soprano/Soprano/"
73 version "/"
74 "soprano-" version ".tar.bz2"))
75 (sha256
76 (base32
77 "08gb5d8bgy7vc6qd6r1kkmmc5rli67dlglpjqjlahpnvs26r1cwl"))))
78 (build-system cmake-build-system)
79 ;; FIXME: Add optional dependencies: Raptor, Redland, odbci, clucene; doxygen
80 (inputs
81 `(("qt" ,qt-4)))
82 (native-inputs
83 `(("pkg-config" ,pkg-config)))
84 (home-page "http://soprano.sourceforge.net/")
85 (synopsis "RDF data library for Qt")
86 (description "Soprano (formerly known as QRDF) is a library which
87 provides a highly usable object-oriented C++/Qt4 framework for RDF data. It
88 uses different RDF storage solutions as backends through a simple plugin
89 system.")
90 (license lgpl2.0+)))