gnu: Move numerous "inputs" which should be "native-inputs".
[jackhill/guix/guix.git] / gnu / packages / ratpoison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ratpoison)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:select (gpl2+))
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages readline)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages fontutils))
29
30 (define-public ratpoison
31 (package
32 (name "ratpoison")
33 (version "1.4.6")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "0v4mh8d3vsh5xbbycfdl3g8zfygi1rkslh1x7k5hi1d05bfq3cdr"))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("libXi" ,libxi)
44 ("readline" ,readline)
45 ("xextproto" ,xextproto)
46 ("libXtst" ,libxtst)
47 ("freetype" ,freetype)
48 ("fontconfig" ,fontconfig)
49 ("libXft" ,libxft)
50 ("libXpm" ,libxpm)
51 ("libXt" ,libxt)
52 ("inputproto" ,inputproto)
53 ("libX11" ,libx11)))
54 (native-inputs
55 `(("perl" ,perl)
56 ("pkg-config" ,pkg-config)))
57 (home-page "http://www.nongnu.org/ratpoison/")
58 (synopsis "A simple mouse-free tiling window manager")
59 (description
60 "Ratpoison is a simple window manager with no fat library
61 dependencies, no fancy graphics, no window decorations, and no
62 rodent dependence. It is largely modelled after GNU Screen which
63 has done wonders in the virtual terminal market.
64
65 The screen can be split into non-overlapping frames. All windows
66 are kept maximized inside their frames to take full advantage of
67 your precious screen real estate.
68
69 All interaction with the window manager is done through keystrokes.
70 Ratpoison has a prefix map to minimize the key clobbering that
71 cripples Emacs and other quality pieces of software.")
72 (license gpl2+)))