gnu: Move numerous "inputs" which should be "native-inputs".
[jackhill/guix/guix.git] / gnu / packages / linux.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages linux)
21 #:use-module ((guix licenses)
22 #:hide (zlib))
23 #:use-module (gnu packages)
24 #:use-module ((gnu packages compression)
25 #:renamer (symbol-prefix-proc 'guix:))
26 #:use-module (gnu packages flex)
27 #:use-module (gnu packages bison)
28 #:use-module (gnu packages libusb)
29 #:use-module (gnu packages ncurses)
30 #:use-module (gnu packages bdb)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages algebra)
34 #:use-module (gnu packages gettext)
35 #:use-module (gnu packages pulseaudio)
36 #:use-module (gnu packages attr)
37 #:use-module (gnu packages xml)
38 #:use-module (gnu packages autotools)
39 #:use-module (guix packages)
40 #:use-module (guix download)
41 #:use-module (guix build-system gnu))
42
43 (define-public (system->linux-architecture arch)
44 "Return the Linux architecture name for ARCH, a Guix system name such as
45 \"x86_64-linux\"."
46 (let ((arch (car (string-split arch #\-))))
47 (cond ((string=? arch "i686") "i386")
48 ((string-prefix? "mips" arch) "mips")
49 ((string-prefix? "arm" arch) "arm")
50 (else arch))))
51
52 (define (linux-libre-urls version)
53 "Return a list of URLs for Linux-Libre VERSION."
54 (list (string-append
55 "http://linux-libre.fsfla.org/pub/linux-libre/releases/"
56 version "-gnu/linux-libre-" version "-gnu.tar.xz")
57
58 ;; XXX: Work around <http://bugs.gnu.org/14851>.
59 (string-append
60 "ftp://alpha.gnu.org/gnu/guix/mirror/linux-libre-"
61 version "-gnu.tar.xz")
62
63 ;; Maybe this URL will become valid eventually.
64 (string-append
65 "mirror://gnu/linux-libre/" version "-gnu/linux-libre-"
66 version "-gnu.tar.xz")))
67
68 (define-public linux-libre-headers
69 (let* ((version "3.3.8")
70 (build-phase
71 (lambda (arch)
72 `(lambda _
73 (setenv "ARCH" ,(system->linux-architecture arch))
74 (format #t "`ARCH' set to `~a'~%" (getenv "ARCH"))
75
76 (and (zero? (system* "make" "defconfig"))
77 (zero? (system* "make" "mrproper" "headers_check"))))))
78 (install-phase
79 `(lambda* (#:key outputs #:allow-other-keys)
80 (let ((out (assoc-ref outputs "out")))
81 (and (zero? (system* "make"
82 (string-append "INSTALL_HDR_PATH=" out)
83 "headers_install"))
84 (mkdir (string-append out "/include/config"))
85 (call-with-output-file
86 (string-append out
87 "/include/config/kernel.release")
88 (lambda (p)
89 (format p "~a-default~%" ,version))))))))
90 (package
91 (name "linux-libre-headers")
92 (version version)
93 (source (origin
94 (method url-fetch)
95 (uri (linux-libre-urls version))
96 (sha256
97 (base32
98 "0jkfh0z1s6izvdnc3njm39dhzp1cg8i06jv06izwqz9w9qsprvnl"))))
99 (build-system gnu-build-system)
100 (native-inputs `(("perl" ,perl)))
101 (arguments
102 `(#:modules ((guix build gnu-build-system)
103 (guix build utils)
104 (srfi srfi-1))
105 #:phases (alist-replace
106 'build ,(build-phase (or (%current-target-system)
107 (%current-system)))
108 (alist-replace
109 'install ,install-phase
110 (alist-delete 'configure %standard-phases)))
111 #:tests? #f))
112 (synopsis "GNU Linux-Libre kernel headers")
113 (description "Headers of the Linux-Libre kernel.")
114 (license gpl2)
115 (home-page "http://www.gnu.org/software/linux-libre/"))))
116
117 (define-public module-init-tools
118 (package
119 (name "module-init-tools")
120 (version "3.16")
121 (source (origin
122 (method url-fetch)
123 (uri (string-append
124 "mirror://kernel.org/linux/utils/kernel/module-init-tools/module-init-tools-"
125 version ".tar.bz2"))
126 (sha256
127 (base32
128 "0jxnz9ahfic79rp93l5wxcbgh4pkv85mwnjlbv1gz3jawv5cvwp1"))))
129 (build-system gnu-build-system)
130 (arguments
131 ;; FIXME: The upstream tarball lacks man pages, and building them would
132 ;; require DocBook & co. We used to use Gentoo's pre-built man pages,
133 ;; but they vanished. In the meantime, fake it.
134 '(#:phases (alist-cons-before
135 'configure 'fake-docbook
136 (lambda _
137 (substitute* "Makefile.in"
138 (("^DOCBOOKTOMAN.*$")
139 "DOCBOOKTOMAN = true\n")))
140 %standard-phases)))
141 (home-page "http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/")
142 (synopsis "Tools for loading and managing Linux kernel modules")
143 (description
144 "Tools for loading and managing Linux kernel modules, such as `modprobe',
145 `insmod', `lsmod', and more.")
146 (license gpl2+)))
147
148 (define-public linux-libre
149 (let* ((version "3.12")
150 (build-phase
151 '(lambda* (#:key system #:allow-other-keys #:rest args)
152 (let ((arch (car (string-split system #\-))))
153 (setenv "ARCH"
154 (cond ((string=? arch "i686") "i386")
155 (else arch)))
156 (format #t "`ARCH' set to `~a'~%" (getenv "ARCH")))
157
158 (let ((build (assoc-ref %standard-phases 'build)))
159 (and (zero? (system* "make" "defconfig"))
160 (begin
161 (format #t "enabling additional modules...~%")
162 (substitute* ".config"
163 (("^# CONFIG_CIFS.*$")
164 "CONFIG_CIFS=m\n"))
165 (zero? (system* "make" "oldconfig")))
166
167 ;; Call the default `build' phase so `-j' is correctly
168 ;; passed.
169 (apply build #:make-flags "all" args)))))
170 (install-phase
171 `(lambda* (#:key inputs outputs #:allow-other-keys)
172 (let* ((out (assoc-ref outputs "out"))
173 (moddir (string-append out "/lib/modules"))
174 (mit (assoc-ref inputs "module-init-tools")))
175 (mkdir-p moddir)
176 (for-each (lambda (file)
177 (copy-file file
178 (string-append out "/" (basename file))))
179 (find-files "." "^(bzImage|System\\.map)$"))
180 (copy-file ".config" (string-append out "/config"))
181 (zero? (system* "make"
182 (string-append "DEPMOD=" mit "/sbin/depmod")
183 (string-append "MODULE_DIR=" moddir)
184 (string-append "INSTALL_PATH=" out)
185 (string-append "INSTALL_MOD_PATH=" out)
186 "modules_install"))))))
187 (package
188 (name "linux-libre")
189 (version version)
190 (source (origin
191 (method url-fetch)
192 (uri (linux-libre-urls version))
193 (sha256
194 (base32
195 "0drjxm9h2k9bik2mhrqqqi6cm5rn2db647wf0zvb58xldj0zmhb6"))))
196 (build-system gnu-build-system)
197 (native-inputs `(("perl" ,perl)
198 ("bc" ,bc)
199 ("module-init-tools" ,module-init-tools)))
200 (arguments
201 `(#:modules ((guix build gnu-build-system)
202 (guix build utils)
203 (srfi srfi-1)
204 (ice-9 match))
205 #:phases (alist-replace
206 'build ,build-phase
207 (alist-replace
208 'install ,install-phase
209 (alist-delete 'configure %standard-phases)))
210 #:tests? #f))
211 (synopsis "100% free redistribution of a cleaned Linux kernel")
212 (description
213 "GNU Linux-Libre is a free (as in freedom) variant of the Linux kernel.
214 It has been modified to remove all non-free binary blobs.")
215 (license gpl2)
216 (home-page "http://www.gnu.org/software/linux-libre/"))))
217
218 \f
219 ;;;
220 ;;; Pluggable authentication modules (PAM).
221 ;;;
222
223 (define-public linux-pam
224 (package
225 (name "linux-pam")
226 (version "1.1.6")
227 (source
228 (origin
229 (method url-fetch)
230 (uri (list (string-append "http://www.linux-pam.org/library/Linux-PAM-"
231 version ".tar.bz2")
232 (string-append "mirror://kernel.org/linux/libs/pam/library/Linux-PAM-"
233 version ".tar.bz2")))
234 (sha256
235 (base32
236 "1hlz2kqvbjisvwyicdincq7nz897b9rrafyzccwzqiqg53b8gf5s"))))
237 (build-system gnu-build-system)
238 (native-inputs
239 `(("flex" ,flex)
240
241 ;; TODO: optional dependencies
242 ;; ("libxcrypt" ,libxcrypt)
243 ;; ("cracklib" ,cracklib)
244 ))
245 (arguments
246 '(;; Most users, such as `shadow', expect the headers to be under
247 ;; `security'.
248 #:configure-flags (list (string-append "--includedir="
249 (assoc-ref %outputs "out")
250 "/include/security"))
251
252 ;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
253 ;; isn't available.
254 #:tests? #f))
255 (home-page "http://www.linux-pam.org/")
256 (synopsis "Pluggable authentication modules for Linux")
257 (description
258 "A *Free* project to implement OSF's RFC 86.0.
259 Pluggable authentication modules are small shared object files that can
260 be used through the PAM API to perform tasks, like authenticating a user
261 at login. Local and dynamic reconfiguration are its key features")
262 (license bsd-3)))
263
264 \f
265 ;;;
266 ;;; Miscellaneous.
267 ;;;
268
269 (define-public psmisc
270 (package
271 (name "psmisc")
272 (version "22.20")
273 (source
274 (origin
275 (method url-fetch)
276 (uri (string-append "mirror://sourceforge/psmisc/psmisc/psmisc-"
277 version ".tar.gz"))
278 (sha256
279 (base32
280 "052mfraykmxnavpi8s78aljx8w87hyvpx8mvzsgpjsjz73i28wmi"))))
281 (build-system gnu-build-system)
282 (inputs `(("ncurses" ,ncurses)))
283 (home-page "http://psmisc.sourceforge.net/")
284 (synopsis
285 "set of utilities that use the proc filesystem, such as fuser, killall, and pstree")
286 (description
287 "This PSmisc package is a set of some small useful utilities that
288 use the proc filesystem. We're not about changing the world, but
289 providing the system administrator with some help in common tasks.")
290 (license gpl2+)))
291
292 (define-public util-linux
293 (package
294 (name "util-linux")
295 (version "2.21")
296 (source
297 (origin
298 (method url-fetch)
299 (uri (string-append "mirror://kernel.org/linux/utils/"
300 name "/v" version "/"
301 name "-" version ".2" ".tar.xz"))
302 (sha256
303 (base32
304 "1rpgghf7n0zx0cdy8hibr41wvkm2qp1yvd8ab1rxr193l1jmgcir"))))
305 (build-system gnu-build-system)
306 (arguments
307 `(#:configure-flags '("--disable-use-tty-group")
308 #:phases (alist-cons-after
309 'install 'patch-chkdupexe
310 (lambda* (#:key outputs #:allow-other-keys)
311 (let ((out (assoc-ref outputs "out")))
312 (substitute* (string-append out "/bin/chkdupexe")
313 ;; Allow 'patch-shebang' to do its work.
314 (("@PERL@") "/bin/perl"))))
315 %standard-phases)))
316 (inputs `(("zlib" ,guix:zlib)
317 ("ncurses" ,ncurses)))
318 (native-inputs
319 `(("perl" ,perl)))
320 (home-page "https://www.kernel.org/pub/linux/utils/util-linux/")
321 (synopsis "Collection of utilities for the Linux kernel")
322 (description
323 "util-linux is a random collection of utilities for the Linux kernel.")
324
325 ;; Note that util-linux doesn't use the same license for all the
326 ;; code. GPLv2+ is the default license for a code without an
327 ;; explicitly defined license.
328 (license (list gpl3+ gpl2+ gpl2 lgpl2.0+
329 bsd-4 public-domain))))
330
331 (define-public procps
332 (package
333 (name "procps")
334 (version "3.2.8")
335 (source (origin
336 (method url-fetch)
337 (uri (string-append "http://procps.sourceforge.net/procps-"
338 version ".tar.gz"))
339 (sha256
340 (base32
341 "0d8mki0q4yamnkk4533kx8mc0jd879573srxhg6r2fs3lkc6iv8i"))
342 (patches (list (search-patch "procps-make-3.82.patch")))))
343 (build-system gnu-build-system)
344 (inputs `(("ncurses" ,ncurses)))
345 (arguments
346 '(#:phases (alist-replace
347 'configure
348 (lambda* (#:key outputs #:allow-other-keys)
349 ;; No `configure', just a single Makefile.
350 (let ((out (assoc-ref outputs "out")))
351 (substitute* "Makefile"
352 (("/usr/") "/")
353 (("--(owner|group) 0") "")
354 (("ldconfig") "true")
355 (("^LDFLAGS[[:blank:]]*:=(.*)$" _ value)
356 ;; Add libproc to the RPATH.
357 (string-append "LDFLAGS := -Wl,-rpath="
358 out "/lib" value))))
359 (setenv "CC" "gcc"))
360 (alist-replace
361 'install
362 (lambda* (#:key outputs #:allow-other-keys)
363 (let ((out (assoc-ref outputs "out")))
364 (and (zero?
365 (system* "make" "install"
366 (string-append "DESTDIR=" out)))
367
368 ;; Sanity check.
369 (zero?
370 (system* (string-append out "/bin/ps")
371 "--version")))))
372 %standard-phases))
373
374 ;; What did you expect? Tests?
375 #:tests? #f))
376 (home-page "http://procps.sourceforge.net/")
377 (synopsis "Utilities that give information about processes")
378 (description
379 "procps is the package that has a bunch of small useful utilities
380 that give information about processes using the Linux /proc file system.
381 The package includes the programs ps, top, vmstat, w, kill, free,
382 slabtop, and skill.")
383 (license gpl2)))
384
385 (define-public usbutils
386 (package
387 (name "usbutils")
388 (version "006")
389 (source
390 (origin
391 (method url-fetch)
392 (uri (string-append "mirror://kernel.org/linux/utils/usb/usbutils/"
393 "usbutils-" version ".tar.xz"))
394 (sha256
395 (base32
396 "03pd57vv8c6x0hgjqcbrxnzi14h8hcghmapg89p8k5zpwpkvbdfr"))))
397 (build-system gnu-build-system)
398 (inputs
399 `(("libusb" ,libusb)))
400 (native-inputs
401 `(("pkg-config" ,pkg-config)))
402 (home-page "http://www.linux-usb.org/")
403 (synopsis
404 "Tools for working with USB devices, such as lsusb")
405 (description
406 "Tools for working with USB devices, such as lsusb.")
407 (license gpl2+)))
408
409 (define-public e2fsprogs
410 (package
411 (name "e2fsprogs")
412 (version "1.42.7")
413 (source (origin
414 (method url-fetch)
415 (uri (string-append "mirror://sourceforge/e2fsprogs/e2fsprogs-"
416 version ".tar.gz"))
417 (sha256
418 (base32
419 "0ibkkvp6kan0hn0d1anq4n2md70j5gcm7mwna515w82xwyr02rfw"))))
420 (build-system gnu-build-system)
421 (inputs `(("util-linux" ,util-linux)))
422 (native-inputs `(("pkg-config" ,pkg-config)))
423 (arguments
424 '(#:phases (alist-cons-before
425 'configure 'patch-shells
426 (lambda _
427 (substitute* "configure"
428 (("/bin/sh (.*)parse-types.sh" _ dir)
429 (string-append (which "sh") " " dir
430 "parse-types.sh")))
431 (substitute* (find-files "." "^Makefile.in$")
432 (("#!/bin/sh")
433 (string-append "#!" (which "sh")))))
434 %standard-phases)
435
436 ;; FIXME: Tests work by comparing the stdout/stderr of programs, that
437 ;; they fail because we get an extra line that says "Can't check if
438 ;; filesystem is mounted due to missing mtab file".
439 #:tests? #f))
440 (home-page "http://e2fsprogs.sourceforge.net/")
441 (synopsis "Creating and checking ext2/ext3/ext4 file systems")
442 (description
443 "This package provides tools for manipulating ext2/ext3/ext4 file systems.")
444 (license (list gpl2 ; programs
445 lgpl2.0 ; libext2fs
446 x11)))) ; libuuid
447
448 (define-public strace
449 (package
450 (name "strace")
451 (version "4.7")
452 (source (origin
453 (method url-fetch)
454 (uri (string-append "mirror://sourceforge/strace/strace-"
455 version ".tar.xz"))
456 (sha256
457 (base32
458 "158iwk0pl2mfw93m1843xb7a2zb8p6lh0qim07rca6f1ff4dk764"))))
459 (build-system gnu-build-system)
460 (native-inputs `(("perl" ,perl)))
461 (home-page "http://strace.sourceforge.net/")
462 (synopsis "System call tracer for Linux")
463 (description
464 "strace is a system call tracer, i.e. a debugging tool which prints out a
465 trace of all the system calls made by a another process/program.")
466 (license bsd-3)))
467
468 (define-public alsa-lib
469 (package
470 (name "alsa-lib")
471 (version "1.0.27.1")
472 (source (origin
473 (method url-fetch)
474 (uri (string-append
475 "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-"
476 version ".tar.bz2"))
477 (sha256
478 (base32
479 "0fx057746dj7rjdi0jnvx2m9b0y1lgdkh1hks87d8w32xyihf3k9"))
480 (patches (list (search-patch "alsa-lib-mips-atomic-fix.patch")))))
481 (build-system gnu-build-system)
482 (home-page "http://www.alsa-project.org/")
483 (synopsis "The Advanced Linux Sound Architecture libraries")
484 (description
485 "The Advanced Linux Sound Architecture (ALSA) provides audio and
486 MIDI functionality to the Linux-based operating system.")
487 (license lgpl2.1+)))
488
489 (define-public alsa-utils
490 (package
491 (name "alsa-utils")
492 (version "1.0.27.2")
493 (source (origin
494 (method url-fetch)
495 (uri (string-append "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-"
496 version ".tar.bz2"))
497 (sha256
498 (base32
499 "1sjjngnq50jv5ilwsb4zys6smifni3bd6fn28gbnhfrg14wsrgq2"))))
500 (build-system gnu-build-system)
501 (arguments
502 ;; XXX: Disable man page creation until we have DocBook.
503 '(#:configure-flags (list "--disable-xmlto"
504 (string-append "--with-udev-rules-dir="
505 (assoc-ref %outputs "out")
506 "/lib/udev/rules.d"))
507 #:phases (alist-cons-before
508 'install 'pre-install
509 (lambda _
510 ;; Don't try to mkdir /var/lib/alsa.
511 (substitute* "Makefile"
512 (("\\$\\(MKDIR_P\\) .*ASOUND_STATE_DIR.*")
513 "true\n")))
514 %standard-phases)))
515 (inputs
516 `(("libsamplerate" ,libsamplerate)
517 ("ncurses" ,ncurses)
518 ("alsa-lib" ,alsa-lib)
519 ("xmlto" ,xmlto)
520 ("gettext" ,gnu-gettext)))
521 (home-page "http://www.alsa-project.org/")
522 (synopsis "Utilities for the Advanced Linux Sound Architecture (ALSA)")
523 (description
524 "The Advanced Linux Sound Architecture (ALSA) provides audio and
525 MIDI functionality to the Linux-based operating system.")
526
527 ;; This is mostly GPLv2+ but a few files such as 'alsactl.c' are
528 ;; GPLv2-only.
529 (license gpl2)))
530
531 (define-public iptables
532 (package
533 (name "iptables")
534 (version "1.4.16.2")
535 (source (origin
536 (method url-fetch)
537 (uri (string-append
538 "http://www.netfilter.org/projects/iptables/files/iptables-"
539 version ".tar.bz2"))
540 (sha256
541 (base32
542 "0vkg5lzkn4l3i1sm6v3x96zzvnv9g7mi0qgj6279ld383mzcws24"))))
543 (build-system gnu-build-system)
544 (arguments '(#:tests? #f)) ; no test suite
545 (home-page "http://www.netfilter.org/projects/iptables/index.html")
546 (synopsis "Program to configure the Linux IP packet filtering rules")
547 (description
548 "iptables is the userspace command line program used to configure the
549 Linux 2.4.x and later IPv4 packet filtering ruleset. It is targeted towards
550 system administrators. Since Network Address Translation is also configured
551 from the packet filter ruleset, iptables is used for this, too. The iptables
552 package also includes ip6tables. ip6tables is used for configuring the IPv6
553 packet filter.")
554 (license gpl2+)))
555
556 (define-public iproute
557 (package
558 (name "iproute2")
559 (version "3.12.0")
560 (source (origin
561 (method url-fetch)
562 (uri (string-append
563 "mirror://kernel.org/linux/utils/net/iproute2/iproute2-"
564 version ".tar.xz"))
565 (sha256
566 (base32
567 "04gi11gh087bg2nlxhj0lxrk8l9qxkpr88nsiil23917bm3h1xj4"))))
568 (build-system gnu-build-system)
569 (arguments
570 `(#:tests? #f ; no test suite
571 #:make-flags (let ((out (assoc-ref %outputs "out")))
572 (list "DESTDIR="
573 (string-append "LIBDIR=" out "/lib")
574 (string-append "SBINDIR=" out "/sbin")
575 (string-append "CONFDIR=" out "/etc")
576 (string-append "DOCDIR=" out "/share/doc/"
577 ,name "-" ,version)
578 (string-append "MANDIR=" out "/share/man")))
579 #:phases (alist-cons-before
580 'install 'pre-install
581 (lambda _
582 ;; Don't attempt to create /var/lib/arpd.
583 (substitute* "Makefile"
584 (("^.*ARPDDIR.*$") "")))
585 %standard-phases)))
586 (inputs
587 `(("iptables" ,iptables)
588 ("db4" ,bdb)))
589 (native-inputs
590 `(("pkg-config" ,pkg-config)
591 ("flex" ,flex)
592 ("bison" ,bison)))
593 (home-page
594 "http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2")
595 (synopsis
596 "A collection of utilities for controlling TCP/IP networking and traffic control in Linux")
597 (description
598 "Iproute2 is a collection of utilities for controlling TCP/IP
599 networking and traffic with the Linux kernel.
600
601 Most network configuration manuals still refer to ifconfig and route as the
602 primary network configuration tools, but ifconfig is known to behave
603 inadequately in modern network environments. They should be deprecated, but
604 most distros still include them. Most network configuration systems make use
605 of ifconfig and thus provide a limited feature set. The /etc/net project aims
606 to support most modern network technologies, as it doesn't use ifconfig and
607 allows a system administrator to make use of all iproute2 features, including
608 traffic control.
609
610 iproute2 is usually shipped in a package called iproute or iproute2 and
611 consists of several tools, of which the most important are ip and tc. ip
612 controls IPv4 and IPv6 configuration and tc stands for traffic control. Both
613 tools print detailed usage messages and are accompanied by a set of
614 manpages.")
615 (license gpl2+)))
616
617 (define-public net-tools
618 ;; XXX: This package is basically unmaintained, but it provides a few
619 ;; commands not yet provided by Inetutils, such as 'route', so we have to
620 ;; live with it.
621 (package
622 (name "net-tools")
623 (version "1.60")
624 (home-page "http://www.tazenda.demon.co.uk/phil/net-tools/")
625 (source (origin
626 (method url-fetch)
627 (uri (string-append home-page "/" name "-"
628 version ".tar.bz2"))
629 (sha256
630 (base32
631 "0yvxrzk0mzmspr7sa34hm1anw6sif39gyn85w4c5ywfn8inxvr3s"))))
632 (build-system gnu-build-system)
633 (arguments
634 '(#:phases (alist-cons-after
635 'unpack 'patch
636 (lambda* (#:key inputs #:allow-other-keys)
637 (define (apply-patch file)
638 (zero? (system* "patch" "-p1" "--batch"
639 "--input" file)))
640
641 (let ((patch.gz (assoc-ref inputs "patch")))
642 (format #t "applying Debian patch set '~a'...~%"
643 patch.gz)
644 (system (string-append "gunzip < " patch.gz " > the-patch"))
645 (pk 'here)
646 (and (apply-patch "the-patch")
647 (for-each apply-patch
648 (find-files "debian/patches"
649 "\\.patch")))))
650 (alist-replace
651 'configure
652 (lambda* (#:key outputs #:allow-other-keys)
653 (let ((out (assoc-ref outputs "out")))
654 (mkdir-p (string-append out "/bin"))
655 (mkdir-p (string-append out "/sbin"))
656
657 ;; Pretend we have everything...
658 (system "yes | make config")
659
660 ;; ... except we don't have libdnet, so remove that
661 ;; definition.
662 (substitute* '("config.make" "config.h")
663 (("^.*HAVE_AFDECnet.*$") ""))))
664 %standard-phases))
665
666 ;; Binaries that depend on libnet-tools.a don't declare that
667 ;; dependency, making it parallel-unsafe.
668 #:parallel-build? #f
669
670 #:tests? #f ; no test suite
671 #:make-flags (list "CC=gcc"
672 (string-append "BASEDIR="
673 (assoc-ref %outputs "out")))))
674
675 ;; Use the big Debian patch set (the thing does not even compile out of
676 ;; the box.)
677 (inputs `(("patch" ,(origin
678 (method url-fetch)
679 (uri
680 "http://ftp.de.debian.org/debian/pool/main/n/net-tools/net-tools_1.60-24.2.diff.gz")
681 (sha256
682 (base32
683 "0p93lsqx23v5fv4hpbrydmfvw1ha2rgqpn2zqbs2jhxkzhjc030p"))))))
684 (native-inputs `(("gettext" ,gnu-gettext)))
685
686 (synopsis "Tools for controlling the network subsystem in Linux")
687 (description
688 "This package includes the important tools for controlling the network
689 subsystem of the Linux kernel. This includes arp, hostname, ifconfig,
690 netstat, rarp and route. Additionally, this package contains utilities
691 relating to particular network hardware types (plipconfig, slattach) and
692 advanced aspects of IP configuration (iptunnel, ipmaddr).")
693 (license gpl2+)))
694
695 (define-public libcap
696 (package
697 (name "libcap")
698 (version "2.22")
699 (source (origin
700 (method url-fetch)
701
702 ;; Tarballs used to be available from
703 ;; <https://www.kernel.org/pub/linux/libs/security/linux-privs/>
704 ;; but they never came back after kernel.org was compromised.
705 (uri (string-append
706 "mirror://debian/pool/main/libc/libcap2/libcap2_"
707 version ".orig.tar.gz"))
708 (sha256
709 (base32
710 "07vjhkznm82p8dm4w6j8mmg7h5c70lp5s9bwwfdmgwpbixfydjp1"))))
711 (build-system gnu-build-system)
712 (arguments '(#:phases (alist-delete 'configure %standard-phases)
713 #:tests? #f ; no 'check' target
714 #:make-flags (list "lib=lib"
715 (string-append "prefix="
716 (assoc-ref %outputs "out"))
717 "RAISE_SETFCAP=no")))
718 (native-inputs `(("perl" ,perl)))
719 (inputs `(("attr" ,attr)))
720 (home-page "https://sites.google.com/site/fullycapable/")
721 (synopsis "Library for working with POSIX capabilities")
722 (description
723 "libcap2 provides a programming interface to POSIX capabilities on
724 Linux-based operating systems.")
725
726 ;; License is BSD-3 or GPLv2, at the user's choice.
727 (license gpl2)))
728
729 (define-public bridge-utils
730 (package
731 (name "bridge-utils")
732 (version "1.5")
733 (source (origin
734 (method url-fetch)
735 (uri (string-append "mirror://sourceforge/bridge/bridge-utils-"
736 version ".tar.gz"))
737 (sha256
738 (base32
739 "12367cwqmi0yqphi6j8rkx97q8hw52yq2fx4k0xfclkcizxybya2"))))
740 (build-system gnu-build-system)
741
742 ;; The tarball lacks all the generated files.
743 (native-inputs `(("autoconf" ,autoconf)
744 ("automake" ,automake)))
745 (arguments
746 '(#:phases (alist-cons-before
747 'configure 'bootstrap
748 (lambda _
749 (zero? (system* "autoreconf" "-vf")))
750 %standard-phases)
751 #:tests? #f)) ; no 'check' target
752
753 (home-page
754 "http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge")
755 (synopsis "Manipulate Ethernet bridges")
756 (description
757 "Utilities for Linux's Ethernet bridging facilities. A bridge is a way
758 to connect two Ethernet segments together in a protocol independent way.
759 Packets are forwarded based on Ethernet address, rather than IP address (like
760 a router). Since forwarding is done at Layer 2, all protocols can go
761 transparently through a bridge.")
762 (license gpl2+)))
763
764 (define-public libnl
765 (package
766 (name "libnl")
767 (version "3.2.13")
768 (source (origin
769 (method url-fetch)
770 (uri (string-append
771 "http://www.infradead.org/~tgr/libnl/files/libnl-"
772 version ".tar.gz"))
773 (sha256
774 (base32
775 "1ydw42lsd572qwrfgws97n76hyvjdpanwrxm03lysnhfxkna1ssd"))))
776 (build-system gnu-build-system)
777 (native-inputs `(("flex" ,flex) ("bison" ,bison)))
778 (home-page "http://www.infradead.org/~tgr/libnl/")
779 (synopsis "NetLink protocol library suite")
780 (description
781 "The libnl suite is a collection of libraries providing APIs to netlink
782 protocol based Linux kernel interfaces. Netlink is an IPC mechanism primarly
783 between the kernel and user space processes. It was designed to be a more
784 flexible successor to ioctl to provide mainly networking related kernel
785 configuration and monitoring interfaces.")
786
787 ;; Most files are LGPLv2.1-only, but some are GPLv2-only (like
788 ;; 'nl-addr-add.c'), so the result is GPLv2-only.
789 (license gpl2)))
790
791 (define-public powertop
792 (package
793 (name "powertop")
794 (version "2.5")
795 (source
796 (origin
797 (method url-fetch)
798 (uri (string-append
799 "https://01.org/powertop/sites/default/files/downloads/powertop-"
800 version ".tar.gz"))
801 (sha256
802 (base32
803 "02rwqbpasdayl201v0549gbp2f82rd0hqiv3i111r7npanjhhb4b"))))
804 (build-system gnu-build-system)
805 (inputs
806 ;; TODO: Add pciutils.
807 `(("zlib" ,guix:zlib)
808 ;; ("pciutils" ,pciutils)
809 ("ncurses" ,ncurses)
810 ("libnl" ,libnl)))
811 (native-inputs
812 `(("pkg-config" ,pkg-config)))
813 (home-page "https://01.org/powertop/")
814 (synopsis "Analyze power consumption on Intel-based laptops")
815 (description
816 "PowerTOP is a Linux tool to diagnose issues with power consumption and
817 power management. In addition to being a diagnostic tool, PowerTOP also has
818 an interactive mode where the user can experiment various power management
819 settings for cases where the operating system has not enabled these
820 settings.")
821 (license gpl2)))