gnu: Move numerous "inputs" which should be "native-inputs".
[jackhill/guix/guix.git] / gnu / packages / libcanberra.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libcanberra)
20 #:use-module ((guix licenses) #:select (lgpl2.1+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages autotools)
25 #:use-module (gnu packages gstreamer)
26 #:use-module (gnu packages gtk)
27 #:use-module (gnu packages linux)
28 #:use-module (gnu packages oggvorbis)
29 #:use-module (gnu packages pkg-config))
30
31 (define-public libcanberra
32 (package
33 (name "libcanberra")
34 (version "0.30")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "http://0pointer.de/lennart/projects/libcanberra/libcanberra-"
39 version ".tar.xz"))
40 (sha256
41 (base32
42 "0wps39h8rx2b00vyvkia5j40fkak3dpipp1kzilqla0cgvk73dn2"))))
43 (build-system gnu-build-system)
44 (inputs
45 ;; FIXME: Add optional inputs udev and pulse.
46 `(("alsa-lib" ,alsa-lib)
47 ("gstreamer" ,gstreamer)
48 ("gtk+" ,gtk+)
49 ("libtool" ,libtool)
50 ("libvorbis" ,libvorbis)))
51 (native-inputs
52 `(("pkg-config" ,pkg-config)))
53 (home-page "http://0pointer.de/lennart/projects/libcanberra/")
54 (synopsis
55 "Implementation of the XDG Sound Theme and Name Specifications")
56 (description
57 "Libcanberra is an implementation of the XDG Sound Theme and Name
58 Specifications, for generating event sounds on free desktops, such as
59 GNOME. It comes with several backends (ALSA, PulseAudio, OSS, GStreamer,
60 null) and is designed to be portable.")
61 (license lgpl2.1+)))