gnu: Move numerous "inputs" which should be "native-inputs".
[jackhill/guix/guix.git] / gnu / packages / gdb.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gdb)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages ncurses)
22 #:use-module (gnu packages readline)
23 #:use-module (gnu packages dejagnu)
24 #:use-module (gnu packages texinfo)
25 #:use-module (gnu packages multiprecision)
26 #:use-module (gnu packages xml)
27 #:use-module (gnu packages python)
28 #:use-module ((guix licenses) #:select (gpl3+))
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix build-system gnu))
32
33 (define-public gdb
34 (package
35 (name "gdb")
36 (version "7.6.2")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/gdb/gdb-"
40 version ".tar.bz2"))
41 (sha256
42 (base32
43 "1s6hjqmq7xz10hqx45dgrpfh5mla578shn3zxgnrsv66w4n0wsig"))
44 (patches (list (search-patch "gdb-loongson-madd-fix.patch")))))
45 (build-system gnu-build-system)
46 (arguments
47 '(#:phases (alist-cons-after
48 'configure 'post-configure
49 (lambda _
50 (for-each patch-makefile-SHELL
51 (find-files "." "Makefile\\.in")))
52 %standard-phases)))
53 (inputs
54 `(("expat" ,expat)
55 ("mpfr" ,mpfr)
56 ("gmp" ,gmp)
57 ("readline" ,readline)
58 ("ncurses" ,ncurses)
59 ("python" ,python-wrapper)
60 ("dejagnu" ,dejagnu)))
61 (native-inputs
62 `(("texinfo" ,texinfo)))
63 (home-page "http://www.gnu.org/software/gdb/")
64 (synopsis "The GNU debugger")
65 (description
66 "GDB is the GNU debugger. With it, you can monitor what a program is
67 doing while it runs or what it was doing just before a crash. It allows you
68 to specify the runtime conditions, to define breakpoints, and to change how
69 the program is running to try to fix bugs. It can be used to debug programs
70 written in C, C++, Ada, Objective-C, Pascal and more.")
71 (license gpl3+)))