gnu: Move numerous "inputs" which should be "native-inputs".
[jackhill/guix/guix.git] / gnu / packages / curl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages curl)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages gnutls)
27 #:use-module (gnu packages groff)
28 #:use-module (gnu packages gsasl)
29 #:use-module (gnu packages libidn)
30 #:use-module (gnu packages openldap)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages ssh))
34
35 (define-public curl
36 (package
37 (name "curl")
38 (version "7.28.1")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append "http://curl.haxx.se/download/curl-"
42 version ".tar.lzma"))
43 (sha256
44 (base32
45 "13bhfs41yf60ys2hrikqxjwfzaj0gm91kqzsgc5fr4grzmpm38nx"))))
46 (build-system gnu-build-system)
47 (inputs `(("gnutls" ,gnutls)
48 ("gss" ,gss)
49 ("libidn" ,libidn)
50 ("libssh2" ,libssh2)
51 ("openldap" ,openldap)
52 ("zlib" ,zlib)))
53 (native-inputs
54 `(("perl" ,perl)
55 ;; to enable the --manual option and make test 1026 pass
56 ("groff" ,groff)
57 ("pkg-config" ,pkg-config)))
58 (arguments
59 `(#:configure-flags '("--with-gnutls" "--with-gssapi")))
60 (synopsis "curl, command line tool for transferring data with URL syntax")
61 (description
62 "curl is a command line tool for transferring data with URL syntax,
63 supporting DICT, FILE, FTP, FTPS, Gopher, HTTP, HTTPS, IMAP, IMAPS, LDAP,
64 LDAPS, POP3, POP3S, RTMP, RTSP, SCP, SFTP, SMTP, SMTPS, Telnet and TFTP.
65 curl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading,
66 HTTP form based upload, proxies, cookies, user+password authentication
67 (Basic, Digest, NTLM, Negotiate, kerberos...), file transfer resume,
68 proxy tunneling, and so on")
69 (license (license:bsd-style "file://COPYING"
70 "See COPYING in the distribution."))
71 (home-page "http://curl.haxx.se/")))