Merge branch 'master' into 'core-updates'.
[jackhill/guix/guix.git] / gnu / packages / tre.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright 2014 John Darrington
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages tre)
20 #:use-module (gnu packages)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix licenses))
25
26 (define-public tre
27 (package
28 (name "tre")
29 (version "0.8.0")
30 (source
31 (origin
32 (method url-fetch)
33 (uri
34 (string-append "http://laurikari.net/tre/" name "-" version
35 ".tar.bz2"))
36 (sha256
37 (base32 "0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
38
39 (build-system gnu-build-system)
40 (synopsis "Approximate regex matching library and agrep utility")
41 (description "Superset of the POSIX regex API, enabling approximate
42 matching. Also ships a version of the agrep utility which behaves similar to
43 grep but features ineaxct matching.")
44 (home-page "http://laurikari.net/tre")
45 (license bsd-2)))