gnu: libedit: Use HTTPS for home page.
[jackhill/guix/guix.git] / gnu / packages / libedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
3 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libedit)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages ncurses))
26
27 (define-public libedit
28 (package
29 (name "libedit")
30 (version "20150325-3.1")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "http://thrysoee.dk/editline"
35 "/" name "-" version ".tar.gz"))
36 (sha256
37 (base32
38 "1if8zi9h52m80ck796an28rrqfljk2n8cn25m3fl0prwz155x2n8"))))
39 (build-system gnu-build-system)
40 (arguments `(#:configure-flags (list "--enable-widec")))
41 (inputs
42 `(("ncurses" ,ncurses)))
43 (home-page "https://thrysoee.dk/editline/")
44 (synopsis "NetBSD Editline library")
45 (description
46 "This is an autotool- and libtoolized port of the NetBSD Editline
47 library (libedit). This Berkeley-style licensed command line editor library
48 provides generic line editing, history, and tokenization functions, similar to
49 those found in GNU Readline.")
50 (license bsd-3)))
51
52 ;;; libedit.scm ends here