gnu: ruby-listen: Update to 3.1.5.
[jackhill/guix/guix.git] / gnu / packages / rails.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages rails)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (gnu packages ruby)
24 #:use-module (guix build-system ruby))
25
26 (define-public ruby-spring
27 (package
28 (name "ruby-spring")
29 (version "1.7.2")
30 (source
31 (origin
32 (method url-fetch)
33 (uri
34 (string-append "https://github.com/rails/spring/archive/v"
35 version ".tar.gz"))
36 (file-name (string-append name "-" version ".tar.gz"))
37 (sha256
38 (base32
39 "1dd58y0cpsm2izj74yscn0ybfygmgcbbfdw1891g7cq41aai4b35"))))
40 (build-system ruby-build-system)
41 (arguments
42 `(#:test-target "test:unit"
43 #:phases
44 (modify-phases %standard-phases
45 (add-before 'check 'remove-bump
46 (lambda _
47 (substitute* "spring.gemspec"
48 (("gem.add_development_dependency 'bump'") "")
49 (("gem.add_development_dependency 'activesupport'.*")
50 "gem.add_development_dependency 'activesupport'\n"))
51 (substitute* "Rakefile"
52 (("require \\\"bump/tasks\\\"") ""))
53 #t)))))
54 (native-inputs
55 `(("bundler" ,bundler)
56 ("ruby-activesupport" ,ruby-activesupport)))
57 (synopsis "Ruby on Rails application preloader")
58 (description
59 "Spring is a Ruby on Rails application preloader. It speeds up
60 development by keeping your application running in the background so the
61 application does need to boot it every time you run a test, rake task or
62 migration.")
63 (home-page "https://github.com/rails/spring")
64 (license license:expat)))
65
66 (define-public ruby-debug-inspector
67 (package
68 (name "ruby-debug-inspector")
69 (version "0.0.2")
70 (source
71 (origin
72 (method url-fetch)
73 (uri (rubygems-uri "debug_inspector" version))
74 (sha256
75 (base32
76 "109761g00dbrw5q0dfnbqg8blfm699z4jj70l4zrgf9mzn7ii50m"))))
77 (build-system ruby-build-system)
78 (arguments
79 `(#:phases
80 (modify-phases %standard-phases
81 (replace 'check
82 (lambda _
83 (and
84 (zero? (system* "rake" "compile"))
85 (zero?
86 (system*
87 "ruby" "-Ilib" "-e"
88 (string-append
89 "require 'debug_inspector'; RubyVM::DebugInspector."
90 "open{|dc| p dc.backtrace_locations}")))))))))
91 (synopsis "Ruby wrapper for the MRI 2.0 debug_inspector API")
92 (description
93 "This package provides a Ruby wrapper for the MRI 2.0 debug_inspector
94 API.")
95 (home-page
96 "https://github.com/banister/debug_inspector")
97 (license license:expat)))