gnu: java: Use HTTPS for osgi.org home pages.
[jackhill/guix/guix.git] / gnu / packages / nickle.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages nickle)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages readline)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix download)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages))
26
27 (define-public nickle
28 (package
29 (name "nickle")
30 (version "2.77")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "https://nickle.org/release/nickle-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "0rhij7cn1zkn8wzxyjkamz9fs262zyg80p6v6i864hdalg4plpm3"))))
38 (build-system gnu-build-system)
39 (native-inputs
40 `(("readline" ,readline)))
41 (synopsis "Numeric oriented programming language")
42 (description
43 "Nickle is a programming language based prototyping environment with
44 powerful programming and scripting capabilities. Nickle supports a variety of
45 datatypes, especially arbitrary precision numbers. The programming language
46 vaguely resembles C. Some things in C which do not translate easily are
47 different, some design choices have been made differently, and a very few
48 features are simply missing. Nickle provides the functionality of Unix bc, dc
49 and expr in a different form. It is also an ideal environment for prototyping
50 complex algorithms. Nickle's scripting capabilities make it a replacement for
51 spreadsheets in some applications, and its numeric features complement the
52 limited numeric functionality of text-oriented languages such as AWK and Perl.")
53 (home-page "https://nickle.org/")
54 (license license:expat)))