Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages kde)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system qt)
30 #:use-module (guix deprecation)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix packages)
35 #:use-module (guix utils)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages algebra)
38 #:use-module (gnu packages apr)
39 #:use-module (gnu packages audio)
40 #:use-module (gnu packages boost)
41 #:use-module (gnu packages code)
42 #:use-module (gnu packages compression)
43 #:use-module (gnu packages curl)
44 #:use-module (gnu packages documentation)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages ghostscript)
47 #:use-module (gnu packages gl)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages graphics)
50 #:use-module (gnu packages image)
51 #:use-module (gnu packages kde-frameworks)
52 #:use-module (gnu packages kde-plasma)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages llvm)
55 #:use-module (gnu packages maths)
56 #:use-module (gnu packages pdf)
57 #:use-module (gnu packages perl)
58 #:use-module (gnu packages photo)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages pulseaudio)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages tls)
63 #:use-module (gnu packages qt)
64 #:use-module (gnu packages version-control)
65 #:use-module (gnu packages video)
66 #:use-module (gnu packages xdisorg)
67 #:use-module (gnu packages xml)
68 #:use-module (gnu packages xorg))
69
70 (define-public baloo-widgets
71 (package
72 (name "baloo-widgets")
73 (version "19.08.3")
74 (source
75 (origin
76 (method url-fetch)
77 (uri (string-append "mirror://kde/stable/applications/" version
78 "/src/baloo-widgets-" version ".tar.xz"))
79 (sha256
80 (base32 "0bba8dgxd7rcjji809kwnw78hl1nb5ssh2ir4k4b0wvx395jifgd"))))
81 (build-system qt-build-system)
82 (native-inputs
83 `(("extra-cmake-modules" ,extra-cmake-modules)))
84 (inputs
85 `(("baloo" ,baloo)
86 ("kconfig" ,kconfig)
87 ("ki18n" ,ki18n)
88 ("kio" ,kio)
89 ("qtbase" ,qtbase)))
90 (arguments
91 `(#:phases
92 (modify-phases %standard-phases
93 (add-before 'check 'check-setup
94 (lambda _
95 (setenv "QT_QPA_PLATFORM" "offscreen")
96 #t)))))
97 (home-page "https://community.kde.org/Baloo")
98 (synopsis "Wigets for use with Baloo")
99 (description "Baloo is a framework for searching and managing metadata.
100 This package contains GUI widgets for baloo.")
101 (license license:lgpl2.0+)))
102
103 (define-public grantleetheme
104 (package
105 (name "grantleetheme")
106 (version "19.08.3")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (string-append "mirror://kde/stable/applications/" version
111 "/src/grantleetheme-" version ".tar.xz"))
112 (sha256
113 (base32 "0j77q1yyfmggzgkqgcw2xr0v9xg3h5cdhh8jry8h2llw75ahy6xb"))
114 (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
115 (build-system qt-build-system)
116 (native-inputs
117 `(("extra-cmake-modules" ,extra-cmake-modules)
118 ("libxml2" ,libxml2))) ;; xmllint required for tests
119 (inputs
120 `(("grantlee" ,grantlee)
121 ("ki18n" ,ki18n)
122 ("kiconthemes" ,kiconthemes)
123 ("knewstuff" ,knewstuff)
124 ("qtbase" ,qtbase)))
125 (home-page "https://cgit.kde.org/grantleetheme.git")
126 (synopsis "Library providing Grantlee theme support")
127 (description "This library provides Grantlee theme support.")
128 (license ;; LGPL for libraries, FDL for documentation
129 (list license:lgpl2.0+ license:fdl1.2+))))
130
131 (define-public kdenlive
132 (let ((version "18.08.1"))
133 (package
134 (name "kdenlive")
135 (version version)
136 (source
137 (origin
138 (method git-fetch)
139 (uri (git-reference
140 (url "git://anongit.kde.org/kdenlive.git")
141 (commit (string-append "v" version))))
142 (file-name (string-append name "-" version "-checkout"))
143 (sha256
144 (base32
145 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
146 (build-system cmake-build-system)
147 (native-inputs
148 `(("extra-cmake-modules" ,extra-cmake-modules)
149 ("qttools" ,qttools)))
150 (propagated-inputs
151 `(("mlt" ,mlt)))
152 (inputs
153 `(("shared-mime-info" ,shared-mime-info)
154 ("frei0r-plugins" ,frei0r-plugins)
155 ("qtbase" ,qtbase)
156 ("qtscript" ,qtscript)
157 ("qtsvg" ,qtsvg)
158 ("kparts" ,kparts)
159 ("knotifications" ,knotifications)
160 ("karchive" ,karchive)
161 ("kdbusaddons" ,kdbusaddons)
162 ("kcrash" ,kcrash)
163 ("kguiaddons" ,kguiaddons)
164 ("knewstuff" ,knewstuff)
165 ("knotifyconfig" ,knotifyconfig)
166 ("kfilemetadata" ,kfilemetadata)
167 ("kdoctools" ,kdoctools)
168 ("kdeclarative" ,kdeclarative)
169 ("qtdeclarative" ,qtdeclarative)
170 ("qtquickcontrols" ,qtquickcontrols)
171 ("kiconthemes" ,kiconthemes)
172 ("qtgraphicaleffects" ,qtgraphicaleffects)
173 ("kplotting" ,kplotting)))
174 (arguments
175 `(#:phases
176 (modify-phases %standard-phases
177 (add-after 'install 'wrap-executable
178 (lambda* (#:key inputs outputs #:allow-other-keys)
179 (let* ((out (assoc-ref outputs "out"))
180 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
181 (qtbase (assoc-ref inputs "qtbase"))
182 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
183 (frei0r (assoc-ref inputs "frei0r-plugins"))
184 (qml "/lib/qt5/qml"))
185 (wrap-program (string-append out "/bin/kdenlive")
186 `("QT_PLUGIN_PATH" ":" prefix
187 ,(map (lambda (label)
188 (string-append (assoc-ref inputs label)
189 "/lib/qt5/plugins/"))
190 '("qtbase" "qtsvg")))
191 `("FREI0R_PATH" ":" =
192 (,(string-append frei0r "/lib/frei0r-1/")))
193 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
194 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
195 `("QML2_IMPORT_PATH" ":" prefix
196 (,(string-append qtquickcontrols qml)
197 ,(string-append qtdeclarative qml)))))
198 #t)))))
199 (home-page "https://kdenlive.org")
200 (synopsis "Non-linear video editor")
201 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
202
203 Non-linear video editing is much more powerful than beginner's (linear)
204 editors, hence it requires a bit more organization before starting. However,
205 it is not reserved to specialists and can be used for small personal
206 projects.")
207 (license license:gpl2+))))
208
209 (define-public kdevelop
210 (package
211 (name "kdevelop")
212 (version "5.4.6")
213 (source
214 (origin
215 (method url-fetch)
216 (uri (string-append "mirror://kde/stable/kdevelop"
217 "/" version "/src/kdevelop-"
218 version ".tar.xz"))
219 (sha256
220 (base32 "01jmrmwbc1hrvq7jdfcc7mxl03q2l6kz57yca2j26xwyvfcfv5sz"))))
221 (build-system qt-build-system)
222 (native-inputs
223 `(("extra-cmake-modules" ,extra-cmake-modules)
224 ("pkg-config" ,pkg-config)
225 ("shared-mime-info" ,shared-mime-info)
226 ("qttools" ,qttools)))
227 (inputs
228 `(("boost" ,boost)
229 ("clang" ,clang)
230 ("grantlee" ,grantlee)
231 ("karchive" ,karchive)
232 ("kcmutils" ,kcmutils)
233 ("kcrash" ,kcrash)
234 ("kdeclarative" ,kdeclarative)
235 ("kdoctools" ,kdoctools)
236 ("kguiaddons" ,kguiaddons)
237 ("ki18n" ,ki18n)
238 ("kiconthemes" ,kiconthemes)
239 ("kio" ,kio) ;; not checked as requirement
240 ("kitemmodels" ,kitemmodels)
241 ("kitemviews" ,kitemviews)
242 ("kjobwidgets" ,kjobwidgets)
243 ("knotifications" ,knotifications)
244 ("knotifyconfig" ,knotifyconfig)
245 ("kparts" ,kparts)
246 ("kservice" ,kservice)
247 ("ktexteditor" ,ktexteditor)
248 ("kwindowsystem" ,kwindowsystem)
249 ("kxmlgui" ,kxmlgui)
250 ("libkomparediff2" ,libkomparediff2)
251 ("oxygen-icons" ,oxygen-icons)
252 ("qtbase" ,qtbase)
253 ("qtdeclarative" ,qtdeclarative)
254 ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
255 ("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
256 ("qtwebkit" ,qtwebkit)
257 ("threadweaver" ,threadweaver)
258
259 ;; recommendes
260 ("astyle" ,astyle)
261 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
262 ("libksysguard" ,libksysguard)
263
264 ;; optional
265 ("apr" ,apr) ; required for subversion support
266 ("apr-util" ,apr-util) ; required for subversion support
267 ("attica" ,attica)
268 ("kconfigwidgets" ,kconfigwidgets)
269 ("knewstuff" ,knewstuff)
270 ("krunner" ,krunner)
271 ;; TODO: OktetaGui, OktetaKastenControllers
272 ("plasma" ,plasma-framework)
273 ;; TODO: purpose
274 ("sonnet" ,sonnet)
275 ("subversion" ,subversion)))
276
277 ;; run-time packages - TODO
278 ;; ClazyStandalone
279 ;; Cppcheck
280 ;; heaptrack
281 ;; heaptrack_gui
282 ;; meson
283 (arguments
284 `(#:tests? #f ;; there are some issues with the test suite
285 #:phases
286 (modify-phases %standard-phases
287 (add-before 'configure 'add-include-path
288 (lambda* (#:key inputs #:allow-other-keys)
289 (substitute* "cmake/modules/FindClang.cmake"
290 (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
291 (string-append line " " (assoc-ref inputs "clang") "/lib")))
292 #t)))))
293 (home-page "https://kdevelop.org")
294 (synopsis "IDE for C, C++, Python, Javascript and PHP")
295 (description "The KDevelop IDE provides semantic syntax highlighting, as
296 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
297 JavaScript, Python and PHP. It also integrates with a debugger, different
298 build systems (CMake, QMake, custom Makefiles) and version control
299 software (Git, Subversion, Mercurial, CVS and Bazaar).")
300 (license license:lgpl2.1+)))
301
302 (define-public kdevelop-pg-qt
303 (package
304 (name "kdevelop-pg-qt")
305 (version "2.2.0")
306 (source
307 (origin
308 (method url-fetch)
309 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
310 version ".tar.gz"))
311 (file-name (string-append name "-" version ".tar.gz"))
312 (sha256
313 (base32 "15ja19gg6x7gww4ch12hy585x55ghbkpsiyr8fqiyjk0j6v07hh5"))))
314 (native-inputs
315 `(("extra-cmake-modules" ,extra-cmake-modules)))
316 (inputs
317 `(("qtbase" ,qtbase)))
318 (build-system cmake-build-system)
319 (home-page "https://kde.org")
320 (synopsis "Parser generator library for KDevplatform")
321 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
322 for some KDevelop language plugins (Ruby, PHP, CSS...).")
323 (license license:lgpl2.0+)))
324
325 ;; kdevplatform was merged into kdevelop as of 5.2.x
326 (define-deprecated kdevplatform kdevelop)
327
328 (define-public kdiagram
329 (package
330 (name "kdiagram")
331 (version "2.6.1")
332 (source
333 (origin
334 (method url-fetch)
335 (uri (string-append "mirror://kde/stable/kdiagram/" version
336 "/kdiagram-" version ".tar.xz"))
337 (sha256
338 (base32 "1c6dbp9gssjrx59z8yxzq1ay56pnw7h28symjrv0gcvhxyjirrxx"))
339 (patches (search-patches
340 "kdiagram-Fix-missing-link-libraries.patch"))))
341 (build-system qt-build-system)
342 (native-inputs
343 `(("extra-cmake-modules" ,extra-cmake-modules)
344 ("qttools" ,qttools)))
345 (inputs
346 `(("qtbase" ,qtbase)
347 ("qtsvg" ,qtsvg)))
348 (home-page "https://cgit.kde.org/kdiagram.git/")
349 (synopsis "Libraries for creating business diagrams")
350 (description "This package provides libraries for integrating business
351 diagrams in Qt-based applications.
352
353 @code{KCharts} provides an implementation of the ODF Chart specification. It
354 supports stock charts, box charts, and whisker charts. @code{KGantt} provides
355 a module for implementing ODF Gantt charts, which are bar charts that
356 illustrate project schedules.")
357 (license license:gpl2+)))
358
359 (define-public krita
360 (package
361 (name "krita")
362 (version "4.2.7.1")
363 (source (origin
364 (method url-fetch)
365 (uri (string-append
366 "mirror://kde/stable/krita/" version
367 "/krita-" version ".tar.gz"))
368 (sha256
369 (base32
370 "0gcwq1w09gmx53i2fir73l222p41299wagvhbvsxwrz0v3crzliy"))))
371 (build-system cmake-build-system)
372 (arguments
373 `(#:tests? #f
374 #:configure-flags
375 (list "-DBUILD_TESTING=OFF"
376 (string-append "-DCMAKE_CXX_FLAGS=-I"
377 (assoc-ref %build-inputs "ilmbase")
378 "/include/OpenEXR"))
379 #:phases
380 (modify-phases %standard-phases
381 ;; Ensure that icons are found at runtime.
382 ;; This works around <https://bugs.gnu.org/22138>.
383 (add-after 'install 'wrap-executable
384 (lambda* (#:key inputs outputs #:allow-other-keys)
385 (let ((out (assoc-ref outputs "out"))
386 (qt '("qtbase" "qtsvg")))
387 (wrap-program (string-append out "/bin/krita")
388 `("QT_PLUGIN_PATH" ":" prefix
389 ,(map (lambda (label)
390 (string-append (assoc-ref inputs label)
391 "/lib/qt5/plugins/"))
392 qt)))
393 #t))))))
394 (native-inputs
395 `(("curl" ,curl)
396 ("eigen" ,eigen)
397 ("extra-cmake-modules" ,extra-cmake-modules)
398 ("gettext-minimal" ,gettext-minimal)
399 ("kitemmodels" ,kitemmodels)
400 ("pkg-config" ,pkg-config)
401 ("qwt" ,qwt)
402 ("vc" ,vc)))
403 (inputs
404 `(("boost" ,boost)
405 ("exiv2" ,exiv2)
406 ("fftw" ,fftw)
407 ("gsl" ,gsl)
408 ("ilmbase" ,ilmbase)
409 ("karchive" ,karchive)
410 ("kcompletion" ,kcompletion)
411 ("kconfig" ,kconfig)
412 ("kcoreaddons" ,kcoreaddons)
413 ("kcrash" ,kcrash)
414 ("kguiaddons" ,kguiaddons)
415 ("ki18n" ,ki18n)
416 ("kiconthemes" ,kiconthemes)
417 ("kio" ,kio)
418 ("kitemviews" ,kitemviews)
419 ("kwidgetsaddons" ,kwidgetsaddons)
420 ("kwindowsystem" ,kwindowsystem)
421 ("kxmlgui" ,kxmlgui)
422 ("lcms" ,lcms)
423 ("libjpeg-turbo" ,libjpeg-turbo)
424 ("libpng" ,libpng)
425 ("libraw" ,libraw-0.18)
426 ("libtiff" ,libtiff)
427 ("libx11" ,libx11)
428 ("libxcb" ,libxcb)
429 ("libxi" ,libxi)
430 ("openexr" ,openexr)
431 ("perl" ,perl)
432 ("poppler-qt5" ,poppler-qt5)
433 ("qtbase" ,qtbase)
434 ("qtdeclarative" ,qtdeclarative)
435 ("qtmultimedia" ,qtmultimedia)
436 ("qtsvg" ,qtsvg)
437 ("qtx11extras" ,qtx11extras)
438 ("quazip" ,quazip)
439 ("zlib" ,zlib)))
440 (home-page "https://krita.org")
441 (synopsis "Digital painting application")
442 (description
443 "Krita is a professional painting tool designed for concept artists,
444 illustrators, matte and texture artists, and the VFX industry. Notable
445 features include brush stabilizers, brush engines and wrap-around mode.")
446 (license license:gpl2+)))
447
448 (define-public libkomparediff2
449 (package
450 (name "libkomparediff2")
451 (version "19.08.2")
452 (source
453 (origin
454 (method url-fetch)
455 (uri (string-append "mirror://kde/stable/applications/" version
456 "/src/libkomparediff2-" version ".tar.xz"))
457 (sha256
458 (base32 "1mvihd0xpkl8kryf5dvsfgpbgs9af8c9bzq8mmr74gfsvfb8ywy5"))))
459 (native-inputs
460 `(("extra-cmake-modules" ,extra-cmake-modules)
461 ("pkg-config" ,pkg-config)))
462 (inputs
463 `(("kcodecs" ,kcodecs)
464 ("kconfig" ,kconfig)
465 ("kcoreaddons" ,kcoreaddons)
466 ("ki18n" ,ki18n)
467 ("kio" ,kio)
468 ("kxmlgui" ,kxmlgui)
469 ("qtbase" ,qtbase)))
470 (build-system cmake-build-system)
471 (home-page "https://kde.org")
472 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
473 (description "Libkomparediff2 is a library to work with diffs and patches,
474 used in KDE development tools Kompare and KDevelop.")
475
476 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
477 ;; source archive
478 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
479
480 (define-public qca
481 (package
482 (name "qca")
483 (version "2.2.1")
484 (source
485 (origin
486 (method url-fetch)
487 (uri (string-append "mirror://kde/stable/qca/" version
488 "/qca-" version ".tar.xz"))
489 (sha256
490 (base32
491 "00kv1vsrc8fp556hm8s6yw3240vx3l4067q6vfxrb3gdwgcd45np"))))
492 (build-system cmake-build-system)
493 (native-inputs
494 `(("pkg-config" ,pkg-config)))
495 (inputs
496 `(("openssl" ,openssl)
497 ("qtbase" ,qtbase)))
498 (home-page "https://userbase.kde.org/QCA")
499 (synopsis "Libraries for the Qt Cryptographic Architecture")
500 (description "The Qt Cryptographic Architecture (QCA) provides a
501 straightforward and cross-platform API for a range of cryptographic features,
502 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
503 cards.")
504 (license license:lgpl2.1)))
505
506 (define-public kpmcore
507 (package
508 (name "kpmcore")
509 (version "4.0.1")
510 (source (origin
511 (method url-fetch)
512 (uri (string-append
513 "mirror://kde/stable/kpmcore"
514 "/" version "/src/"
515 name "-" version ".tar.xz"))
516 (sha256
517 (base32
518 "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))
519 (patches (search-patches "kpmcore-fix-tests.patch"
520 "kpmcore-remove-broken-test.patch"))))
521 (build-system cmake-build-system)
522 (native-inputs
523 `(("extra-cmake-modules" ,extra-cmake-modules)
524 ("pkg-config" ,pkg-config)))
525 (inputs
526 `(("kauth" ,kauth)
527 ("kcoreaddons" ,kcoreaddons)
528 ("ki18n" ,ki18n)
529 ("kwidgetsaddons" ,kwidgetsaddons)
530 ("qtbase" ,qtbase)
531 ("qca" ,qca)
532 ("util-linux" ,util-linux "lib")))
533 (home-page "https://community.kde.org/Frameworks")
534 (synopsis "Library for managing partitions")
535 (description "Library for managing partitions.")
536 (license license:gpl3+)))
537
538 (define-public snorenotify
539 (package
540 (name "snorenotify")
541 (version "0.7.0")
542 (source
543 (origin
544 (method url-fetch)
545 (uri (string-append "mirror://kde/stable/snorenotify/"
546 version "/src/snorenotify-" version ".tar.xz"))
547 (sha256
548 (base32
549 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
550 (build-system cmake-build-system)
551 (arguments
552 `(#:tests? #f)) ; both tests fail, require display
553 (inputs
554 `(("qtbase" ,qtbase)))
555 (native-inputs
556 `(("extra-cmake-modules" ,extra-cmake-modules)
557 ("qttools" ,qttools)))
558 (home-page "https://techbase.kde.org/Projects/Snorenotify")
559 (synopsis "Qt notification framework")
560 (description "Snorenotify is a multi platform Qt notification framework.
561 Using a plugin system it is possible to create notifications with many
562 different notification systems.")
563 (license license:lgpl3)))
564
565 (define-public kdeconnect
566 (package
567 (name "kdeconnect")
568 (version "1.3.5")
569 (source
570 (origin
571 (method url-fetch)
572 (uri (string-append "mirror://kde/stable/kdeconnect/"
573 version "/kdeconnect-kde-"
574 version ".tar.xz"))
575 (sha256
576 (base32
577 "02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
578 (build-system qt-build-system)
579 (arguments
580 `(#:configure-flags '("-DBUILD_TESTING=ON")
581 #:tests? #f)) ; tests fail hard in our build environment
582 (native-inputs
583 `(("extra-cmake-modules" ,extra-cmake-modules)
584 ("kdoctools" ,kdoctools)
585 ("libxtst" ,libxtst)
586 ("pkg-config" ,pkg-config)
587 ("python" ,python-wrapper)))
588 (inputs
589 `(("kcmutils" ,kcmutils)
590 ("kconfigwidgets" ,kconfigwidgets)
591 ("kdbusaddons" ,kdbusaddons)
592 ("ki18n" ,ki18n)
593 ("kiconthemes" ,kiconthemes)
594 ("kio" ,kio)
595 ("knotifications" ,knotifications)
596 ("kwayland" ,kwayland)
597 ("libfakekey" ,libfakekey)
598 ("qca" ,qca)
599 ("qtbase" ,qtbase)
600 ("qtdeclarative" ,qtdeclarative)
601 ("qtx11extras" ,qtx11extras)))
602 (home-page "https://community.kde.org/KDEConnect")
603 (synopsis "Enable your devices to communicate with each other")
604 (description "KDE Connect is a project that enables all your devices to
605 communicate with each other. Here's a few things KDE Connect can do:
606 @enumerate
607 @item Receive your phone notifications on your desktop computer and reply to messages
608 @item Control music playing on your desktop from your phone
609 @item Use your phone as a remote control for your desktop
610 @item Run predefined commands on your PC from connected devices
611 @item Check your phones battery level from the desktop
612 @item Ring your phone to help finding it
613 @item Share files and links between devices
614 @item Browse your phone from the desktop
615 @item Control the desktop's volume from the phone
616 @end enumerate")
617 (properties `((upstream-name . "kdeconnect-kde")))
618 (license (list license:gpl2 license:gpl3)))) ; dual licensed
619
620 (define-public kqtquickcharts
621 (package
622 (name "kqtquickcharts")
623 (version "19.08.2")
624 (source
625 (origin
626 (method url-fetch)
627 (uri (string-append "mirror://kde/stable/applications/"
628 version "/src/kqtquickcharts-" version ".tar.xz"))
629 (sha256
630 (base32
631 "1yy9fyd8y4g25ljdsbil19qdf4j3mzmzl489sx7rqpm3lfdzjh9k"))))
632 (build-system cmake-build-system)
633 (native-inputs
634 `(("extra-cmake-modules" ,extra-cmake-modules)))
635 (inputs
636 `(("qtbase" ,qtbase)
637 ("qtdeclarative" ,qtdeclarative)))
638 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
639 (synopsis "Interactive charts for Qt Quick")
640 (description
641 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
642 charts.")
643 (license license:lgpl2.1+)))
644
645 (define-public kcachegrind
646 (package
647 (name "kcachegrind")
648 (version "19.04.1")
649 (source (origin
650 (method url-fetch)
651 (uri (string-append "mirror://kde/stable/applications/" version
652 "/src/kcachegrind-" version ".tar.xz"))
653 (sha256
654 (base32
655 "1hhsk64yp6q2xh8j269j4wp9y24ggmii861r6gf02mj1mbn2p1jb"))))
656 (build-system cmake-build-system)
657 (native-inputs
658 `(("extra-cmake-modules" ,extra-cmake-modules)
659 ("perl" ,perl)
660 ("python" ,python)
661 ("qttools" ,qttools)
662 ("kdoctools" ,kdoctools)))
663 (inputs
664 `(("qtbase" ,qtbase)
665 ("karchive" ,karchive)
666 ("ki18n" ,ki18n)
667 ("kio" ,kio)
668 ("kdbusaddons" ,kdbusaddons)))
669 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
670 ;; Python and PHP, respectively. These are optional and we ignore them
671 ;; for now.
672 (home-page "https://kcachegrind.github.io/html/Home.html")
673 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
674 (description
675 "The data files generated by the Callgrind of Valgrind, an application
676 profiler, can be loaded into KCachegrind for browsing the performance results.
677 There is also a command-line tool to get ASCII reports from data files without
678 the need to use KCachegrind.
679
680 The format of Callgrind output is documented. With conversion scripts,
681 KCachegrind is able to visualize output of other profilers like OProfile, a
682 system-wide profiler for Linux using statistical sampling with hardware
683 performance counters. There also exist converters for profiling output of
684 Python, PHP, and Perl.")
685 (license license:gpl2)))
686
687 (define-public libkdegames
688 (package
689 (name "libkdegames")
690 (version "19.08.3")
691 (source
692 (origin
693 (method url-fetch)
694 (uri (string-append "mirror://kde/stable/applications/" version
695 "/src/libkdegames-" version ".tar.xz"))
696 (sha256
697 (base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
698 (build-system qt-build-system)
699 (native-inputs
700 `(("extra-cmake-modules" ,extra-cmake-modules)))
701 (inputs
702 `(("karchive" ,karchive)
703 ("kbookmarks" ,kbookmarks)
704 ("kcodecs" ,kcodecs)
705 ("kcompletion" ,kcompletion)
706 ("kconfigwidgets" ,kconfigwidgets)
707 ("kcrash" ,kcrash)
708 ("kdbusaddons" ,kdbusaddons)
709 ("kdeclarative" ,kdeclarative)
710 ("kdnssd" ,kdnssd)
711 ("kglobalaccel" ,kglobalaccel)
712 ("kguiaddons" ,kguiaddons)
713 ("ki18n" ,ki18n)
714 ("kiconthemes" ,kiconthemes)
715 ;("kio" ,kio)
716 ("kitemviews" ,kitemviews)
717 ("kjobwidgets" ,kjobwidgets)
718 ("knewstuff" ,knewstuff)
719 ("kservice" ,kservice)
720 ("ktextwidgets" ,ktextwidgets)
721 ("kwidgetsaddons" ,kwidgetsaddons)
722 ("kxmlgui" ,kxmlgui)
723 ("libsndfile" ,libsndfile)
724 ("openal" ,openal)
725 ("qtbase" ,qtbase)
726 ("qtdeclarative" ,qtdeclarative)
727 ("qtsvg" ,qtsvg)))
728 (home-page "https://games.kde.org/")
729 (synopsis "Runtime library for kdegames")
730 (description "Runtime library for kdegames")
731 (license (list license:gpl2+ license:fdl1.2+))))
732
733 (define-public zeroconf-ioslave
734 (package
735 (name "zeroconf-ioslave")
736 (version "19.08.3")
737 (source
738 (origin
739 (method url-fetch)
740 (uri (string-append "mirror://kde/stable/applications/" version
741 "/src/zeroconf-ioslave-" version ".tar.xz"))
742 (sha256
743 (base32 "1vbi4kpyrk530q2dj8ql2i0gxjybdbmkqpl8vkhrihl7r7f0xc5p"))))
744 (build-system qt-build-system)
745 (native-inputs
746 `(("extra-cmake-modules" ,extra-cmake-modules)))
747 (inputs
748 `(("kdbusaddons" ,kdbusaddons)
749 ("kdnssd" ,kdnssd)
750 ("ki18n" ,ki18n)
751 ("kio" ,kio)
752 ("qtbase" ,qtbase)))
753 (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
754 (synopsis "DNS-SD Service Discovery Monitor")
755 (description "Adds an entry to Dolphin's Network page to show local
756 services such as printers which advertise themselves with DNSSD (called Avahi
757 or Bonjour by other projects).")
758 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
759 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))