gnu: gnome: Depend on xdg-user-dirs.
[jackhill/guix/guix.git] / gnu / packages / patches / ghostscript-CVE-2016-7978.patch
1 From 6f749c0c44e7b9e09737b9f29edf29925a34f0cf Mon Sep 17 00:00:00 2001
2 From: Chris Liddell <chris.liddell@artifex.com>
3 Date: Wed, 5 Oct 2016 09:59:25 +0100
4 Subject: [PATCH] Bug 697179: Reference count device icc profile
5
6 when copying a device
7 ---
8 base/gsdevice.c | 1 +
9 1 file changed, 1 insertion(+)
10
11 diff --git a/base/gsdevice.c b/base/gsdevice.c
12 index 778106f..aea986a 100644
13 --- a/base/gsdevice.c
14 +++ b/base/gsdevice.c
15 @@ -614,6 +614,7 @@ gx_device_init(gx_device * dev, const gx_device * proto, gs_memory_t * mem,
16 dev->memory = mem;
17 dev->retained = !internal;
18 rc_init(dev, mem, (internal ? 0 : 1));
19 + rc_increment(dev->icc_struct);
20 }
21
22 void
23 --
24 2.9.1
25