gnu: gnome: Depend on xdg-user-dirs.
[jackhill/guix/guix.git] / gnu / packages / patches / binutils-mips-bash-bug.patch
1 Bash 4.2.0(1)-release, which we use during bootstrap, does not yield the
2 "x" case in:
3
4 case x"$EMULATION_NAME" in x) ;; *) ;; esac
5
6 when 'EMULATION_NAME' is undefined. Bash 4.3.30(1)-release doesn't have this
7 problem. Work around it.
8
9 This Bash bug was fixed
10 in <http://ftp.gnu.org/gnu/bash/bash-4.2-patches/bash42-007>.
11
12 --- a/ld/emulparams/elf32bmipn32-defs.sh
13 +++ b/ld/emulparams/elf32bmipn32-defs.sh
14 @@ -13,7 +13,7 @@ LITTLE_OUTPUT_FORMAT="elf32-littlemips"
15 TEMPLATE_NAME=elf32
16 EXTRA_EM_FILE=mipself
17
18 -case x"$EMULATION_NAME" in
19 +case "x$EMULATION_NAME" in
20 xelf32*n32*) ELFSIZE=32 ;;
21 xelf64*) ELFSIZE=64 ;;
22 x) ;;