gnu: go-github-com-gogo-protobuf: Update to 0.5-1.35b81a0.
[jackhill/guix/guix.git] / gnu / packages / pumpio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages pumpio)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages aspell)
27 #:use-module (gnu packages qt)
28 #:use-module (gnu packages web))
29
30 (define-public pumpa
31 (package
32 (name "pumpa")
33 (version "0.9.2")
34 (source (origin
35 (method git-fetch) ; no source tarballs
36 (uri (git-reference
37 (url "git://pumpa.branchable.com/")
38 (commit (string-append "v" version))))
39 (sha256
40 (base32
41 "09www29s4ldvd6apr73w7r4nmq93rcl2d182fylwgfcnncbvpy8s"))
42 (file-name (string-append name "-" version "-checkout"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(#:phases
46 (modify-phases %standard-phases
47 (replace 'configure
48 (lambda* (#:key inputs outputs #:allow-other-keys)
49 ;; Fix dependency tests.
50 (substitute* "pumpa.pro"
51 (("/usr/include/tidy\\.h")
52 (string-append (assoc-ref inputs "tidy")
53 "/include/tidy.h"))
54 (("/usr/include/aspell.h")
55 (string-append (assoc-ref inputs "aspell")
56 "/include/aspell.h")))
57 ;; Run qmake with proper installation prefix.
58 (let ((prefix (string-append "PREFIX="
59 (assoc-ref outputs "out"))))
60 (zero? (system* "qmake" prefix)))
61 #t)))))
62 (inputs
63 `(("aspell" ,aspell)
64 ("qtbase" ,qtbase)
65 ("tidy" ,tidy)))
66 (synopsis "Qt-based pump.io client")
67 (description "Pumpa is a simple pump.io client written in C++ and Qt.")
68 (home-page "https://pumpa.branchable.com/")
69 (license gpl3+)))