gnu: go-github-com-gogo-protobuf: Update to 0.5-1.35b81a0.
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages libidn)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages libunistring)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
30
31 (define-public libidn
32 (package
33 (name "libidn")
34 (version "1.33")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/libidn/libidn-" version
38 ".tar.gz"))
39 (sha256
40 (base32
41 "068fjg2arlppjqqpzd714n1lf6gxkpac9v5yyvp1qwmv6nvam9s4"))))
42 (build-system gnu-build-system)
43 ;; FIXME: No Java and C# libraries are currently built.
44 (synopsis "Internationalized string processing library")
45 (description
46 "libidn is a library implementing of the Stringprep, Punycode and IDNA
47 specifications. These are used to encode and decode internationalized domain
48 names according to the IDNA2003 specifications. It includes native C, C# and
49 Java libraries.")
50 ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
51 ;; the command line tool is gpl3+.
52 (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
53 (home-page "https://www.gnu.org/software/libidn/")))
54
55 (define-public libidn2
56 (package
57 (name "libidn2")
58 (version "2.0.2")
59 (replacement libidn2-2.0.4)
60 (source (origin
61 (method url-fetch)
62 (uri (string-append "mirror://gnu/libidn/" name "-" version
63 ".tar.lz"))
64 (sha256
65 (base32
66 "0pqaj8d01aj4i110669fincqs10kgynyqcrmq2q7pss8v9dcd1jq"))))
67 (native-inputs
68 `(("lzip" ,lzip)))
69 (inputs
70 `(("libunistring" ,libunistring)))
71 (build-system gnu-build-system)
72 (synopsis "Internationalized domain name library for IDNA2008")
73 (description "Libidn2 is an internationalized domain library implementing
74 the IDNA2008 specifications. Libidn2 is believed to be a complete IDNA2008
75 implementation, but has yet to be as extensively used as the original Libidn
76 library.")
77 (home-page "https://www.gnu.org/software/libidn/#libidn2")
78 ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
79 ;; GPL2+ or LGPL3+.
80 (license (list gpl2+ gpl3+ lgpl3+))))
81
82 (define-public libidn2-2.0.4
83 (package
84 (inherit libidn2)
85 (name "libidn2")
86 (version "2.0.4")
87 (source (origin
88 (method url-fetch)
89 (uri (string-append "mirror://gnu/libidn/" name "-" version
90 ".tar.lz"))
91 (sha256
92 (base32
93 "00f2fyw5kwr9is3cdn5h9arzxp0lnvg0z9bb9zyfs0dq81gaqim4"))))))