gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2015, 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
9 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
11 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
12 ;;; Copyright © 2017 ng0 <ng0@n0.is>
13 ;;; Copyright © 2018 Manuel Graf <graf@init.at>
14 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages ssh)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages base)
35 #:autoload (gnu packages boost) (boost)
36 #:use-module (gnu packages compression)
37 #:use-module (gnu packages crypto)
38 #:use-module (gnu packages elf)
39 #:use-module (gnu packages gnupg)
40 #:use-module (gnu packages gperf)
41 #:use-module (gnu packages groff)
42 #:use-module (gnu packages guile)
43 #:use-module (gnu packages libedit)
44 #:use-module (gnu packages linux)
45 #:use-module (gnu packages logging)
46 #:use-module (gnu packages m4)
47 #:use-module (gnu packages multiprecision)
48 #:use-module (gnu packages ncurses)
49 #:use-module (gnu packages nettle)
50 #:use-module (gnu packages kerberos)
51 #:use-module (gnu packages perl)
52 #:use-module (gnu packages pkg-config)
53 #:use-module (gnu packages popt)
54 #:autoload (gnu packages protobuf) (protobuf)
55 #:use-module (gnu packages python)
56 #:use-module (gnu packages python-xyz)
57 #:use-module (gnu packages readline)
58 #:use-module (gnu packages texinfo)
59 #:use-module (gnu packages tls)
60 #:use-module (gnu packages xorg)
61 #:use-module (guix build-system cmake)
62 #:use-module (guix build-system gnu)
63 #:use-module (guix build-system python)
64 #:use-module (guix download)
65 #:use-module (guix git-download)
66 #:use-module ((guix licenses) #:prefix license:)
67 #:use-module (guix packages)
68 #:use-module (guix utils)
69 #:use-module (srfi srfi-1))
70
71 (define-public libssh
72 (package
73 (name "libssh")
74 (version "0.9.3")
75 (source (origin
76 (method git-fetch)
77 (uri (git-reference
78 (url "https://git.libssh.org/projects/libssh.git")
79 (commit (string-append "libssh-" version))))
80 (sha256
81 (base32
82 "175i3xybg69d5lb078334v6dd3njm743kww8f67ix9w33969rmzf"))
83 (file-name (git-file-name name version))))
84 (build-system cmake-build-system)
85 (outputs '("out" "debug"))
86 (arguments
87 '(#:configure-flags '("-DWITH_GCRYPT=ON")
88
89 ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
90 #:tests? #f))
91 (inputs `(("zlib" ,zlib)
92 ("libgcrypt" ,libgcrypt)))
93 (synopsis "SSH client library")
94 (description
95 "libssh is a C library implementing the SSHv2 and SSHv1 protocol for client
96 and server implementations. With libssh, you can remotely execute programs,
97 transfer files, and use a secure and transparent tunnel for your remote
98 applications.")
99 (home-page "https://www.libssh.org")
100 (license license:lgpl2.1+)))
101
102 (define-public libssh2
103 (package
104 (name "libssh2")
105 (version "1.9.0")
106 (source (origin
107 (method url-fetch)
108 (uri (string-append
109 "https://www.libssh2.org/download/libssh2-"
110 version ".tar.gz"))
111 (sha256
112 (base32
113 "1zfsz9nldakfz61d2j70pk29zlmj7w2vv46s9l3x2prhcgaqpyym"))))
114 (build-system gnu-build-system)
115 ;; The installed libssh2.pc file does not include paths to libgcrypt and
116 ;; zlib libraries, so we need to propagate the inputs.
117 (propagated-inputs `(("libgcrypt" ,libgcrypt)
118 ("zlib" ,zlib)))
119 (arguments `(#:configure-flags `("--with-libgcrypt")))
120 (synopsis "Client-side C library implementing the SSH2 protocol")
121 (description
122 "libssh2 is a library intended to allow software developers access to
123 the SSH-2 protocol in an easy-to-use self-contained package. It can be built
124 into an application to perform many different tasks when communicating with
125 a server that supports the SSH-2 protocol.")
126 (license license:bsd-3)
127 (home-page "https://www.libssh2.org/")))
128
129 (define-public openssh
130 (package
131 (name "openssh")
132 (version "8.0p1")
133 (source (origin
134 (method url-fetch)
135 (uri (string-append "mirror://openbsd/OpenSSH/portable/"
136 name "-" version ".tar.gz"))
137 (sha256
138 (base32
139 "0s7xh4s0qcipnjh9ls5blxcpvhyd116z9dxn3q1yi64lwrwki55x"))))
140 (build-system gnu-build-system)
141 (native-inputs `(("groff" ,groff)
142 ("pkg-config" ,pkg-config)))
143 (inputs `(("libedit" ,libedit)
144 ("openssl" ,openssl)
145 ("pam" ,linux-pam)
146 ("mit-krb5" ,mit-krb5)
147 ("zlib" ,zlib)
148 ("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
149 (arguments
150 `(#:test-target "tests"
151 ;; Otherwise, the test scripts try to use a nonexistent directory and
152 ;; fail.
153 #:make-flags '("REGRESSTMP=\"$${BUILDDIR}/regress\"")
154 #:configure-flags `("--sysconfdir=/etc/ssh"
155
156 ;; Default value of 'PATH' used by sshd.
157 "--with-default-path=/run/current-system/profile/bin"
158
159 ;; configure needs to find krb5-config
160 ,(string-append "--with-kerberos5="
161 (assoc-ref %build-inputs "mit-krb5")
162 "/bin")
163
164 ;; libedit needed for sftp completion
165 "--with-libedit"
166
167 ;; Enable PAM support in sshd.
168 "--with-pam")
169
170 #:phases
171 (modify-phases %standard-phases
172 (add-after 'configure 'reset-/var/empty
173 (lambda* (#:key outputs #:allow-other-keys)
174 (let ((out (assoc-ref outputs "out")))
175 (substitute* "Makefile"
176 (("PRIVSEP_PATH=/var/empty")
177 (string-append "PRIVSEP_PATH=" out "/var/empty")))
178 #t)))
179 (add-before 'check 'patch-tests
180 (lambda _
181 ;; remove 't-exec' regress target which requires user 'sshd'
182 (substitute* "regress/Makefile"
183 (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
184 (string-append pre post)))
185 #t))
186 (replace 'install
187 (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
188 ;; install without host keys and system configuration files
189 (apply invoke "make" "install-nosysconf" make-flags)
190 (install-file "contrib/ssh-copy-id"
191 (string-append (assoc-ref outputs "out")
192 "/bin/"))
193 (chmod (string-append (assoc-ref outputs "out")
194 "/bin/ssh-copy-id") #o555)
195 (install-file "contrib/ssh-copy-id.1"
196 (string-append (assoc-ref outputs "out")
197 "/share/man/man1/"))
198 #t)))))
199 (synopsis "Client and server for the secure shell (ssh) protocol")
200 (description
201 "The SSH2 protocol implemented in OpenSSH is standardised by the
202 IETF secsh working group and is specified in several RFCs and drafts.
203 It is composed of three layered components:
204
205 The transport layer provides algorithm negotiation and a key exchange.
206 The key exchange includes server authentication and results in a
207 cryptographically secured connection: it provides integrity, confidentiality
208 and optional compression.
209
210 The user authentication layer uses the established connection and relies on
211 the services provided by the transport layer. It provides several mechanisms
212 for user authentication. These include traditional password authentication
213 as well as public-key or host-based authentication mechanisms.
214
215 The connection layer multiplexes many different concurrent channels over the
216 authenticated connection and allows tunneling of login sessions and
217 TCP-forwarding. It provides a flow control service for these channels.
218 Additionally, various channel-specific options can be negotiated.")
219 (license (license:non-copyleft "file://LICENSE"
220 "See LICENSE in the distribution."))
221 (home-page "https://www.openssh.com/")))
222
223 (define-public guile-ssh
224 (package
225 (name "guile-ssh")
226 (version "0.11.3")
227 (home-page "https://github.com/artyom-poptsov/guile-ssh")
228 (source (origin
229 (method git-fetch)
230 (uri (git-reference
231 (url home-page)
232 (commit (string-append "v" version))))
233 (file-name (string-append name "-" version ".tar.gz"))
234 (sha256
235 (base32
236 "03bv3hwp2s8f0bqgfjaan9jx4dyab0abv27n2zn2g0izlidv0vl6"))
237 (modules '((guix build utils)))
238 (snippet
239 '(begin
240 ;; libssh >= 0.8.0 no longer provides libssh_threads: see
241 ;; <https://github.com/artyom-poptsov/guile-ssh/issues/9>.
242 (substitute* "libguile-ssh/Makefile.am"
243 (("-lssh_threads") ""))
244
245 ;; This test would wrongfully pick DSS keys when running on
246 ;; libssh >= 0.8.0, which fails:
247 ;; <https://github.com/artyom-poptsov/guile-ssh/issues/10>.
248 (substitute* "tests/server.scm"
249 (("= %libssh-minor-version 7")
250 ">= %libssh-minor-version 7"))
251
252 ;; Allow builds with Guile 3.0.
253 (substitute* "configure.ac"
254 (("^GUILE_PKG.*$")
255 "GUILE_PKG([3.0 2.2 2.0])\n"))
256 #t))))
257 (build-system gnu-build-system)
258 (outputs '("out" "debug"))
259 (arguments
260 '(;; It makes no sense to build libguile-ssh.a.
261 #:configure-flags '("--disable-static")
262
263 #:phases (modify-phases %standard-phases
264 (add-before 'build 'fix-libguile-ssh-file-name
265 (lambda* (#:key outputs #:allow-other-keys)
266 ;; Build and install libguile-ssh.so so that we can use
267 ;; its absolute file name in .scm files, before we build
268 ;; the .go files.
269 (let* ((out (assoc-ref outputs "out"))
270 (lib (string-append out "/lib")))
271 (invoke "make" "install"
272 "-C" "libguile-ssh"
273 "-j" (number->string
274 (parallel-job-count)))
275 (substitute* (find-files "." "\\.scm$")
276 (("\"libguile-ssh\"")
277 (string-append "\"" lib "/libguile-ssh\"")))
278 #t)))
279 (add-after 'install 'remove-bin-directory
280 (lambda* (#:key outputs #:allow-other-keys)
281 (let* ((out (assoc-ref outputs "out"))
282 (bin (string-append out "/bin"))
283 (examples (string-append
284 out "/share/guile-ssh/examples")))
285 (mkdir-p examples)
286 (rename-file (string-append bin "/ssshd.scm")
287 (string-append examples "/ssshd.scm"))
288 (rename-file (string-append bin "/sssh.scm")
289 (string-append examples "/sssh.scm"))
290 (delete-file-recursively bin)
291 #t))))
292 ;; Tests are not parallel-safe.
293 #:parallel-tests? #f))
294 (native-inputs `(("autoconf" ,autoconf)
295 ("automake" ,automake)
296 ("libtool" ,libtool)
297 ("texinfo" ,texinfo)
298 ("pkg-config" ,pkg-config)
299 ("which" ,which)))
300 (inputs `(("guile" ,guile-2.2)
301 ("libssh" ,libssh)
302 ("libgcrypt" ,libgcrypt)))
303 (synopsis "Guile bindings to libssh")
304 (description
305 "Guile-SSH is a library that provides access to the SSH protocol for
306 programs written in GNU Guile interpreter. It is a wrapper to the underlying
307 libssh library.")
308 (license license:gpl3+)))
309
310 (define-public guile2.0-ssh
311 (package
312 (inherit guile-ssh)
313 (name "guile2.0-ssh")
314 (inputs `(("guile" ,guile-2.0)
315 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
316
317 (define-public guile3.0-ssh
318 (package
319 (inherit guile-ssh)
320 (name "guile3.0-ssh")
321 (arguments
322 (substitute-keyword-arguments (package-arguments guile-ssh)
323 ((#:phases phases)
324 `(modify-phases ,phases
325 (add-before 'bootstrap 'delete-old-guile-m4
326 (lambda _
327 ;; The old 'guile.m4' that's shipped would fail to recognize
328 ;; Guile 2.9 as "3.0".
329 (delete-file "m4/guile.m4")
330 #t))
331 (add-before 'build 'adjust-for-guile3
332 (lambda _
333 ;; Adjust for things that are deprecated in 2.2 and removed in
334 ;; 3.0.
335 (substitute* "tests/common.scm"
336 (("define-module \\(tests common\\)")
337 "define-module (tests common)
338 #:use-module (ice-9 threads)\n"))
339 (substitute* "modules/ssh/tunnel.scm"
340 (("define-module \\(ssh tunnel\\)")
341 "define-module (ssh tunnel)
342 #:use-module (ice-9 threads)"))
343 (substitute* "modules/srfi/srfi-64.upstream.scm"
344 (("_IOLBF")
345 "'line"))
346 #t))))))
347 (inputs `(("guile" ,guile-next)
348 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
349
350 (define-public corkscrew
351 (package
352 (name "corkscrew")
353 (version "2.0")
354 (source
355 (origin
356 (method url-fetch)
357 ;; The agroman.net domain name expired on 2017-03-23, and the original
358 ;; "http://www.agroman.net/corkscrew/corkscrew-2.0.tar.gz" now returns
359 ;; bogus HTML. Perhaps it will yet return. Until then, use a mirror.
360 (uri (string-append "https://downloads.openwrt.org/sources/"
361 "corkscrew-" version ".tar.gz"))
362 (sha256 (base32
363 "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
364 (build-system gnu-build-system)
365 (arguments
366 `(#:phases
367 (modify-phases %standard-phases
368 (replace 'configure
369 ;; Replace configure phase as the ./configure script does not like
370 ;; CONFIG_SHELL and SHELL passed as parameters
371 (lambda* (#:key outputs build target #:allow-other-keys)
372 (let* ((out (assoc-ref outputs "out"))
373 (bash (which "bash"))
374 ;; Set --build and --host flags as the provided config.guess
375 ;; is not able to detect them
376 (flags `(,(string-append "--prefix=" out)
377 ,(string-append "--build=" build)
378 ,(string-append "--host=" (or target build)))))
379 (setenv "CONFIG_SHELL" bash)
380 (apply invoke bash "./configure" flags))))
381 (add-after 'install 'install-documentation
382 (lambda* (#:key outputs #:allow-other-keys)
383 (let* ((out (assoc-ref outputs "out"))
384 (doc (string-append out "/share/doc/" ,name "-" ,version)))
385 (install-file "README" doc)
386 #t))))))
387 (home-page "http://www.agroman.net/corkscrew")
388 (synopsis "SSH tunneling through HTTP(S) proxies")
389 (description
390 "Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.
391 Proxy authentication is only supported through the plain-text HTTP basic
392 authentication scheme.")
393 (license license:gpl2+)))
394
395 (define-public mosh
396 (package
397 (name "mosh")
398 (version "1.3.2")
399 (source (origin
400 (method url-fetch)
401 (uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
402 (sha256
403 (base32
404 "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
405 (build-system gnu-build-system)
406 (arguments
407 '(#:phases
408 (modify-phases %standard-phases
409 (add-after 'install 'wrap
410 (lambda* (#:key outputs #:allow-other-keys)
411 ;; Make sure 'mosh' can find 'mosh-client' and
412 ;; 'mosh-server'.
413 (let* ((out (assoc-ref outputs "out"))
414 (bin (string-append out "/bin")))
415 (wrap-program (string-append bin "/mosh")
416 `("PATH" ":" prefix (,bin)))))))))
417 (native-inputs
418 `(("pkg-config" ,pkg-config)))
419 (inputs
420 `(("openssl" ,openssl)
421 ("perl" ,perl)
422 ("perl-io-tty" ,perl-io-tty)
423 ("zlib" ,zlib)
424 ("ncurses" ,ncurses)
425 ("protobuf" ,protobuf)
426 ("boost-headers" ,boost)))
427 (home-page "https://mosh.org/")
428 (synopsis "Remote shell tolerant to intermittent connectivity")
429 (description
430 "Remote terminal application that allows roaming, supports intermittent
431 connectivity, and provides intelligent local echo and line editing of user
432 keystrokes. Mosh is a replacement for SSH. It's more robust and responsive,
433 especially over Wi-Fi, cellular, and long-distance links.")
434 (license license:gpl3+)))
435
436 (define-public et
437 (package
438 (name "et")
439 (version "3.1.0")
440 (source
441 (origin
442 (method git-fetch)
443 (uri (git-reference
444 (url "https://github.com/MisterTea/EternalTCP.git")
445 (commit (string-append "et-v" version))))
446 (file-name (git-file-name name version))
447 (sha256
448 (base32 "1m5caxckn2ihwp9s2pbyh5amxlpwr7yc54q8s0kb10fr52w2vfnm"))))
449 (build-system cmake-build-system)
450 (arguments `(#:tests? #f))
451 (native-inputs
452 `(("pkg-config" ,pkg-config)))
453 (inputs `(("glog" ,glog)
454 ("gflags" ,gflags)
455 ("libsodium" ,libsodium)
456 ("protobuf" ,protobuf)))
457 (synopsis "Remote shell that automatically reconnects")
458 (description
459 "Eternal Terminal (ET) is a remote shell that automatically reconnects
460 without interrupting the session. Unlike SSH sessions, ET sessions will
461 survive even network outages and IP changes. ET uses a custom protocol over
462 TCP, not the SSH protocol.")
463 (home-page "https://mistertea.github.io/EternalTCP/")
464 (license license:asl2.0)))
465
466 (define-public dropbear
467 (package
468 (name "dropbear")
469 (version "2019.78")
470 (source
471 (origin
472 (method url-fetch)
473 (uri (string-append
474 "https://matt.ucc.asn.au/dropbear/releases/"
475 "dropbear-" version ".tar.bz2"))
476 (sha256
477 (base32 "19242qlr40pbqfqd0gg6h8qpj38q6lgv03ja6sahj9vj2abnanaj"))))
478 (build-system gnu-build-system)
479 (arguments `(#:tests? #f)) ; there is no "make check" or anything similar
480 ;; TODO: Investigate unbundling libtommath and libtomcrypt or at least
481 ;; cherry-picking important bug fixes from them. See <bugs.gnu.org/24674>
482 ;; for more information.
483 (inputs `(("zlib" ,zlib)))
484 (synopsis "Small SSH server and client")
485 (description "Dropbear is a relatively small SSH server and
486 client. It runs on a variety of POSIX-based platforms. Dropbear is
487 particularly useful for embedded systems, such as wireless routers.")
488 (home-page "https://matt.ucc.asn.au/dropbear/dropbear.html")
489 (license (license:x11-style "" "See file LICENSE."))))
490
491 (define-public liboop
492 (package
493 (name "liboop")
494 (version "1.0.1")
495 (source
496 (origin
497 (method url-fetch)
498 (uri (string-append "http://ftp.lysator.liu.se/pub/liboop/"
499 name "-" version ".tar.gz"))
500 (sha256
501 (base32
502 "1q0p1l72pq9k3bi7a366j2rishv7dzzkg3i6r2npsfg7cnnidbsn"))))
503 (build-system gnu-build-system)
504 (home-page "http://www.lysator.liu.se/liboop/")
505 (synopsis "Event loop library")
506 (description "Liboop is a low-level event loop management library for
507 POSIX-based operating systems. It supports the development of modular,
508 multiplexed applications which may respond to events from several sources. It
509 replaces the \"select() loop\" and allows the registration of event handlers
510 for file and network I/O, timers and signals. Since processes use these
511 mechanisms for almost all external communication, liboop can be used as the
512 basis for almost any application.")
513 (license license:lgpl2.1+)))
514
515 (define-public lsh
516 (package
517 (name "lsh")
518 (version "2.1")
519 (source (origin
520 (method url-fetch)
521 (uri (string-append "mirror://gnu/lsh/lsh-"
522 version ".tar.gz"))
523 (sha256
524 (base32
525 "1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))
526 (modules '((guix build utils)))
527 (snippet
528 '(begin
529 (substitute* "src/testsuite/functions.sh"
530 (("localhost")
531 ;; Avoid host name lookups since they don't work in
532 ;; chroot builds.
533 "127.0.0.1")
534 (("set -e")
535 ;; Make tests more verbose.
536 "set -e\nset -x"))
537
538 (substitute* (find-files "src/testsuite" "-test$")
539 (("localhost") "127.0.0.1"))
540
541 (substitute* "src/testsuite/login-auth-test"
542 (("/bin/cat") "cat"))
543 #t))))
544 (build-system gnu-build-system)
545 (native-inputs
546 `(("m4" ,m4)
547 ("guile" ,guile-2.0)
548 ("gperf" ,gperf)
549 ("psmisc" ,psmisc))) ; for `killall'
550 (inputs
551 `(("nettle" ,nettle-2)
552 ("linux-pam" ,linux-pam)
553
554 ;; 'rl.c' uses the 'CPPFunction' type, which is no longer in
555 ;; Readline 6.3.
556 ("readline" ,readline-6.2)
557
558 ("liboop" ,liboop)
559 ("zlib" ,zlib)
560 ("gmp" ,gmp)
561
562 ;; The server (lshd) invokes xauth when X11 forwarding is requested.
563 ;; This adds 24 MiB (or 27%) to the closure of lsh.
564 ("xauth" ,xauth)))
565 (arguments
566 '(;; Skip the `configure' test that checks whether /dev/ptmx &
567 ;; co. work as expected, because it relies on impurities (for
568 ;; instance, /dev/pts may be unavailable in chroots.)
569 #:configure-flags '("lsh_cv_sys_unix98_ptys=yes"
570
571 ;; Use glibc's argp rather than the bundled one.
572 "--with-system-argp"
573
574 ;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
575 ;; defines it.
576 "CPPFLAGS=-DHAVE_ARGP_PARSE")
577
578 ;; FIXME: Tests won't run in a chroot, presumably because
579 ;; /etc/profile is missing, and thus clients get an empty $PATH
580 ;; and nothing works.
581 #:tests? #f
582
583 #:phases
584 (modify-phases %standard-phases
585 (add-before 'configure 'pre-configure
586 (lambda* (#:key inputs #:allow-other-keys)
587 (let* ((nettle (assoc-ref inputs "nettle"))
588 (sexp-conv (string-append nettle "/bin/sexp-conv")))
589 ;; Remove argp from the list of sub-directories; we don't want
590 ;; to build it, really.
591 (substitute* "src/Makefile.in"
592 (("^SUBDIRS = argp")
593 "SUBDIRS ="))
594
595 ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
596 ;; by default.
597 (substitute* "src/environ.h.in"
598 (("^#define PATH_SEXP_CONV.*")
599 (string-append "#define PATH_SEXP_CONV \""
600 sexp-conv "\"\n")))
601
602 ;; Same for the 'lsh-authorize' script.
603 (substitute* "src/lsh-authorize"
604 (("=sexp-conv")
605 (string-append "=" sexp-conv)))
606
607 ;; Tell lshd where 'xauth' lives. Another option would be to
608 ;; hardcode "/run/current-system/profile/bin/xauth", thereby
609 ;; reducing the closure size, but that wouldn't work on foreign
610 ;; distros.
611 (with-fluids ((%default-port-encoding "ISO-8859-1"))
612 (substitute* "src/server_x11.c"
613 (("define XAUTH_PROGRAM.*")
614 (string-append "define XAUTH_PROGRAM \""
615 (assoc-ref inputs "xauth")
616 "/bin/xauth\"\n")))))
617
618 ;; Tests rely on $USER being set.
619 (setenv "USER" "guix"))))))
620 (home-page "http://www.lysator.liu.se/~nisse/lsh/")
621 (synopsis "GNU implementation of the Secure Shell (ssh) protocols")
622 (description
623 "GNU lsh is a free implementation of the SSH version 2 protocol. It is
624 used to create a secure line of communication between two computers,
625 providing shell access to the server system from the client. It provides
626 both the server daemon and the client application, as well as tools for
627 manipulating key files.")
628 (license license:gpl2+)))
629
630 (define-public sshpass
631 (package
632 (name "sshpass")
633 (version "1.06")
634 (synopsis "Non-interactive password authentication with SSH")
635 (home-page "https://sourceforge.net/projects/sshpass/")
636 (source
637 (origin
638 (method url-fetch)
639 (uri (string-append "mirror://sourceforge/sshpass/sshpass/"
640 version "/sshpass-" version ".tar.gz"))
641 (sha256
642 (base32
643 "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6"))))
644 (build-system gnu-build-system)
645 (description "sshpass is a tool for non-interactivly performing password
646 authentication with SSH's so-called @dfn{interactive keyboard password
647 authentication}.")
648 (license license:gpl2+)))
649
650 (define-public autossh
651 (package
652 (name "autossh")
653 (version "1.4g")
654 (source
655 (origin
656 (method url-fetch)
657 (uri (string-append
658 "https://www.harding.motd.ca/autossh/autossh-"
659 version ".tgz"))
660 (sha256
661 (base32 "0xqjw8df68f4kzkns5gcah61s5wk0m44qdk2z1d6388w6viwxhsz"))))
662 (build-system gnu-build-system)
663 (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
664 (inputs `(("openssh" ,openssh)))
665 (synopsis "Automatically restart SSH sessions and tunnels")
666 (description "autossh is a program to start a copy of @command{ssh} and
667 monitor it, restarting it as necessary should it die or stop passing traffic.")
668 (home-page "https://www.harding.motd.ca/autossh/")
669 (license
670 ;; Why point to a source file? Well, all the individual files have a
671 ;; copy of this license in their headers, but there's no separate file
672 ;; with that information.
673 (license:non-copyleft "file://autossh.c"))))
674
675 (define-public pdsh
676 (package
677 (name "pdsh")
678 (version "2.33")
679 (source
680 (origin
681 (method url-fetch)
682 (uri (string-append "https://github.com/chaos/pdsh/"
683 "releases/download/pdsh-" version
684 "/pdsh-" version ".tar.gz"))
685 (file-name (string-append name "-" version ".tar.gz"))
686 (sha256
687 (base32 "0bwlkl9inj66iwvafg00pi3sk9n673phdi0kcc59y9nn55s0hs3k"))))
688 (build-system gnu-build-system)
689 (arguments
690 `(#:configure-flags
691 (list "--with-ssh")
692 #:phases
693 (modify-phases %standard-phases
694 (add-after 'unpack 'patch-/bin/sh
695 (lambda _
696 (substitute* '("tests/t0006-pdcp.sh"
697 "tests/t0004-module-loading.sh"
698 "tests/t2001-ssh.sh"
699 "tests/t1003-slurm.sh"
700 "tests/t6036-long-output-lines.sh"
701 "tests/aggregate-results.sh"
702 "tests/t2000-exec.sh"
703 "tests/t0002-internal.sh"
704 "tests/t1002-dshgroup.sh"
705 "tests/t5000-dshbak.sh"
706 "tests/t0001-basic.sh"
707 "tests/t0005-rcmd_type-and-user.sh"
708 "tests/test-lib.sh"
709 "tests/t2002-mrsh.sh"
710 "tests/t0003-wcoll.sh"
711 "tests/test-modules/pcptest.c")
712 (("/bin/sh") (which "bash")))
713 #t))
714 (add-after 'unpack 'patch-tests
715 (lambda _
716 (substitute* "tests/t6036-long-output-lines.sh"
717 (("which") (which "which")))
718 #t)))))
719 (inputs
720 `(("openssh" ,openssh)
721 ("mit-krb5" ,mit-krb5)
722 ("perl" ,perl)))
723 (native-inputs
724 `(("which" ,which)))
725 (home-page "https://github.com/chaos/pdsh")
726 (synopsis "Parallel distributed shell")
727 (description "Pdsh is a an efficient, multithreaded remote shell client
728 which executes commands on multiple remote hosts in parallel. Pdsh implements
729 dynamically loadable modules for extended functionality such as new remote
730 shell services and remote host selection.")
731 (license license:gpl2+)))
732
733 (define-public clustershell
734 (package
735 (name "clustershell")
736 (version "1.8.3")
737 (source
738 (origin
739 (method url-fetch)
740 (uri (string-append "https://github.com/cea-hpc/clustershell/releases"
741 "/download/v" version
742 "/ClusterShell-" version ".tar.gz"))
743 (sha256
744 (base32 "1qdcgh733szwj9r1gambrgfkizvbjci0bnnkds9a8mnyb3sasnan"))))
745 (build-system python-build-system)
746 (inputs `(("openssh" ,openssh)))
747 (propagated-inputs `(("python-pyyaml" ,python-pyyaml)))
748 (arguments
749 `(#:phases (modify-phases %standard-phases
750 (add-before 'build 'record-openssh-file-name
751 (lambda* (#:key inputs #:allow-other-keys)
752 (let ((ssh (assoc-ref inputs "openssh")))
753 (substitute* "lib/ClusterShell/Worker/Ssh.py"
754 (("info\\(\"ssh_path\"\\) or \"ssh\"")
755 (string-append "info(\"ssh_path\") or \""
756 ssh "/bin/ssh\"")))
757 #t))))))
758 (home-page "https://cea-hpc.github.io/clustershell/")
759 (synopsis "Scalable event-driven Python framework for cluster administration")
760 (description
761 "ClusterShell is an event-driven Python framework, designed to run local
762 or distant commands in parallel on server farms or on large GNU/Linux
763 clusters. It will take care of common issues encountered on HPC clusters,
764 such as operating on groups of nodes, running distributed commands using
765 optimized execution algorithms, as well as gathering results and merging
766 identical outputs, or retrieving return codes. ClusterShell takes advantage
767 of existing remote shell facilities such as SSH.")
768 (license license:lgpl2.1+)))
769
770 (define-public endlessh
771 (package
772 (name "endlessh")
773 (version "1.0")
774 (source
775 (origin
776 (method url-fetch)
777 (uri (string-append "https://github.com/skeeto/endlessh/releases/"
778 "download/" version "/endlessh-" version ".tar.xz"))
779 (sha256
780 (base32
781 "0hhsr65hzrcb7ylskmxyr92svzndhks8hqzn8hvg7f7j89rkvq5k"))))
782 (build-system gnu-build-system)
783 (arguments
784 '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
785 "CC=gcc")
786 #:tests? #f ; no test target
787 #:phases
788 (modify-phases %standard-phases
789 (delete 'configure)))) ; no configure script
790 (home-page "https://github.com/skeeto/endlessh")
791 (synopsis "SSH tarpit that slowly sends an endless banner")
792 (description
793 "Endlessh is an SSH tarpit that very slowly sends an endless, random SSH
794 banner. It keeps SSH clients locked up for hours or even days at a time. The
795 purpose is to put your real SSH server on another port and then let the script
796 kiddies get stuck in this tarpit instead of bothering a real server.
797
798 Since the tarpit is in the banner before any cryptographic exchange occurs, this
799 program doesn't depend on any cryptographic libraries. It's a simple,
800 single-threaded, standalone C program. It uses @code{poll()} to trap multiple
801 clients at a time.")
802 (license license:unlicense)))