gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / libdaemon.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libdaemon)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public libdaemon
26 (package
27 (name "libdaemon")
28 (version "0.14")
29 (source (origin
30 (method url-fetch)
31 (uri (list
32 (string-append
33 "mirror://debian/pool/main/libd/libdaemon/libdaemon_"
34 version ".orig.tar.gz")
35 "http://pkgs.fedoraproject.org/repo/pkgs/libdaemon/libdaemon-0.14.tar.gz/509dc27107c21bcd9fbf2f95f5669563/libdaemon-0.14.tar.gz"
36
37 ;; This used to be the canonical URL but it vanished.
38 ;; See <http://bugs.gnu.org/18639>.
39 ;; (string-append
40 ;; "http://0pointer.de/lennart/projects/libdaemon/libdaemon-"
41 ;; version ".tar.gz")
42 ))
43 (sha256
44 (base32
45 "0d5qlq5ab95wh1xc87rqrh1vx6i8lddka1w3f1zcqvcqdxgyn8zx"))
46 (file-name (string-append name "-" version ".tar.gz"))))
47 (build-system gnu-build-system)
48
49 ;; XXX: Stale URL, missing replacement. See <http://bugs.gnu.org/18639>.
50 (home-page "http://0pointer.de/lennart/projects/libdaemon/")
51
52 (synopsis "Lightweight C library that eases the writing of UNIX daemons")
53 (description
54 "Libdaemon is a lightweight C library that eases the writing of UNIX
55 daemons. It consists of the following parts:
56
57 • A wrapper around fork() which does the correct daemonization procedure of
58 a process
59
60 • A wrapper around syslog() for simpler and compatible log output to Syslog
61 or STDERR
62
63 • An API for writing PID files
64
65 • An API for serializing UNIX signals into a pipe for usage with select() or
66 poll()
67
68 • An API for running subprocesses with STDOUT and STDERR redirected to
69 syslog.
70
71 APIs like these are used in most daemon software available. It is not that
72 simple to get it done right and code duplication is not a goal.")
73 (license lgpl2.1+)))