gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages kde)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system qt)
30 #:use-module (guix deprecation)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix packages)
35 #:use-module (guix utils)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages algebra)
38 #:use-module (gnu packages apr)
39 #:use-module (gnu packages audio)
40 #:use-module (gnu packages boost)
41 #:use-module (gnu packages code)
42 #:use-module (gnu packages compression)
43 #:use-module (gnu packages curl)
44 #:use-module (gnu packages documentation)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages ghostscript)
47 #:use-module (gnu packages gl)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages graphics)
50 #:use-module (gnu packages image)
51 #:use-module (gnu packages kde-frameworks)
52 #:use-module (gnu packages kde-plasma)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages llvm)
55 #:use-module (gnu packages maths)
56 #:use-module (gnu packages pdf)
57 #:use-module (gnu packages perl)
58 #:use-module (gnu packages photo)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages pulseaudio)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages tls)
63 #:use-module (gnu packages qt)
64 #:use-module (gnu packages version-control)
65 #:use-module (gnu packages video)
66 #:use-module (gnu packages xdisorg)
67 #:use-module (gnu packages xml)
68 #:use-module (gnu packages xorg))
69
70 (define-public grantleetheme
71 (package
72 (name "grantleetheme")
73 (version "19.08.3")
74 (source
75 (origin
76 (method url-fetch)
77 (uri (string-append "mirror://kde/stable/applications/" version
78 "/src/grantleetheme-" version ".tar.xz"))
79 (sha256
80 (base32 "0j77q1yyfmggzgkqgcw2xr0v9xg3h5cdhh8jry8h2llw75ahy6xb"))
81 (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
82 (build-system qt-build-system)
83 (native-inputs
84 `(("extra-cmake-modules" ,extra-cmake-modules)
85 ("libxml2" ,libxml2))) ;; xmllint required for tests
86 (inputs
87 `(("grantlee" ,grantlee)
88 ("ki18n" ,ki18n)
89 ("kiconthemes" ,kiconthemes)
90 ("knewstuff" ,knewstuff)
91 ("qtbase" ,qtbase)))
92 (arguments
93 `(#:phases
94 (modify-phases %standard-phases
95 (add-before 'check 'check-setup
96 (lambda _
97 (setenv "QT_QPA_PLATFORM" "offscreen")
98 #t)))))
99 (home-page "https://cgit.kde.org/grantleetheme.git")
100 (synopsis "Library providing Grantlee theme support")
101 (description "This library provides Grantlee theme support.")
102 (license ;; LGPL for libraries, FDL for documentation
103 (list license:lgpl2.0+ license:fdl1.2+))))
104
105 (define-public kdenlive
106 (let ((version "18.08.1"))
107 (package
108 (name "kdenlive")
109 (version version)
110 (source
111 (origin
112 (method git-fetch)
113 (uri (git-reference
114 (url "git://anongit.kde.org/kdenlive.git")
115 (commit (string-append "v" version))))
116 (file-name (string-append name "-" version "-checkout"))
117 (sha256
118 (base32
119 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
120 (build-system cmake-build-system)
121 (native-inputs
122 `(("extra-cmake-modules" ,extra-cmake-modules)
123 ("qttools" ,qttools)))
124 (propagated-inputs
125 `(("mlt" ,mlt)))
126 (inputs
127 `(("shared-mime-info" ,shared-mime-info)
128 ("frei0r-plugins" ,frei0r-plugins)
129 ("qtbase" ,qtbase)
130 ("qtscript" ,qtscript)
131 ("qtsvg" ,qtsvg)
132 ("kparts" ,kparts)
133 ("knotifications" ,knotifications)
134 ("karchive" ,karchive)
135 ("kdbusaddons" ,kdbusaddons)
136 ("kcrash" ,kcrash)
137 ("kguiaddons" ,kguiaddons)
138 ("knewstuff" ,knewstuff)
139 ("knotifyconfig" ,knotifyconfig)
140 ("kfilemetadata" ,kfilemetadata)
141 ("kdoctools" ,kdoctools)
142 ("kdeclarative" ,kdeclarative)
143 ("qtdeclarative" ,qtdeclarative)
144 ("qtquickcontrols" ,qtquickcontrols)
145 ("kiconthemes" ,kiconthemes)
146 ("qtgraphicaleffects" ,qtgraphicaleffects)
147 ("kplotting" ,kplotting)))
148 (arguments
149 `(#:phases
150 (modify-phases %standard-phases
151 (add-after 'install 'wrap-executable
152 (lambda* (#:key inputs outputs #:allow-other-keys)
153 (let* ((out (assoc-ref outputs "out"))
154 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
155 (qtbase (assoc-ref inputs "qtbase"))
156 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
157 (frei0r (assoc-ref inputs "frei0r-plugins"))
158 (qml "/lib/qt5/qml"))
159 (wrap-program (string-append out "/bin/kdenlive")
160 `("QT_PLUGIN_PATH" ":" prefix
161 ,(map (lambda (label)
162 (string-append (assoc-ref inputs label)
163 "/lib/qt5/plugins/"))
164 '("qtbase" "qtsvg")))
165 `("FREI0R_PATH" ":" =
166 (,(string-append frei0r "/lib/frei0r-1/")))
167 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
168 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
169 `("QML2_IMPORT_PATH" ":" prefix
170 (,(string-append qtquickcontrols qml)
171 ,(string-append qtdeclarative qml)))))
172 #t)))))
173 (home-page "https://kdenlive.org")
174 (synopsis "Non-linear video editor")
175 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
176
177 Non-linear video editing is much more powerful than beginner's (linear)
178 editors, hence it requires a bit more organization before starting. However,
179 it is not reserved to specialists and can be used for small personal
180 projects.")
181 (license license:gpl2+))))
182
183 (define-public kdevelop
184 (package
185 (name "kdevelop")
186 (version "5.4.5")
187 (source
188 (origin
189 (method url-fetch)
190 (uri (string-append "mirror://kde/stable/kdevelop"
191 "/" version "/src/kdevelop-"
192 version ".tar.xz"))
193 (sha256
194 (base32
195 "08vhbg9ql0402bw3y3xw1kdxhig9sv3ss8g0h4477vy3z17m1h4j"))))
196 (build-system qt-build-system)
197 (native-inputs
198 `(("extra-cmake-modules" ,extra-cmake-modules)
199 ("pkg-config" ,pkg-config)
200 ("shared-mime-info" ,shared-mime-info)
201 ("qttools" ,qttools)))
202 (inputs
203 `(("boost" ,boost)
204 ("clang" ,clang)
205 ("grantlee" ,grantlee)
206 ("karchive" ,karchive)
207 ("kcmutils" ,kcmutils)
208 ("kcrash" ,kcrash)
209 ("kdeclarative" ,kdeclarative)
210 ("kdoctools" ,kdoctools)
211 ("kguiaddons" ,kguiaddons)
212 ("ki18n" ,ki18n)
213 ("kiconthemes" ,kiconthemes)
214 ("kio" ,kio) ;; not checked as requirement
215 ("kitemmodels" ,kitemmodels)
216 ("kitemviews" ,kitemviews)
217 ("kjobwidgets" ,kjobwidgets)
218 ("knotifications" ,knotifications)
219 ("knotifyconfig" ,knotifyconfig)
220 ("kparts" ,kparts)
221 ("kservice" ,kservice)
222 ("ktexteditor" ,ktexteditor)
223 ("kwindowsystem" ,kwindowsystem)
224 ("kxmlgui" ,kxmlgui)
225 ("libkomparediff2" ,libkomparediff2)
226 ("oxygen-icons" ,oxygen-icons)
227 ("qtbase" ,qtbase)
228 ("qtdeclarative" ,qtdeclarative)
229 ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
230 ("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
231 ("qtwebkit" ,qtwebkit)
232 ("threadweaver" ,threadweaver)
233
234 ;; recommendes
235 ("astyle" ,astyle)
236 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
237 ("libksysguard" ,libksysguard)
238
239 ;; optional
240 ("apr" ,apr) ; required for subversion support
241 ("apr-util" ,apr-util) ; required for subversion support
242 ("attica" ,attica)
243 ("kconfigwidgets" ,kconfigwidgets)
244 ("knewstuff" ,knewstuff)
245 ("krunner" ,krunner)
246 ;; TODO: OktetaGui, OktetaKastenControllers
247 ("plasma" ,plasma-framework)
248 ;; TODO: purpose
249 ("sonnet" ,sonnet)
250 ("subversion" ,subversion)))
251
252 ;; run-time packages - TODO
253 ;; ClazyStandalone
254 ;; Cppcheck
255 ;; heaptrack
256 ;; heaptrack_gui
257 ;; meson
258 (arguments
259 `(#:tests? #f ;; there are some issues with the test suite
260 #:phases
261 (modify-phases %standard-phases
262 (add-before 'configure 'add-include-path
263 (lambda* (#:key inputs #:allow-other-keys)
264 (substitute* "cmake/modules/FindClang.cmake"
265 (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
266 (string-append line " " (assoc-ref inputs "clang") "/lib")))
267 #t)))))
268 (home-page "https://kdevelop.org")
269 (synopsis "IDE for C, C++, Python, Javascript and PHP")
270 (description "The KDevelop IDE provides semantic syntax highlighting, as
271 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
272 JavaScript, Python and PHP. It also integrates with a debugger, different
273 build systems (CMake, QMake, custom Makefiles) and version control
274 software (Git, Subversion, Mercurial, CVS and Bazaar).")
275 (license license:lgpl2.1+)))
276
277 (define-public kdevelop-pg-qt
278 (package
279 (name "kdevelop-pg-qt")
280 (version "2.2.0")
281 (source
282 (origin
283 (method url-fetch)
284 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
285 version ".tar.gz"))
286 (file-name (string-append name "-" version ".tar.gz"))
287 (sha256
288 (base32 "15ja19gg6x7gww4ch12hy585x55ghbkpsiyr8fqiyjk0j6v07hh5"))))
289 (native-inputs
290 `(("extra-cmake-modules" ,extra-cmake-modules)))
291 (inputs
292 `(("qtbase" ,qtbase)))
293 (build-system cmake-build-system)
294 (home-page "https://kde.org")
295 (synopsis "Parser generator library for KDevplatform")
296 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
297 for some KDevelop language plugins (Ruby, PHP, CSS...).")
298 (license license:lgpl2.0+)))
299
300 ;; kdevplatform was merged into kdevelop as of 5.2.x
301 (define-deprecated kdevplatform kdevelop kdevelop)
302
303 (define-public krita
304 (package
305 (name "krita")
306 (version "4.2.7.1")
307 (source (origin
308 (method url-fetch)
309 (uri (string-append
310 "mirror://kde/stable/krita/" version
311 "/krita-" version ".tar.gz"))
312 (sha256
313 (base32
314 "0gcwq1w09gmx53i2fir73l222p41299wagvhbvsxwrz0v3crzliy"))))
315 (build-system cmake-build-system)
316 (arguments
317 `(#:tests? #f
318 #:configure-flags
319 (list "-DBUILD_TESTING=OFF"
320 (string-append "-DCMAKE_CXX_FLAGS=-I"
321 (assoc-ref %build-inputs "ilmbase")
322 "/include/OpenEXR"))
323 #:phases
324 (modify-phases %standard-phases
325 ;; Ensure that icons are found at runtime.
326 ;; This works around <https://bugs.gnu.org/22138>.
327 (add-after 'install 'wrap-executable
328 (lambda* (#:key inputs outputs #:allow-other-keys)
329 (let ((out (assoc-ref outputs "out"))
330 (qt '("qtbase" "qtsvg")))
331 (wrap-program (string-append out "/bin/krita")
332 `("QT_PLUGIN_PATH" ":" prefix
333 ,(map (lambda (label)
334 (string-append (assoc-ref inputs label)
335 "/lib/qt5/plugins/"))
336 qt)))
337 #t))))))
338 (native-inputs
339 `(("curl" ,curl)
340 ("eigen" ,eigen)
341 ("extra-cmake-modules" ,extra-cmake-modules)
342 ("gettext-minimal" ,gettext-minimal)
343 ("kitemmodels" ,kitemmodels)
344 ("pkg-config" ,pkg-config)
345 ("qwt" ,qwt)
346 ("vc" ,vc)))
347 (inputs
348 `(("boost" ,boost)
349 ("exiv2" ,exiv2)
350 ("fftw" ,fftw)
351 ("gsl" ,gsl)
352 ("ilmbase" ,ilmbase)
353 ("karchive" ,karchive)
354 ("kcompletion" ,kcompletion)
355 ("kconfig" ,kconfig)
356 ("kcoreaddons" ,kcoreaddons)
357 ("kcrash" ,kcrash)
358 ("kguiaddons" ,kguiaddons)
359 ("ki18n" ,ki18n)
360 ("kiconthemes" ,kiconthemes)
361 ("kio" ,kio)
362 ("kitemviews" ,kitemviews)
363 ("kwidgetsaddons" ,kwidgetsaddons)
364 ("kwindowsystem" ,kwindowsystem)
365 ("kxmlgui" ,kxmlgui)
366 ("lcms" ,lcms)
367 ("libjpeg-turbo" ,libjpeg-turbo)
368 ("libpng" ,libpng)
369 ("libraw" ,libraw-0.18)
370 ("libtiff" ,libtiff)
371 ("libx11" ,libx11)
372 ("libxcb" ,libxcb)
373 ("libxi" ,libxi)
374 ("openexr" ,openexr)
375 ("perl" ,perl)
376 ("poppler-qt5" ,poppler-qt5)
377 ("qtbase" ,qtbase)
378 ("qtdeclarative" ,qtdeclarative)
379 ("qtmultimedia" ,qtmultimedia)
380 ("qtsvg" ,qtsvg)
381 ("qtx11extras" ,qtx11extras)
382 ("quazip" ,quazip)
383 ("zlib" ,zlib)))
384 (home-page "https://krita.org")
385 (synopsis "Digital painting application")
386 (description
387 "Krita is a professional painting tool designed for concept artists,
388 illustrators, matte and texture artists, and the VFX industry. Notable
389 features include brush stabilizers, brush engines and wrap-around mode.")
390 (license license:gpl2+)))
391
392 (define-public libkomparediff2
393 (package
394 (name "libkomparediff2")
395 (version "19.08.2")
396 (source
397 (origin
398 (method url-fetch)
399 (uri (string-append "mirror://kde/stable/applications/" version
400 "/src/libkomparediff2-" version ".tar.xz"))
401 (sha256
402 (base32 "1mvihd0xpkl8kryf5dvsfgpbgs9af8c9bzq8mmr74gfsvfb8ywy5"))))
403 (native-inputs
404 `(("extra-cmake-modules" ,extra-cmake-modules)
405 ("pkg-config" ,pkg-config)))
406 (inputs
407 `(("kcodecs" ,kcodecs)
408 ("kconfig" ,kconfig)
409 ("kcoreaddons" ,kcoreaddons)
410 ("ki18n" ,ki18n)
411 ("kio" ,kio)
412 ("kxmlgui" ,kxmlgui)
413 ("qtbase" ,qtbase)))
414 (build-system cmake-build-system)
415 (home-page "https://kde.org")
416 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
417 (description "Libkomparediff2 is a library to work with diffs and patches,
418 used in KDE development tools Kompare and KDevelop.")
419
420 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
421 ;; source archive
422 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
423
424 (define-public qca
425 (package
426 (name "qca")
427 (version "2.2.1")
428 (source
429 (origin
430 (method url-fetch)
431 (uri (string-append "mirror://kde/stable/qca/" version
432 "/qca-" version ".tar.xz"))
433 (sha256
434 (base32
435 "00kv1vsrc8fp556hm8s6yw3240vx3l4067q6vfxrb3gdwgcd45np"))))
436 (build-system cmake-build-system)
437 (native-inputs
438 `(("pkg-config" ,pkg-config)))
439 (inputs
440 `(("openssl" ,openssl)
441 ("qtbase" ,qtbase)))
442 (home-page "https://userbase.kde.org/QCA")
443 (synopsis "Libraries for the Qt Cryptographic Architecture")
444 (description "The Qt Cryptographic Architecture (QCA) provides a
445 straightforward and cross-platform API for a range of cryptographic features,
446 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
447 cards.")
448 (license license:lgpl2.1)))
449
450 (define-public kpmcore
451 (package
452 (name "kpmcore")
453 (version "4.0.1")
454 (source (origin
455 (method url-fetch)
456 (uri (string-append
457 "mirror://kde/stable/kpmcore"
458 "/" version "/src/"
459 name "-" version ".tar.xz"))
460 (sha256
461 (base32
462 "1sslkwcj2cyrn7bpjdjdwikp1q8wrsxpsg2sxxd8hsairgy7ygh3"))
463 (patches (search-patches "kpmcore-fix-tests.patch"
464 "kpmcore-remove-broken-test.patch"))))
465 (build-system cmake-build-system)
466 (native-inputs
467 `(("extra-cmake-modules" ,extra-cmake-modules)
468 ("pkg-config" ,pkg-config)))
469 (inputs
470 `(("kauth" ,kauth)
471 ("kcoreaddons" ,kcoreaddons)
472 ("ki18n" ,ki18n)
473 ("kwidgetsaddons" ,kwidgetsaddons)
474 ("qtbase" ,qtbase)
475 ("qca" ,qca)
476 ("util-linux" ,util-linux)))
477 (home-page "https://community.kde.org/Frameworks")
478 (synopsis "Library for managing partitions")
479 (description "Library for managing partitions.")
480 (license license:gpl3+)))
481
482 (define-public snorenotify
483 (package
484 (name "snorenotify")
485 (version "0.7.0")
486 (source
487 (origin
488 (method url-fetch)
489 (uri (string-append "mirror://kde/stable/snorenotify/"
490 version "/src/snorenotify-" version ".tar.xz"))
491 (sha256
492 (base32
493 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
494 (build-system cmake-build-system)
495 (arguments
496 `(#:tests? #f)) ; both tests fail, require display
497 (inputs
498 `(("qtbase" ,qtbase)))
499 (native-inputs
500 `(("extra-cmake-modules" ,extra-cmake-modules)
501 ("qttools" ,qttools)))
502 (home-page "https://techbase.kde.org/Projects/Snorenotify")
503 (synopsis "Qt notification framework")
504 (description "Snorenotify is a multi platform Qt notification framework.
505 Using a plugin system it is possible to create notifications with many
506 different notification systems.")
507 (license license:lgpl3)))
508
509 (define-public kdeconnect
510 (package
511 (name "kdeconnect")
512 (version "1.3.5")
513 (source
514 (origin
515 (method url-fetch)
516 (uri (string-append "mirror://kde/stable/kdeconnect/"
517 version "/kdeconnect-kde-"
518 version ".tar.xz"))
519 (sha256
520 (base32
521 "02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
522 (build-system qt-build-system)
523 (arguments
524 `(#:configure-flags '("-DBUILD_TESTING=ON")
525 #:tests? #f ; tests fail hard in our build environment
526 #:phases
527 (modify-phases %standard-phases
528 (add-before 'check 'check-setup
529 (lambda _
530 (setenv "QT_QPA_PLATFORM" "offscreen")
531 #t)))))
532 (native-inputs
533 `(("extra-cmake-modules" ,extra-cmake-modules)
534 ("kdoctools" ,kdoctools)
535 ("libxtst" ,libxtst)
536 ("pkg-config" ,pkg-config)
537 ("python" ,python-wrapper)))
538 (inputs
539 `(("kcmutils" ,kcmutils)
540 ("kconfigwidgets" ,kconfigwidgets)
541 ("kdbusaddons" ,kdbusaddons)
542 ("ki18n" ,ki18n)
543 ("kiconthemes" ,kiconthemes)
544 ("kio" ,kio)
545 ("knotifications" ,knotifications)
546 ("kwayland" ,kwayland)
547 ("libfakekey" ,libfakekey)
548 ("qca" ,qca)
549 ("qtbase" ,qtbase)
550 ("qtdeclarative" ,qtdeclarative)
551 ("qtx11extras" ,qtx11extras)))
552 (home-page "https://community.kde.org/KDEConnect")
553 (synopsis "Enable your devices to communicate with each other")
554 (description "KDE Connect is a project that enables all your devices to
555 communicate with each other. Here's a few things KDE Connect can do:
556 @enumerate
557 @item Receive your phone notifications on your desktop computer and reply to messages
558 @item Control music playing on your desktop from your phone
559 @item Use your phone as a remote control for your desktop
560 @item Run predefined commands on your PC from connected devices
561 @item Check your phones battery level from the desktop
562 @item Ring your phone to help finding it
563 @item Share files and links between devices
564 @item Browse your phone from the desktop
565 @item Control the desktop's volume from the phone
566 @end enumerate")
567 (properties `((upstream-name . "kdeconnect-kde")))
568 (license (list license:gpl2 license:gpl3)))) ; dual licensed
569
570 (define-public kqtquickcharts
571 (package
572 (name "kqtquickcharts")
573 (version "19.08.2")
574 (source
575 (origin
576 (method url-fetch)
577 (uri (string-append "mirror://kde/stable/applications/"
578 version "/src/kqtquickcharts-" version ".tar.xz"))
579 (sha256
580 (base32
581 "1yy9fyd8y4g25ljdsbil19qdf4j3mzmzl489sx7rqpm3lfdzjh9k"))))
582 (build-system cmake-build-system)
583 (native-inputs
584 `(("extra-cmake-modules" ,extra-cmake-modules)))
585 (inputs
586 `(("qtbase" ,qtbase)
587 ("qtdeclarative" ,qtdeclarative)))
588 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
589 (synopsis "Interactive charts for Qt Quick")
590 (description
591 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
592 charts.")
593 (license license:lgpl2.1+)))
594
595 (define-public kcachegrind
596 (package
597 (name "kcachegrind")
598 (version "19.04.1")
599 (source (origin
600 (method url-fetch)
601 (uri (string-append "mirror://kde/stable/applications/" version
602 "/src/kcachegrind-" version ".tar.xz"))
603 (sha256
604 (base32
605 "1hhsk64yp6q2xh8j269j4wp9y24ggmii861r6gf02mj1mbn2p1jb"))))
606 (build-system cmake-build-system)
607 (native-inputs
608 `(("extra-cmake-modules" ,extra-cmake-modules)
609 ("perl" ,perl)
610 ("python" ,python)
611 ("qttools" ,qttools)
612 ("kdoctools" ,kdoctools)))
613 (inputs
614 `(("qtbase" ,qtbase)
615 ("karchive" ,karchive)
616 ("ki18n" ,ki18n)
617 ("kio" ,kio)
618 ("kdbusaddons" ,kdbusaddons)))
619 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
620 ;; Python and PHP, respectively. These are optional and we ignore them
621 ;; for now.
622 (home-page "https://kcachegrind.github.io/html/Home.html")
623 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
624 (description
625 "The data files generated by the Callgrind of Valgrind, an application
626 profiler, can be loaded into KCachegrind for browsing the performance results.
627 There is also a command-line tool to get ASCII reports from data files without
628 the need to use KCachegrind.
629
630 The format of Callgrind output is documented. With conversion scripts,
631 KCachegrind is able to visualize output of other profilers like OProfile, a
632 system-wide profiler for Linux using statistical sampling with hardware
633 performance counters. There also exist converters for profiling output of
634 Python, PHP, and Perl.")
635 (license license:gpl2)))
636
637 (define-public libkdegames
638 (package
639 (name "libkdegames")
640 (version "19.08.3")
641 (source
642 (origin
643 (method url-fetch)
644 (uri (string-append "mirror://kde/stable/applications/" version
645 "/src/libkdegames-" version ".tar.xz"))
646 (sha256
647 (base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
648 (build-system cmake-build-system)
649 (native-inputs
650 `(("extra-cmake-modules" ,extra-cmake-modules)))
651 (inputs
652 `(("karchive" ,karchive)
653 ("kbookmarks" ,kbookmarks)
654 ("kcodecs" ,kcodecs)
655 ("kcompletion" ,kcompletion)
656 ("kconfigwidgets" ,kconfigwidgets)
657 ("kcrash" ,kcrash)
658 ("kdbusaddons" ,kdbusaddons)
659 ("kdeclarative" ,kdeclarative)
660 ("kdnssd" ,kdnssd)
661 ("kglobalaccel" ,kglobalaccel)
662 ("kguiaddons" ,kguiaddons)
663 ("ki18n" ,ki18n)
664 ("kiconthemes" ,kiconthemes)
665 ;("kio" ,kio)
666 ("kitemviews" ,kitemviews)
667 ("kjobwidgets" ,kjobwidgets)
668 ("knewstuff" ,knewstuff)
669 ("kservice" ,kservice)
670 ("ktextwidgets" ,ktextwidgets)
671 ("kwidgetsaddons" ,kwidgetsaddons)
672 ("kxmlgui" ,kxmlgui)
673 ("libsndfile" ,libsndfile)
674 ("openal" ,openal)
675 ("qtbase" ,qtbase)
676 ("qtdeclarative" ,qtdeclarative)
677 ("qtsvg" ,qtsvg)))
678 (arguments
679 `(#:phases
680 (modify-phases %standard-phases
681 (add-before 'check 'check-setup
682 (lambda _
683 ;; make Qt render "offscreen", required for tests
684 (setenv "QT_QPA_PLATFORM" "offscreen")
685 #t)))))
686 (home-page "https://games.kde.org/")
687 (synopsis "Runtime library for kdegames")
688 (description "Runtime library for kdegames")
689 (license (list license:gpl2+ license:fdl1.2+))))
690
691 (define-public zeroconf-ioslave
692 (package
693 (name "zeroconf-ioslave")
694 (version "19.08.3")
695 (source
696 (origin
697 (method url-fetch)
698 (uri (string-append "mirror://kde/stable/applications/" version
699 "/src/zeroconf-ioslave-" version ".tar.xz"))
700 (sha256
701 (base32 "1vbi4kpyrk530q2dj8ql2i0gxjybdbmkqpl8vkhrihl7r7f0xc5p"))))
702 (build-system qt-build-system)
703 (native-inputs
704 `(("extra-cmake-modules" ,extra-cmake-modules)))
705 (inputs
706 `(("kdbusaddons" ,kdbusaddons)
707 ("kdnssd" ,kdnssd)
708 ("ki18n" ,ki18n)
709 ("kio" ,kio)
710 ("qtbase" ,qtbase)))
711 (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
712 (synopsis "DNS-SD Service Discovery Monitor")
713 (description "Adds an entry to Dolphin's Network page to show local
714 services such as printers which advertise themselves with DNSSD (called Avahi
715 or Bonjour by other projects).")
716 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
717 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))