gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / gnome-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
3 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
4 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages gnome-xyz)
22 #:use-module (guix build-system trivial)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix git-download)
25 #:use-module (guix packages)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages bash)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages gnome)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages ruby)
34 #:use-module (gnu packages xml))
35
36 (define-public matcha-theme
37 (package
38 (name "matcha-theme")
39 (version "2019-11-02")
40 (source
41 (origin
42 (method git-fetch)
43 (uri
44 (git-reference
45 (url "https://github.com/vinceliuice/matcha")
46 (commit version)))
47 (file-name (git-file-name name version))
48 (sha256
49 (base32
50 "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
51 (build-system trivial-build-system)
52 (arguments
53 '(#:modules ((guix build utils))
54 #:builder
55 (begin
56 (use-modules (guix build utils))
57 (let* ((out (assoc-ref %outputs "out"))
58 (source (assoc-ref %build-inputs "source"))
59 (bash (assoc-ref %build-inputs "bash"))
60 (coreutils (assoc-ref %build-inputs "coreutils"))
61 (themesdir (string-append out "/share/themes")))
62 (setenv "PATH"
63 (string-append coreutils "/bin:"
64 (string-append bash "/bin:")))
65 (copy-recursively source (getcwd))
66 (patch-shebang "Install")
67 (mkdir-p themesdir)
68 (invoke "./Install" "-d" themesdir)
69 #t))))
70 (inputs
71 `(("gtk-engines" ,gtk-engines)))
72 (native-inputs
73 `(("bash" ,bash)
74 ("coreutils" ,coreutils)))
75 (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
76 (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
77 Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
78 like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
79 (home-page "https://github.com/vinceliuice/matcha")
80 (license license:gpl3+)))
81
82 (define-public delft-icon-theme
83 (package
84 (name "delft-icon-theme")
85 (version "1.10")
86 (source
87 (origin
88 (method git-fetch)
89 (uri (git-reference
90 (url "https://github.com/madmaxms/iconpack-delft.git")
91 (commit (string-append "v" version))))
92 (sha256
93 (base32
94 "0vw3yw9f9ygzfd2k3zrfih3r0vkzlhk1bmsk8sapvk7np24i1z9s"))
95 (file-name (git-file-name name version))))
96 (build-system trivial-build-system)
97 (arguments
98 `(#:modules ((guix build utils))
99 #:builder
100 (begin
101 (use-modules (guix build utils))
102 (copy-recursively (assoc-ref %build-inputs "source") "icons")
103 (substitute* "icons/Delft/index.theme"
104 (("gnome") "Adwaita"))
105 (delete-file "icons/README.md")
106 (delete-file "icons/LICENSE")
107 (delete-file "icons/logo.jpg")
108 (copy-recursively "icons" (string-append %output "/share/icons")))))
109 (home-page "https://www.gnome-look.org/p/1199881/")
110 (synopsis "Continuation of Faenza icon theme with up to date app icons")
111 (description "Delft is a fork of the popular icon theme Faenza with up to
112 date app icons. It will stay optically close to the original Faenza icons,
113 which haven't been updated for some years. The new app icons are ported from
114 the Obsidian icon theme.")
115 (license license:gpl3)))
116
117 (define-public gnome-shell-extension-dash-to-dock
118 (package
119 (name "gnome-shell-extension-dash-to-dock")
120 (version "66")
121 (source (origin
122 (method git-fetch)
123 (uri (git-reference
124 (url "https://github.com/micheleg/dash-to-dock.git")
125 (commit (string-append "extensions.gnome.org-v"
126 version))))
127 (sha256
128 (base32
129 "04krl6rxlp1qc97psraf2kwin7h0mx4c7pnfpi7vhplmvasrwkfh"))
130 (file-name (git-file-name name version))))
131 (build-system gnu-build-system)
132 (arguments
133 '(#:tests? #f
134 #:make-flags (list (string-append "INSTALLBASE="
135 (assoc-ref %outputs "out")
136 "/share/gnome-shell/extensions"))
137 #:phases
138 (modify-phases %standard-phases
139 (delete 'bootstrap)
140 (delete 'configure))))
141 (native-inputs
142 `(("glib:bin" ,glib "bin")
143 ("intltool" ,intltool)
144 ("pkg-config" ,pkg-config)))
145 (propagated-inputs
146 `(("glib" ,glib)))
147 (synopsis "Transforms GNOME's dash into a dock")
148 (description "This extension moves the dash out of the
149 overview, transforming it into a dock for easier application launching and
150 faster window switching.")
151 (home-page "https://micheleg.github.io/dash-to-dock/")
152 (license license:gpl2+)))
153
154 (define-public gnome-shell-extension-hide-app-icon
155 (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
156 (revision "0"))
157 (package
158 (name "gnome-shell-extension-hide-app-icon")
159 (version (git-version "2.7" revision commit))
160 (source
161 (origin
162 (method git-fetch)
163 (uri (git-reference
164 (url (string-append "https://github.com/michael-rapp"
165 "/gnome-shell-extension-hide-app-icon.git"))
166 (commit commit)))
167 (sha256
168 (base32
169 "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
170 (file-name (git-file-name name version))))
171 (build-system gnu-build-system)
172 (arguments
173 '(#:tests? #f ; no test target
174 #:make-flags (list (string-append "EXTENSIONS_DIR="
175 (assoc-ref %outputs "out")
176 "/share/gnome-shell/extensions"))
177 #:phases
178 (modify-phases %standard-phases
179 (delete 'configure) ; no configure script
180 (replace 'install
181 (lambda* (#:key outputs #:allow-other-keys)
182 (let ((out (assoc-ref outputs "out"))
183 (pre "/share/gnome-shell/extensions/")
184 (dir "hide-app-icon@mrapp.sourceforge.com"))
185 (copy-recursively dir (string-append out pre dir))
186 #t))))))
187 (native-inputs
188 `(("glib" ,glib "bin")
189 ("intltool" ,intltool)))
190 (propagated-inputs
191 `(("glib" ,glib)))
192 (synopsis "Hide app icon from GNOME's panel")
193 (description "This extension allows to hide the icon and/or title of the
194 currently focused application in the top panel of the GNOME shell.")
195 (home-page
196 "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
197 (license
198 ;; README.md and LICENSE.txt disagree -- the former claims v3, the
199 ;; latter v2. No mention of "or later" in either place or in the code.
200 (list license:gpl2
201 license:gpl3)))))
202
203 (define-public gnome-shell-extension-dash-to-panel
204 (package
205 (name "gnome-shell-extension-dash-to-panel")
206 (version "26")
207 (source (origin
208 (method git-fetch)
209 (uri (git-reference
210 (url "https://github.com/home-sweet-gnome/dash-to-panel.git")
211 (commit (string-append "v" version))))
212 (sha256
213 (base32
214 "1phfx2pblygpcvsppsqqqflm7qnz46mqkw29hj0nv2dn69hf4xbc"))
215 (file-name (git-file-name name version))))
216 (build-system gnu-build-system)
217 (arguments
218 `(#:tests? #f
219 #:make-flags (list (string-append "INSTALLBASE="
220 (assoc-ref %outputs "out")
221 "/share/gnome-shell/extensions")
222 (string-append "VERSION="
223 ,(package-version
224 gnome-shell-extension-dash-to-panel)))
225 #:phases
226 (modify-phases %standard-phases
227 (delete 'bootstrap)
228 (delete 'configure))))
229 (native-inputs
230 `(("intltool" ,intltool)
231 ("pkg-config" ,pkg-config)))
232 (propagated-inputs
233 `(("glib" ,glib)
234 ("glib" ,glib "bin")))
235 (synopsis "Icon taskbar for GNOME Shell")
236 (description "This extension moves the dash into the gnome main
237 panel so that the application launchers and system tray are combined
238 into a single panel, similar to that found in KDE Plasma and Windows 7+.")
239 (home-page "https://github.com/home-sweet-gnome/dash-to-panel/")
240 (license license:gpl2+)))
241
242 (define-public gnome-shell-extension-noannoyance
243 (package
244 (name "gnome-shell-extension-noannoyance")
245 (version "5")
246 (source (origin
247 (method git-fetch)
248 (uri (git-reference
249 (url "https://github.com/BjoernDaase/noannoyance.git")
250 (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
251 (sha256
252 (base32
253 "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
254 (file-name (git-file-name name version))))
255 (build-system trivial-build-system)
256 (arguments
257 '(#:modules ((guix build utils))
258 #:builder
259 (begin
260 (use-modules (guix build utils))
261 (let ((dst (string-append
262 (assoc-ref %outputs "out")
263 "/share/gnome-shell/extensions/"
264 "noannoyance@daase.net")))
265 (mkdir-p dst)
266 (copy-recursively (assoc-ref %build-inputs "source") dst)))))
267 (synopsis "Removes 'Window is ready' annotation")
268 (description "One of the many extensions, that remove this message.
269 It uses ES6 syntax and claims to be more actively maintained than others.")
270 (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
271 (license license:gpl2)))
272
273 (define-public numix-theme
274 (package
275 (name "numix-theme")
276 (version "2.6.7")
277 (source (origin
278 (method git-fetch)
279 (uri (git-reference
280 (url "https://github.com/numixproject/numix-gtk-theme.git")
281 (commit version)))
282 (file-name (git-file-name name version))
283 (sha256
284 (base32
285 "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
286 (build-system gnu-build-system)
287 (arguments
288 '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
289 #:phases
290 (modify-phases %standard-phases
291 (delete 'configure)
292 (delete 'check))))
293 (native-inputs
294 `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
295 ("gnome-shell" ,gnome-shell)
296 ("gtk+" ,gtk+)
297 ("xmllint" ,libxml2)
298 ("ruby-sass" ,ruby-sass)))
299 (synopsis "Flat theme with light and dark elements")
300 (description "Numix is a modern flat theme with a combination of light and
301 dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
302 (home-page "https://numixproject.github.io")
303 (license license:gpl3+)))
304
305 (define-public papirus-icon-theme
306 (let ((version "0.0.0") ;; The package does not use semver
307 (revision "0")
308 (tag "20191201"))
309 (package
310 (name "papirus-icon-theme")
311 (version (git-version version revision tag))
312 (source
313 (origin
314 (method git-fetch)
315 (uri (git-reference
316 (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git")
317 (commit tag)))
318 (sha256
319 (base32
320 "0lnz1kmz28xh1f4slbsx7ycji5hgszyiyprbf5w5fbjhvi5gzw1h"))
321 (file-name (git-file-name name version))))
322 (build-system gnu-build-system)
323 (arguments
324 '(#:tests? #f
325 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
326 #:phases
327 (modify-phases %standard-phases
328 (delete 'bootstrap)
329 (delete 'configure)
330 (delete 'build))))
331 (native-inputs
332 `(("gtk+:bin" ,gtk+ "bin")))
333 (home-page "https://git.io/papirus-icon-theme")
334 (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
335 (description "Papirus is a fork of the icon theme Paper with a lot of new icons
336 and a few extra features.")
337 (license license:gpl3))))