gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / gcal.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gcal)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses))
24
25 (define-public gcal
26 (package
27 (name "gcal")
28 (version "4.1")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://gnu/gcal/gcal-"
32 version ".tar.xz"))
33 (sha256
34 (base32
35 "1av11zkfirbixn05hyq4xvilin0ncddfjqzc4zd9pviyp506rdci"))
36 (modules '((guix build utils)))
37 (snippet
38 '(begin
39 ;; Adjust the bundled gnulib to work with glibc 2.28. See e.g.
40 ;; "m4-gnulib-libio.patch". This is a phase rather than patch
41 ;; or snippet to work around <https://bugs.gnu.org/32347>.
42 (substitute* (find-files "lib" "\\.c$")
43 (("#if defined _IO_ftrylockfile")
44 "#if defined _IO_EOF_SEEN"))
45 (substitute* "lib/stdio-impl.h"
46 (("^/\\* BSD stdio derived implementations")
47 (string-append "#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN\n"
48 "# define _IO_IN_BACKUP 0x100\n"
49 "#endif\n\n"
50 "/* BSD stdio derived implementations")))
51 #t))))
52 (build-system gnu-build-system)
53 (home-page "https://www.gnu.org/software/gcal/")
54 (synopsis "Calculating and printing a wide variety of calendars")
55 (description
56 "Gcal is a program to calculate and print calendars on the
57 command-line. Calendars can be printed in 1-month, 3-month or whole-year
58 views. In addition, eternal holiday lists can be generated for many
59 countries, which can be complemented by user-made lists of fixed dates to
60 make an agenda. Gcal can also calculate astronomical data, such as the
61 phases of the moon, and supports alternative calendar formats: Julian,
62 Gregorian, Islamic, Chinese and more.")
63 (license gpl3+)))