gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / distributed.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Brant Gardner <brantcgardner@brantware.com>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages distributed)
21 #:use-module (guix packages)
22 #:use-module (guix utils)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages autotools)
29 #:use-module (gnu packages base)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages databases)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages tls)
34 #:use-module (gnu packages curl)
35 #:use-module (gnu packages wxwidgets)
36 #:use-module (gnu packages gnome)
37 #:use-module (gnu packages gtk)
38 #:use-module (gnu packages perl)
39 #:use-module (gnu packages sqlite)
40 #:use-module (gnu packages python)
41 #:use-module (gnu packages python-xyz))
42
43 (define-public boinc-client
44 (package
45 (name "boinc-client")
46 (version "7.16.3")
47 (source (origin
48 (method git-fetch)
49 (uri (git-reference
50 (url "https://github.com/boinc/boinc.git")
51 (commit (string-append "client_release/"
52 (version-major+minor version)
53 "/" version))))
54 (file-name (git-file-name "boinc" version))
55 (sha256
56 (base32
57 "1l181s7wnx0xd7m62qjixdjw4ri87q47xi0x662m2jsh9lzb8khf"))))
58 (build-system gnu-build-system)
59 (arguments '(#:configure-flags '("--disable-server")))
60 (inputs `(("openssl" ,openssl)
61 ("curl" ,curl)
62 ("wxwidgets" ,wxwidgets)
63 ("gtk+" ,gtk+)
64 ("gdk-pixbuf" ,gdk-pixbuf)
65 ("libnotify" ,libnotify)
66 ("sqlite" ,sqlite)
67 ("python" ,python)
68 ("python-pyserial" ,python-pyserial)))
69 (native-inputs
70 `(("autoconf" ,autoconf)
71 ("automake" ,automake)
72 ("libtool" ,libtool)
73 ("pkg-config" ,pkg-config)))
74 (synopsis "BOINC lets you help cutting-edge science research using your computer")
75 (description "BOINC is a platform for high-throughput computing on a large
76 scale (thousands or millions of computers). It can be used for volunteer
77 computing (using consumer devices) or grid computing (using organizational
78 resources). It supports virtualized, parallel, and GPU-based applications.")
79 (home-page "https://boinc.berkeley.edu/")
80 ;; BOINC is distributed as LGPL3+, with some individual modules under GPL3+.
81 (license (list license:lgpl3+ license:gpl3+))))
82
83 (define-public boinc-server
84 (package (inherit boinc-client)
85 (name "boinc-server")
86 (arguments '(#:configure-flags '("--disable-client" "--disable-manager")
87 #:parallel-build? #f
88 #:tests? #f)) ; FIXME: Looks like bad test syntax in the
89 ; source package, 2 tests fail. Disable for
90 ; now.
91 (inputs `(("openssl" ,openssl)
92 ("curl" ,curl)
93 ("mariadb" ,mariadb)
94 ("zlib" ,zlib)))
95 (propagated-inputs `(("python" ,python-wrapper)
96 ("perl" ,perl)))))