gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / datastructures.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016, 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
5 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages datastructures)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages perl)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix git-download)
29 #:use-module (guix build-system cmake)
30 #:use-module (guix build-system gnu))
31
32 (define-public gdsl
33 (package
34 (name "gdsl")
35 (version "1.8")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "http://download.gna.org/gdsl/"
39 "gdsl-" version ".tar.gz"))
40 (sha256
41 (base32
42 "1v64jvlnj8jfpphphgjgb36p0kv50kwfyqncf0y12f16v8ydyiaw"))))
43 (build-system gnu-build-system)
44 (home-page "http://home.gna.org/gdsl/")
45 (synopsis "Generic data structures library")
46 (description "The Generic Data Structures Library (GDSL) is a collection
47 of routines for generic data structures manipulation. It is a re-entrant
48 library fully written from scratch in pure ANSI C. It is designed to offer
49 for C programmers common data structures with powerful algorithms, and hidden
50 implementation. Available structures are lists, queues, stacks, hash tables,
51 binary trees, binary search trees, red-black trees, 2D arrays, permutations
52 and heaps.")
53 (license license:gpl2+)))
54
55 (define-public marisa
56 (package
57 (name "marisa")
58 (version "0.2.5")
59 (source
60 (origin
61 (method url-fetch)
62 (uri (string-append "https://github.com/s-yata/marisa-trie"
63 "/releases/download/v" version "/" name "-"
64 version ".tar.gz"))
65 (sha256
66 (base32 "19ifrcmnbr9whaaf4ly3s9ndyiq9sjqhnfkrxbz9zsb44w2n36hf"))))
67 (build-system gnu-build-system)
68 (home-page "https://github.com/s-yata/marisa-trie")
69 (synopsis "Trie data structure C++ library")
70 (description "Matching Algorithm with Recursively Implemented
71 StorAge (MARISA) is a static and space-efficient trie data structure C++
72 library.")
73
74 ;; Dual-licensed, according to docs/readme.en.html (source files lack
75 ;; copyright/license headers.)
76 (license (list license:bsd-2 license:lgpl2.1+))))
77
78 (define-public sparsehash
79 (package
80 (name "sparsehash")
81 (version "2.0.3")
82 (source (origin
83 (method git-fetch)
84 (uri (git-reference
85 (url "https://github.com/sparsehash/sparsehash.git")
86 (commit (string-append name "-" version))))
87 (file-name (git-file-name name version))
88 (sha256
89 (base32
90 "0m3f0cnpnpf6aak52wn8xbrrdw8p0yhq8csgc8nlvf9zp8c402na"))))
91 (build-system gnu-build-system)
92 (synopsis "Memory-efficient hashtable implementations")
93 (description
94 "This library contains several hash-map implementations, similar in API
95 to SGI's @code{hash_map} class, but with different performance
96 characteristics. @code{sparse_hash_map} uses very little space overhead, 1-2
97 bits per entry. @code{dense_hash_map} is very fast, particularly on lookup.
98 @code{sparse_hash_set} and @code{dense_hash_set} are the set versions of these
99 routines. All these implementation use a hashtable with internal quadratic
100 probing. This method is space-efficient -- there is no pointer overhead --
101 and time-efficient for good hash functions.")
102 (home-page "https://github.com/sparsehash/sparsehash")
103 (license license:bsd-3)))
104
105 (define-public ssdeep
106 (package
107 (name "ssdeep")
108 (version "2.13")
109 (source (origin
110 (method url-fetch)
111 (uri (string-append "mirror://sourceforge/ssdeep/"
112 name "-" version "/"
113 name "-" version ".tar.gz"))
114 (sha256
115 (base32
116 "1igqy0j7jrklb8fdlrm6ald4cyl1fda5ipfl8crzyl6bax2ajk3f"))))
117 (build-system gnu-build-system)
118 (home-page "http://ssdeep.sourceforge.net")
119 (synopsis "Context-triggered piecewise hashing algorithm")
120 (description "ssdeep computes and matches context triggered piecewise
121 hashes (CTPH), also called fuzzy checksums. It can identify similar files
122 that have sequences of identical bytes in the same order, even though bytes
123 in between these sequences may be different in both content and length.")
124 (license license:gpl2+)))
125
126 (define-public liburcu
127 (package
128 (name "liburcu")
129 (version "0.11.1")
130 (source (origin
131 (method url-fetch)
132 (uri (string-append "https://www.lttng.org/files/urcu/"
133 "userspace-rcu-" version ".tar.bz2"))
134 (sha256
135 (base32
136 "0l1kxgzch4m8fxiz2hc8fwg56hrvzzspp7n0svnl7i7iycdrgfcj"))))
137 (build-system gnu-build-system)
138 (native-inputs
139 `(("perl" ,perl))) ; for tests
140 (home-page "https://liburcu.org/")
141 (synopsis "User-space RCU data synchronisation library")
142 (description "liburcu is a user-space @dfn{Read-Copy-Update} (RCU) data
143 synchronisation library. It provides read-side access that scales linearly
144 with the number of cores. liburcu-cds provides efficient data structures
145 based on RCU and lock-free algorithms. These structures include hash tables,
146 queues, stacks, and doubly-linked lists.")
147 (license license:lgpl2.1+)))
148
149 (define-public uthash
150 (package
151 (name "uthash")
152 (version "2.0.2")
153 (source
154 (origin
155 (method git-fetch)
156 (uri (git-reference
157 (url "https://github.com/troydhanson/uthash.git")
158 (commit (string-append "v" version))))
159 (file-name (git-file-name name version))
160 (sha256
161 (base32
162 "0kslz8k6lssh7fl7ayzwlj62p0asxs3dq03357ls5ywjad238gqg"))))
163 (build-system gnu-build-system)
164 (native-inputs
165 `(("perl" ,perl)))
166 (arguments
167 `(#:make-flags
168 (list "CC=gcc")
169 #:phases
170 (modify-phases %standard-phases
171 (delete 'configure) ; nothing to configure
172 (delete 'build) ; nothing to build
173 (replace 'check
174 (lambda* (#:key make-flags #:allow-other-keys)
175 (with-directory-excursion "tests"
176 (apply invoke "make" make-flags))))
177 (replace 'install
178 ;; There is no top-level Makefile to do this for us.
179 (lambda* (#:key outputs #:allow-other-keys)
180 (let* ((out (assoc-ref outputs "out"))
181 (doc (string-append out "/share/doc/" ,name))
182 (include (string-append out "/include")))
183 ;; Don't install HTML files: they're just the below .txt files
184 ;; dolled up, can be stale, and regeneration requires asciidoc.
185 (for-each (λ (file) (install-file file doc))
186 (find-files "doc" "\\.txt$"))
187 (for-each (λ (file) (install-file file include))
188 (find-files "src" "\\.h$"))
189 #t))))))
190 (home-page "https://troydhanson.github.io/uthash/")
191 (synopsis
192 "Hash tables, lists, and other data structures implemented as C macros")
193 (description
194 "uthash implements a hash table and a few other basic data structures
195 as C preprocessor macros. It aims to be minimalistic and efficient: it's
196 around 1,000 lines of code which, being macros, inline automatically.
197
198 Unlike function calls with fixed prototypes, macros operate on untyped
199 arguments. Thus, they are able to work with any type of structure and key.
200 Any C structure can be stored in a hash table by adding @code{UT_hash_handle}
201 to the structure and choosing one or more fields to act as the key.")
202 (license license:bsd-2)))
203
204 (define-public sdsl-lite
205 (package
206 (name "sdsl-lite")
207 (version "2.1.1")
208 (source (origin
209 (method url-fetch)
210 (uri (string-append "https://github.com/simongog/sdsl-lite/"
211 "releases/download/v" version "/"
212 "sdsl-lite-" version
213 ".tar.gz.offline.install.gz"))
214 (sha256
215 (base32
216 "1v86ivv3mmdy802i9xkjpxb4cggj3s27wb19ja4sw1klnivjj69g"))
217 (modules '((guix build utils)))
218 (snippet
219 '(begin
220 (delete-file-recursively "external") #t))
221 (patches
222 (list (origin
223 (method url-fetch)
224 (uri "https://salsa.debian.org/science-team/libsdsl/raw/debian/2.1.1+dfsg-2/debian/patches/0001-Patch-cmake-files.patch")
225 (file-name "sdsl-lite-dont-use-bundled-libraries.patch")
226 (sha256
227 (base32
228 "0m542xpys54bni29zibgrfpgpd0zgyny4h131virxsanixsbz52z")))))))
229 (build-system cmake-build-system)
230 (arguments
231 '(#:phases
232 (modify-phases %standard-phases
233 (add-after 'install 'install-static-library
234 (lambda* (#:key outputs #:allow-other-keys)
235 (let ((out (assoc-ref outputs "out")))
236 (copy-file "lib/libsdsl_static.a"
237 (string-append out "/lib/libsdsl.a")))
238 #t)))))
239 (native-inputs
240 `(("libdivsufsort" ,libdivsufsort)))
241 (home-page "https://github.com/simongog/sdsl-lite")
242 (synopsis "Succinct data structure library")
243 (description "The Succinct Data Structure Library (SDSL) is a powerful and
244 flexible C++11 library implementing succinct data structures. In total, the
245 library contains the highlights of 40 research publications. Succinct data
246 structures can represent an object (such as a bitvector or a tree) in space
247 close to the information-theoretic lower bound of the object while supporting
248 operations of the original object efficiently. The theoretical time
249 complexity of an operation performed on the classical data structure and the
250 equivalent succinct data structure are (most of the time) identical.")
251 (license license:gpl3+)))
252
253 (define-public libdivsufsort
254 (package
255 (name "libdivsufsort")
256 (version "2.0.1")
257 (source (origin
258 (method git-fetch)
259 (uri (git-reference
260 (url "https://github.com/y-256/libdivsufsort.git")
261 (commit version)))
262 (file-name (git-file-name name version))
263 (sha256
264 (base32
265 "0fgdz9fzihlvjjrxy01md1bv9vh12rkgkwbm90b1hj5xpbaqp7z2"))))
266 (build-system cmake-build-system)
267 (arguments
268 '(#:tests? #f ; there are no tests
269 #:configure-flags
270 ;; Needed for rapmap and sailfish.
271 '("-DBUILD_DIVSUFSORT64=ON")))
272 (home-page "https://github.com/y-256/libdivsufsort")
273 (synopsis "Lightweight suffix-sorting library")
274 (description "libdivsufsort is a software library that implements a
275 lightweight suffix array construction algorithm. This library provides a
276 simple and an efficient C API to construct a suffix array and a
277 Burrows-Wheeler transformed string from a given string over a constant-size
278 alphabet. The algorithm runs in O(n log n) worst-case time using only 5n+O(1)
279 bytes of memory space, where n is the length of the string.")
280 (license license:expat)))