gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / cups.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
6 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
8 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages cups)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages algebra)
28 #:use-module (gnu packages autotools)
29 #:use-module (gnu packages avahi)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages fonts) ; font-dejavu
32 #:use-module (gnu packages fontutils)
33 #:use-module (gnu packages ghostscript)
34 #:use-module (gnu packages glib)
35 #:use-module (gnu packages groff)
36 #:use-module (gnu packages image)
37 #:use-module (gnu packages libusb)
38 #:use-module (gnu packages pdf)
39 #:use-module (gnu packages perl)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages polkit)
42 #:use-module (gnu packages pretty-print)
43 #:use-module (gnu packages python)
44 #:use-module (gnu packages python-xyz)
45 #:use-module (gnu packages qt)
46 #:use-module (gnu packages scanner)
47 #:use-module (gnu packages tls)
48 #:use-module (guix build-system gnu)
49 #:use-module (guix build-system python)
50 #:use-module (guix download)
51 #:use-module (guix svn-download)
52 #:use-module ((guix licenses) #:prefix license:)
53 #:use-module (guix packages)
54 #:use-module (guix utils)
55 #:use-module (srfi srfi-1)
56 #:use-module (ice-9 match))
57
58 (define-public cups-filters
59 (package
60 (name "cups-filters")
61 (version "1.25.11")
62 (source(origin
63 (method url-fetch)
64 (uri
65 (string-append "https://openprinting.org/download/cups-filters/"
66 "cups-filters-" version ".tar.xz"))
67 (sha256
68 (base32
69 "0ni8krr4rf5833livn9401cd41gspjvxj0iiqnc1rfg3x90i0fxh"))
70 (modules '((guix build utils)))
71 (snippet
72 ;; install backends, banners and filters to cups-filters output
73 ;; directory, not the cups server directory
74 '(begin
75 (substitute* "Makefile.in"
76 (("CUPS_DATADIR = @CUPS_DATADIR@")
77 "CUPS_DATADIR = $(PREFIX)/share/cups")
78 (("pkgcupsserverrootdir = \\$\\(CUPS_SERVERROOT\\)")
79 "pkgcupsserverrootdir = $(PREFIX)")
80 ;; Choose standard directories notably so that binaries are
81 ;; stripped.
82 (("pkgbackenddir = \\$\\(CUPS_SERVERBIN\\)/backend")
83 "pkgbackenddir = $(PREFIX)/lib/cups/backend")
84 (("pkgfilterdir = \\$\\(CUPS_SERVERBIN\\)/filter")
85 "pkgfilterdir = $(PREFIX)/lib/cups/filter"))
86 ;; Find bannertopdf data such as the print test page in our
87 ;; output directory, not CUPS's prefix.
88 (substitute* "configure"
89 (("\\{CUPS_DATADIR\\}/data")
90 "{prefix}/share/cups/data"))
91 #t))))
92 (build-system gnu-build-system)
93 (arguments
94 `(#:make-flags (list (string-append "PREFIX=" %output))
95 #:configure-flags
96 `("--disable-driverless" ; TODO: enable this
97 "--disable-mutool" ; depends on yet another PDF library (mupdf)
98
99 ;; Look for the "domain socket of CUPS" in /var/run/cups.
100 "--localstatedir=/var"
101
102 ;; Free software for the win.
103 "--with-acroread-path=evince"
104
105 ,(string-append "--with-test-font-path="
106 (assoc-ref %build-inputs "font-dejavu")
107 "/share/fonts/truetype/DejaVuSans.ttf")
108 ,(string-append "--with-gs-path="
109 (assoc-ref %build-inputs "ghostscript")
110 "/bin/gsc")
111 ,(string-append "--with-shell="
112 (assoc-ref %build-inputs "bash")
113 "/bin/bash")
114 ,(string-append "--with-rcdir="
115 (assoc-ref %outputs "out") "/etc/rc.d"))
116
117 #:phases (modify-phases %standard-phases
118 (add-after 'unpack 'patch-foomatic-hardcoded-file-names
119 (lambda* (#:key inputs outputs #:allow-other-keys)
120 ;; Foomatic has hardcoded file names we need to fix.
121 (let ((out (assoc-ref outputs "out"))
122 (gs (assoc-ref inputs "ghostscript")))
123 (substitute* "filter/foomatic-rip/foomaticrip.c"
124 (("/usr/local/lib/cups/filter")
125 (string-append out "/lib/cups/filter")))
126 #t)))
127 (add-after 'unpack 'patch-for-poppler
128 (lambda _
129 (substitute* "filter/pdf.cxx"
130 (("GooString \\*field_name;" m)
131 (string-append "const " m)))
132 #t))
133 (add-after 'install 'wrap-filters
134 (lambda* (#:key inputs outputs #:allow-other-keys)
135 ;; Some filters expect to find 'gs' in $PATH. We cannot
136 ;; just hard-code its absolute file name in the source
137 ;; because foomatic-rip, for example, has tests like
138 ;; 'startswith(cmd, "gs")'.
139 (let ((out (assoc-ref outputs "out"))
140 (ghostscript (assoc-ref inputs "ghostscript")))
141 (for-each (lambda (file)
142 (wrap-program file
143 `("PATH" ":" prefix
144 (,(string-append ghostscript
145 "/bin")))))
146 (find-files (string-append
147 out "/lib/cups/filter")))
148 #t))))))
149 (native-inputs
150 `(("glib" ,glib "bin") ; for gdbus-codegen
151 ("pkg-config" ,pkg-config)))
152 (inputs
153 `(("avahi" ,avahi)
154 ("fontconfig" ,fontconfig)
155 ("freetype" ,freetype)
156 ("font-dejavu" ,font-dejavu) ; also needed by test suite
157 ("ghostscript" ,ghostscript/cups)
158 ("ijs" ,ijs)
159 ("dbus" ,dbus)
160 ("lcms" ,lcms)
161 ("libjpeg" ,libjpeg)
162 ("libpng" ,libpng)
163 ("libtiff" ,libtiff)
164 ("glib" ,glib)
165 ("qpdf" ,qpdf)
166 ("poppler" ,poppler)
167 ("cups-minimal" ,cups-minimal)))
168 (home-page "https://wiki.linuxfoundation.org/openprinting/cups-filters")
169 (synopsis "OpenPrinting CUPS filters and backends")
170 (description
171 "Contains backends, filters, and other software that was once part of the
172 core CUPS distribution but is no longer maintained by Apple Inc. In addition
173 it contains additional filters developed independently of Apple, especially
174 filters for the PDF-centric printing workflow introduced by OpenPrinting.")
175 ;; Different filters and backends have different licenses; see COPYING for
176 ;; details
177 (license (list license:gpl2
178 license:gpl2+
179 license:gpl3
180 license:gpl3+
181 license:lgpl2.0+
182 license:expat))))
183
184 ;; CUPS on non-MacOS systems requires cups-filters. Since cups-filters also
185 ;; depends on CUPS libraries and binaries, cups-minimal has been added to
186 ;; satisfy this dependency.
187 (define-public cups-minimal
188 (package
189 (name "cups-minimal")
190 (version "2.3.0")
191 (source
192 (origin
193 (method url-fetch)
194 (uri (string-append "https://github.com/apple/cups/releases/download/v"
195 version "/cups-" version "-source.tar.gz"))
196 (sha256
197 (base32
198 "19d1jpdpxy0fclq37pchi7ldnw9dssxx3zskcgqai3h0rwlh5bxc"))))
199 (build-system gnu-build-system)
200 (arguments
201 `(#:configure-flags
202 '("--disable-launchd"
203 "--disable-systemd"
204 "--disable-avahi"
205 "--disable-dnssd")
206 ;; Seven tests fail, mostly because of files that are provided by the
207 ;; cups-filters package.
208 #:tests? #f
209 #:phases
210 (modify-phases %standard-phases
211 (add-before 'configure 'patch-makedefs
212 (lambda _
213 (substitute* "Makedefs.in"
214 (("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
215 (("/bin/sh") (which "sh")))
216 #t))
217 ;; Make the compressed manpages writable so that the
218 ;; reset-gzip-timestamps phase does not error out.
219 (add-before 'reset-gzip-timestamps 'make-manpages-writable
220 (lambda* (#:key outputs #:allow-other-keys)
221 (let* ((out (assoc-ref outputs "out"))
222 (man (string-append out "/share/man")))
223 (for-each (lambda (file) (chmod file #o644))
224 (find-files man "\\.gz"))
225 #t)))
226 (add-before 'build 'patch-tests
227 (lambda _
228 (substitute* "tools/ippeveprinter.c"
229 (("# else /\\* HAVE_AVAHI \\*/")
230 "#elif defined(HAVE_AVAHI)"))
231 #t)))))
232 (native-inputs
233 `(("pkg-config" ,pkg-config)))
234 (inputs
235 `(("zlib" ,zlib)
236 ("gnutls" ,gnutls)))
237 (home-page "https://www.cups.org")
238 (synopsis "The Common Unix Printing System")
239 (description
240 "CUPS is a printing system that uses the Internet Printing Protocol
241 (@dfn{IPP}). It provides System V and BSD command-line interfaces, as well
242 as a Web interface and a C programming interface to manage printers and print
243 jobs. It supports printing to both local (parallel, serial, USB) and
244 networked printers, and printers can be shared from one computer to another.
245 Internally, CUPS uses PostScript Printer Description (@dfn{PPD}) files to
246 describe printer capabilities and features, and a wide variety of generic and
247 device-specific programs to convert and print many types of files.")
248 ;; CUPS is Apache 2.0 with exceptions, see the NOTICE file.
249 (license license:asl2.0)))
250
251 (define-public cups
252 (package (inherit cups-minimal)
253 (name "cups")
254 (arguments
255 `(;; Three tests fail:
256 ;; * two tests in ipp-1.1.test related to "RFC 2911 section 3.2.6:
257 ;; Get-Jobs Operation"
258 ;; * test of number of error/warning messages, probably related to a
259 ;; missing font.
260 #:tests? #f
261 #:configure-flags
262 '("--disable-launchd"
263 "--disable-systemd")
264 #:phases
265 (modify-phases %standard-phases
266 (add-before 'configure 'patch-makedefs
267 (lambda _
268 (substitute* "Makedefs.in"
269 (("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
270 (("/bin/sh") (which "sh")))
271 #t))
272 (add-before 'check 'patch-tests
273 (lambda _
274 (let ((filters (assoc-ref %build-inputs "cups-filters"))
275 (catpath (string-append
276 (assoc-ref %build-inputs "coreutils") "/bin/"))
277 (testdir (string-append (getcwd) "/tmp/")))
278 (mkdir testdir)
279 (substitute* "test/run-stp-tests.sh"
280 ((" *BASE=/tmp/") (string-append "BASE=" testdir))
281
282 ;; allow installation of filters from output dir and from
283 ;; cups-filters
284 (("for dir in /usr/libexec/cups/filter /usr/lib/cups/filter")
285 (string-append
286 "for dir in "
287 (assoc-ref %outputs "out") "/lib/cups/filter "
288 filters "/lib/cups/filter"))
289
290 ;; check for charsets in cups-filters output
291 (("/usr/share/cups/charsets")
292 (string-append filters "/share/cups/charsets"))
293
294 ;; install additional required filters
295 (("instfilter texttopdf texttopdf pdf")
296 (string-append
297 "instfilter texttopdf texttopdf pdf;"
298 "instfilter imagetoraster imagetoraster raster;"
299 "instfilter gstoraster gstoraster raster;"
300 "instfilter urftopdf urftopdf pdf;"
301 "instfilter rastertopdf rastertopdf pdf;"
302 "instfilter pstopdf pstopdf pdf"))
303
304 ;; specify location of lpstat binary
305 (("description=\"`lpstat -l")
306 "description=\"`../systemv/lpstat -l")
307
308 ;; patch shebangs of embedded scripts
309 (("#!/bin/sh") (string-append "#!" (which "sh")))
310
311 ;; also link mime definitions from cups-filters
312 ;; to enable the additional filters for the test suite
313 (("ln -s \\$root/conf/mime\\.types")
314 (string-append
315 "ln -s " filters
316 "/share/cups/mime/cupsfilters.types $BASE/share/mime; "
317 "ln -s $root/conf/mime.types"))
318 (("ln -s \\$root/conf/mime\\.convs")
319 (string-append
320 "ln -s " filters
321 "/share/cups/mime/cupsfilters.convs $BASE/share/mime; "
322 "ln -s $root/conf/mime.convs")))
323
324 ;; fix search path for "cat"
325 (substitute* "cups/testfile.c"
326 (("cupsFileFind\\(\"cat\", \"/bin\"")
327 (string-append "cupsFileFind(\"cat\", \"" catpath "\""))
328 (("cupsFileFind\\(\"cat\", \"/bin:/usr/bin\"")
329 (string-append "cupsFileFind(\"cat\", \"" catpath "\"")))
330 #t)))
331 ;; Make the compressed manpages writable so that the
332 ;; reset-gzip-timestamps phase does not error out.
333 (add-before 'reset-gzip-timestamps 'make-manpages-writable
334 (lambda* (#:key outputs #:allow-other-keys)
335 (let* ((out (assoc-ref outputs "out"))
336 (man (string-append out "/share/man")))
337 (for-each (lambda (file) (chmod file #o644))
338 (find-files man "\\.gz"))
339 #t)))
340 (add-after 'install 'install-cups-filters-symlinks
341 (lambda* (#:key inputs outputs #:allow-other-keys)
342 (let ((out (assoc-ref outputs "out"))
343 (cups-filters (assoc-ref inputs "cups-filters")))
344 ;; charsets
345 (symlink
346 (string-append cups-filters "/share/cups/charsets")
347 (string-append out "/share/charsets"))
348
349 ;; mime types, driver file, ppds
350 (for-each
351 (lambda (f)
352 (symlink (string-append cups-filters f)
353 (string-append out f)))
354 '("/share/cups/mime/cupsfilters.types"
355 "/share/cups/mime/cupsfilters.convs"
356 "/share/cups/drv/cupsfilters.drv"
357 "/share/ppd"))
358
359 ;; filters
360 (for-each
361 (lambda (f)
362 (symlink f
363 (string-append out "/lib/cups/filter" (basename f))))
364 (find-files (string-append cups-filters "/lib/cups/filter")))
365
366 ;; backends
367 (for-each
368 (lambda (f)
369 (symlink (string-append cups-filters f)
370 (string-append out "/lib/cups/backend/"
371 (basename f))))
372 '("/lib/cups/backend/parallel"
373 "/lib/cups/backend/serial"))
374
375 ;; banners
376 (let ((banners "/share/cups/banners"))
377 (delete-file-recursively (string-append out banners))
378 (symlink (string-append cups-filters banners)
379 (string-append out banners)))
380
381 ;; assorted data
382 (let ((data "/share/cups/data"))
383 (delete-file-recursively (string-append out data))
384 (symlink (string-append cups-filters data)
385 (string-append out data)))
386
387 #t))))))
388 (inputs
389 `(("avahi" ,avahi)
390 ("gnutls" ,gnutls)
391 ("cups-filters" ,cups-filters)
392 ("zlib" ,zlib)))))
393
394 (define-public cups-pk-helper
395 (package
396 (name "cups-pk-helper")
397 (version "0.2.6")
398 (source (origin
399 (method url-fetch)
400 (uri (string-append "https://freedesktop.org/software/"
401 name "/releases/" name "-" version ".tar.xz"))
402 (sha256
403 (base32
404 "0a52jw6rm7lr5nbyksiia0rn7sasyb5cjqcb95z1wxm2yprgi6lm"))))
405 (build-system gnu-build-system)
406 (native-inputs
407 `(("intltool" ,intltool)
408 ("pkg-config" ,pkg-config)
409 ("glib" ,glib)
410 ("polkit" ,polkit)
411 ("cups" ,cups)))
412 (home-page "https://www.freedesktop.org/wiki/Software/cups-pk-helper/")
413 (synopsis "PolicyKit helper to configure CUPS with fine-grained privileges")
414 (description
415 "This package provides the org.opensuse.CupsPkHelper.Mechanism DBus
416 system service which uses @file{cups-pk-helper-mechanism}. This package
417 should only be used as part of the Guix cups-pk-helper service.")
418 (license license:gpl2+)))
419
420 (define-public hplip
421 (package
422 (name "hplip")
423 (version "3.19.12")
424 (source (origin
425 (method url-fetch)
426 (uri (string-append "mirror://sourceforge/hplip/hplip/" version
427 "/hplip-" version ".tar.gz"))
428 (sha256
429 (base32
430 "0mdj0sqgfxjqa550adiw1gn4z9n6wcvn55slivgf0ndn5x89iwxp"))
431 (modules '((guix build utils)))
432 (patches (search-patches "hplip-remove-imageprocessor.patch"))
433 (snippet
434 '(begin
435 ;; Delete non-free blobs: .so files, pre-compiled
436 ;; 'locatedriver' executable, etc.
437 (for-each delete-file
438 (find-files "."
439 (lambda (file stat)
440 (elf-file? file))))
441 (delete-file "prnt/hpcups/ImageProcessor.h")
442
443 ;; Install binaries under libexec/hplip instead of
444 ;; share/hplip; that'll at least ensure they get stripped.
445 ;; It's not even clear that they're of any use though...
446 (substitute* "Makefile.in"
447 (("^dat2drvdir =.*")
448 "dat2drvdir = $(pkglibexecdir)\n")
449 (("^locatedriverdir =.*")
450 "locatedriverdir = $(pkglibexecdir)\n"))
451 #t))))
452 (build-system gnu-build-system)
453 (home-page "https://developers.hp.com/hp-linux-imaging-and-printing")
454 (synopsis "HP printer drivers")
455 (description
456 "Hewlett-Packard printer drivers and PostScript Printer Descriptions
457 (@dfn{PPD}s).")
458
459 ;; The 'COPYING' file lists directories where each of these 3 licenses
460 ;; applies.
461 (license (list license:gpl2+ license:bsd-3 license:expat))
462
463 ;; TODO install apparmor profile files eventually.
464 (arguments
465 `(#:configure-flags
466 `("--disable-network-build"
467 ,(string-append "--prefix=" (assoc-ref %outputs "out"))
468 ,(string-append "--sysconfdir=" (assoc-ref %outputs "out") "/etc")
469 ,(string-append "LDFLAGS=-Wl,-rpath="
470 (assoc-ref %outputs "out") "/lib")
471 ;; Disable until mime.types merging works (FIXME).
472 "--disable-fax-build"
473 "--enable-hpcups-install"
474 "--enable-new-hpcups"
475 "--enable-cups_ppd_install"
476 "--enable-cups_drv_install"
477 ;; TODO add foomatic drv install eventually.
478 ;; TODO --enable-policykit eventually.
479 ,(string-append "--with-cupsfilterdir="
480 (assoc-ref %outputs "out") "/lib/cups/filter")
481 ,(string-append "--with-cupsbackenddir="
482 (assoc-ref %outputs "out") "/lib/cups/backend")
483 ,(string-append "--with-icondir="
484 (assoc-ref %outputs "out") "/share/applications")
485 ,(string-append "--with-systraydir="
486 (assoc-ref %outputs "out") "/etc/xdg")
487 "--enable-qt5" "--disable-qt4")
488
489 #:imported-modules ((guix build python-build-system)
490 ,@%gnu-build-system-modules)
491 #:modules ((guix build gnu-build-system)
492 (guix build utils)
493 ((guix build python-build-system) #:prefix python:))
494
495 #:phases
496 (modify-phases %standard-phases
497 (add-after 'unpack 'fix-hard-coded-file-names
498 (lambda* (#:key inputs outputs #:allow-other-keys)
499 (let ((out (assoc-ref outputs "out"))
500 ;; FIXME: use merged ppds (I think actually only
501 ;; drvs need to be merged).
502 (cupsdir (assoc-ref inputs "cups-minimal")))
503 (substitute* "base/g.py"
504 (("'/usr/share;[^']*'")
505 (string-append "'" cupsdir "/share'"))
506 (("'/etc/hp/hplip.conf'")
507 (string-append "'" out
508 "/etc/hp/hplip.conf" "'")))
509
510 (substitute* "Makefile.in"
511 (("[[:blank:]]check-plugin\\.py[[:blank:]]") " ")
512 ;; FIXME Use beginning-of-word in regexp.
513 (("[[:blank:]]plugin\\.py[[:blank:]]") " ")
514 (("/usr/include/libusb-1.0")
515 (string-append (assoc-ref inputs "libusb")
516 "/include/libusb-1.0"))
517 (("hplip_statedir =.*$")
518 ;; Don't bail out while trying to create
519 ;; /var/lib/hplip. We can safely change its value
520 ;; here because it's hard-coded in the code anyway.
521 "hplip_statedir = $(prefix)\n")
522 (("hplip_confdir = /etc/hp")
523 ;; This is only used for installing the default config.
524 (string-append "hplip_confdir = " out
525 "/etc/hp"))
526 (("halpredir = /usr/share/hal/fdi/preprobe/10osvendor")
527 ;; We don't use hal.
528 (string-append "halpredir = " out
529 "/share/hal/fdi/preprobe/10osvendor"))
530 (("rulesdir = /etc/udev/rules.d")
531 ;; udev rules will be merged by base service.
532 (string-append "rulesdir = " out
533 "/lib/udev/rules.d"))
534 (("rulessystemdir = /usr/lib/systemd/system")
535 ;; We don't use systemd.
536 (string-append "rulessystemdir = " out
537 "/lib/systemd/system"))
538 (("/etc/sane.d")
539 (string-append out "/etc/sane.d"))))))
540 (add-after 'install 'wrap-binaries
541 ;; Scripts in /bin are all symlinks to .py files in /share/hplip.
542 ;; Symlinks are immune to the Python build system's 'WRAP phase,
543 ;; and the .py files can't be wrapped because they are reused as
544 ;; modules. Replacing the symlinks in /bin with copies and
545 ;; wrapping them also doesn't work (“ModuleNotFoundError:
546 ;; No module named 'base'”). Behold: a custom WRAP-PROGRAM.
547 (lambda* (#:key inputs outputs #:allow-other-keys)
548 (let* ((out (assoc-ref outputs "out"))
549 (bin (string-append out "/bin"))
550 (python (assoc-ref inputs "python")))
551 (with-directory-excursion bin
552 (for-each (lambda (file)
553 (let ((target (readlink file)))
554 (delete-file file)
555 (with-output-to-file file
556 (lambda _
557 (format #t
558 "#!~a~@
559 export PYTHONPATH=\"~a:~a\"~@
560 exec -a \"$0\" \"~a/~a\" \"$@\"~%"
561 (which "bash")
562 (string-append
563 out "/lib/python"
564 (python:python-version python)
565 "/site-packages")
566 (getenv "PYTHONPATH")
567 bin target)))
568 (chmod file #o755)))
569 (find-files "." (lambda (file stat)
570 (eq? 'symlink (stat:type stat)))))
571 #t)))))))
572
573 ;; Note that the error messages printed by the tools in the case of
574 ;; missing dependencies are often downright misleading.
575 ;; TODO: hp-toolbox still fails to start with:
576 ;; from dbus.mainloop.pyqt5 import DBusQtMainLoop
577 ;; ModuleNotFoundError: No module named 'dbus.mainloop.pyqt5'
578 (inputs
579 `(("cups-minimal" ,cups-minimal)
580 ("dbus" ,dbus)
581 ("libjpeg" ,libjpeg)
582 ("libusb" ,libusb)
583 ("python" ,python)
584 ("python-dbus" ,python-dbus)
585 ("python-pygobject" ,python-pygobject)
586 ("python-pyqt" ,python-pyqt)
587 ("python-wrapper" ,python-wrapper)
588 ("sane-backends" ,sane-backends-minimal)
589 ("zlib" ,zlib)))
590 (native-inputs
591 `(("perl" ,perl)
592 ("pkg-config" ,pkg-config)))))
593
594 (define-public hplip-minimal
595 (package
596 (inherit hplip)
597 (name "hplip-minimal")
598 (arguments
599 (substitute-keyword-arguments (package-arguments hplip)
600 ((#:configure-flags cf)
601 ;; Produce a "light build", meaning that only the printer (CUPS) and
602 ;; scanner (SANE) support gets built, without all the 'hp-*'
603 ;; command-line tools.
604 `(cons "--enable-lite-build"
605 (delete "--enable-qt5" ,cf)))
606 ((#:phases phases)
607 ;; The 'wrap-binaries' is not needed here since the 'hp-*' programs
608 ;; are not installed.
609 `(alist-delete 'wrap-binaries ,phases))))
610 (inputs (remove (match-lambda
611 ((label . _)
612 (string-prefix? "python" label)))
613 (package-inputs hplip)))
614 (synopsis "GUI-less version of hplip")))
615
616 (define-public foomatic-filters
617 (package
618 (name "foomatic-filters")
619 (version "4.0.17")
620 (source (origin
621 (method url-fetch)
622 (uri (string-append
623 "http://www.openprinting.org/download/foomatic/"
624 "foomatic-filters-" version ".tar.gz"))
625 (sha256
626 (base32
627 "1qrkgbm5jay2r7sh9qbyf0aiyrsl1mdc844hxf7fhw95a0zfbqm2"))
628 (patches
629 (search-patches "foomatic-filters-CVE-2015-8327.patch"
630 "foomatic-filters-CVE-2015-8560.patch"))))
631 (build-system gnu-build-system)
632 (home-page
633 "https://wiki.linuxfoundation.org/openprinting/database/foomatic")
634 (native-inputs
635 `(("perl" ,perl)
636 ("pkg-config" ,pkg-config)))
637 (inputs
638 `(("dbus" ,dbus)
639 ("a2ps" ,a2ps)))
640 (arguments
641 '( ;; Specify the installation directories.
642 #:configure-flags (list (string-append "ac_cv_path_CUPS_BACKENDS="
643 (assoc-ref %outputs "out")
644 "/lib/cups/backend")
645 (string-append "ac_cv_path_CUPS_FILTERS="
646 (assoc-ref %outputs "out")
647 "/lib/cups/filter")
648 (string-append "ac_cv_path_PPR_INTERFACES="
649 (assoc-ref %outputs "out")
650 "/lib/ppr/interfaces")
651 (string-append "ac_cv_path_PPR_LIB="
652 (assoc-ref %outputs "out")
653 "/lib/ppr/lib")
654
655 ;; For some reason these are misdiagnosed.
656 "ac_cv_func_malloc_0_nonnull=yes"
657 "ac_cv_func_realloc_0_nonnull=yes")
658 #:test-target "tests"))
659 (synopsis "Convert PostScript to the printer's native format")
660 (description
661 "This package contains filter scripts used by the printer spoolers to
662 convert the incoming PostScript data into the printer's native format using a
663 printer/driver specific, but spooler-independent PPD file.")
664 (license license:gpl2+)))
665
666 (define-public foo2zjs
667 (package
668 (name "foo2zjs")
669 (version "20190909")
670 (source (origin
671 (method url-fetch)
672 ;; XXX: This is an unversioned URL!
673 (uri "http://foo2zjs.rkkda.com/foo2zjs.tar.gz")
674 (sha256
675 (base32
676 "1nn84c045mbv6yzpjfggc6152bvgrmcxiyvgz9v2w3sws7ihshrm"))))
677 (build-system gnu-build-system)
678 (arguments
679 '(#:phases (modify-phases %standard-phases
680 (replace 'configure
681 (lambda* (#:key outputs #:allow-other-keys)
682 (substitute* (find-files "." "^Makefile$")
683 ;; Set the installation directory.
684 (("^PREFIX[[:blank:]]*=.*$")
685 (string-append "PREFIX = "
686 (assoc-ref outputs "out")
687 "\n"))
688 (("^UDEVBIN[[:blank:]]*=.*$")
689 "UDEVBIN = $(PREFIX)/bin\n")
690 ;; Don't try to chown/chgrp the installed files.
691 (("-oroot")
692 "")
693 (("-glp")
694 "")
695 ;; Placate the dependency checks.
696 (("/usr/include/stdio.h")
697 "/etc/passwd")
698 (("/usr/")
699 "$(PREFIX)/")
700 ;; Ensure fixed timestamps in man pages.
701 (("^MODTIME[[:blank:]]*=.*$")
702 "MODTIME = echo Thu Jan 01 01:00:00 1970\n"))
703 #t))
704 (add-after 'install 'remove-pdf
705 (lambda* (#:key outputs #:allow-other-keys)
706 ;; Remove 'manual.pdf' which is (1) useless (it's a
707 ;; concatenation of man pages), and (2) not
708 ;; bit-reproducible due to <https://bugs.gnu.org/27593>.
709 (let ((out (assoc-ref outputs "out")))
710 (for-each delete-file
711 (find-files out "^manual\\.pdf$"))
712 #t))))
713 #:parallel-build? #f ;broken makefile
714 #:tests? #f ;no tests
715 #:make-flags '("CC=gcc")))
716 (inputs
717 `(("ghostscript" ,ghostscript)
718 ("foomatic-filters" ,foomatic-filters))) ;for 'foomatic-rip'
719 (native-inputs
720 `(("bc" ,bc)
721 ("groff" ,groff)))
722 (home-page "http://foo2zjs.rkkda.com/")
723 (synopsis "Printer driver for ZjStream-based printers")
724 (description
725 "foo2zjs is a printer driver for printers that use the Zenographics
726 ZjStream wire protocol for their print data, often erroneously referred to as
727 winprinters or GDI printers.
728
729 It supports Minolta/QMS@tie{}Magicolor, Minolta@tie{}Color@tie{}PageWorks/Pro,
730 HP@tie{}LaserJet, and possibly other printers. See @file{README} for details.")
731 (license (list license:expat ; icc2ps/*.[ch]
732 license:gpl2+)))) ; everything else
733
734 (define-public escpr
735 (package
736 (name "escpr")
737 (version "1.6.30")
738 ;; XXX: This currently works. But it will break as soon as a newer
739 ;; version is available since the URLs for older versions are not
740 ;; preserved. An alternative source will be added as soon as
741 ;; available.
742 (source (origin
743 (method url-fetch)
744 ;; The uri has to be chopped up in order to satisfy guix lint.
745 (uri (string-append "https://download3.ebz.epson.net/dsc/f/03/00/08/18/20/"
746 "e94de600e28e510c1cfa158929d8b2c0aadc8aa0/"
747 "epson-inkjet-printer-escpr-1.6.30-1lsb3.2.tar.gz"))
748 (sha256
749 (base32
750 "0m8pyfkixisp0vclwxj340isn15zzisal0v2xvv66kxfd68dzf12"))))
751 (build-system gnu-build-system)
752 (arguments
753 `(#:configure-flags
754 `(,(string-append "--prefix="
755 (assoc-ref %outputs "out"))
756 ,(string-append "--with-cupsfilterdir="
757 (assoc-ref %outputs "out") "/lib/cups/filter")
758 ,(string-append "--with-cupsppddir="
759 (assoc-ref %outputs "out") "/share/ppd"))))
760 (inputs `(("cups" ,cups-minimal)))
761 (synopsis "ESC/P-R printer driver")
762 (description
763 "This package provides a filter for the Common UNIX Printing
764 System (CUPS). It offers high-quality printing with Seiko Epson color ink jet
765 printers. It can only be used with printers that support the Epson ESC/P-R
766 language.")
767 (home-page "http://download.ebz.epson.net/dsc/search/01/search")
768 (license license:gpl2+)))
769
770 (define-public splix
771 ;; The last release was in 2009. The SVN repository contains 5 years of
772 ;; unreleased bug fixes and support for newer printer models.
773 (let ((revision 315))
774 (package
775 (name "splix")
776 (version (string-append "2.0.0-" (number->string revision)))
777 (source
778 (origin
779 (method svn-fetch)
780 (uri (svn-reference
781 (url "https://svn.code.sf.net/p/splix/code/splix/")
782 (revision revision)))
783 (file-name (string-append name "-" version "-checkout"))
784 (sha256
785 (base32 "16wbm4xnz35ca3mw2iggf5f4jaxpyna718ia190ka6y4ah932jxl"))))
786 (build-system gnu-build-system)
787 ;; 90% (3.8 MiB) of output are .ppd files. Don't install them by default:
788 ;; CUPS has been able to read the .drv sources directly since version 1.2.
789 (outputs (list "out" "ppd"))
790 (arguments
791 '(#:make-flags
792 (list (string-append "CUPSDRV="
793 (assoc-ref %outputs "out") "/share/cups/drv")
794 (string-append "CUPSFILTER="
795 (assoc-ref %outputs "out") "/lib/cups/filter")
796 (string-append "CUPSPPD="
797 (assoc-ref %outputs "ppd") "/share/cups/model")
798 "CACHESIZE=100" ; pages in RAM, ±300 KiB each
799 "THREADS=4") ; compress and print faster
800 #:phases
801 (modify-phases %standard-phases
802 (delete 'configure) ; no configure script
803 (add-before 'build 'build-.drv-files
804 (lambda* (#:key make-flags #:allow-other-keys)
805 (apply invoke "make" "drv" make-flags)))
806 (add-after 'install 'install-.drv-files
807 (lambda* (#:key make-flags #:allow-other-keys)
808 (apply invoke "make" "install" "DRV_ONLY=1" make-flags))))
809 #:tests? #f)) ; no test suite
810 (inputs
811 `(("cups" ,cups-minimal)
812 ("zlib" ,zlib)
813
814 ;; This dependency can be dropped by setting DISABLE_JBIG=1, but the
815 ;; result will not support some printers like the Samsung CLP-600.
816 ("jbigkit" ,jbigkit)))
817 (synopsis "QPDL (SPL2) printer driver")
818 (description
819 "SpliX is a set of CUPS drivers for printers that speak @acronym{QPDL,
820 Quick Page Description Language}, also called @acronym{SPL2, Samsung Printer
821 Language version 2}. These include many laser printers sold by Samsung,
822 Xerox, Lexmark, Toshiba, and Dell.
823
824 Colour printers need colour profile files to get better results. These
825 @file{cms} files are provided by the printer's manufacturer and must be
826 obtained and installed separately.")
827 (home-page "http://splix.ap2c.org/")
828 (license license:gpl2))))
829
830 (define-public python-pycups
831 (package
832 (name "python-pycups")
833 (version "1.9.74")
834 (source
835 (origin
836 (method url-fetch)
837 (uri (pypi-uri "pycups" version ".tar.bz2"))
838 (sha256
839 (base32
840 "1ffp7sswhdsfpy88zg0cc8kl04wygkjs01rlm9f0spbwk8jhy2c6"))))
841 (build-system python-build-system)
842 (arguments
843 '(;; Tests require CUPS to be running
844 #:tests? #f))
845 (inputs
846 `(("cups" ,cups)))
847 (home-page "https://github.com/zdohnal/pycups")
848 (synopsis "Python bindings for libcups")
849 (description
850 "This package provides Python bindings for libcups, wrapping the CUPS
851 API.")
852 (license license:gpl2+)))