gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / bison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages bison)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages m4)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages flex)
29 #:use-module (srfi srfi-1))
30
31 (define-public bison
32 (package
33 (name "bison")
34 (version "3.4.1")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/bison/bison-"
39 version ".tar.xz"))
40 (sha256
41 (base32
42 "03c2pmq3bs0drdislnz6gm1rwz3n4pb2rz9navyxydppxg2rl597"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(;; Building in parallel on many-core systems may cause an error such as
46 ;; "mv: cannot stat 'examples/c/reccalc/scan.stamp.tmp': No such file or
47 ;; directory". See <https://bugs.gnu.org/36238>.
48 #:parallel-build? #f
49 ;; Similarly, when building tests in parallel, Make may produce this error:
50 ;; "./examples/c/reccalc/scan.l:13:10: fatal error: parse.h: No such file
51 ;; or directory". Full log in <https://bugs.gnu.org/36238>.
52 #:parallel-tests? #f))
53 (native-inputs `(("perl" ,perl)
54 ;; m4 is not present in PATH when cross-building.
55 ("m4" ,m4)))
56 (inputs `(("flex" ,flex)))
57 (propagated-inputs `(("m4" ,m4)))
58 (home-page "https://www.gnu.org/software/bison/")
59 (synopsis "Parser generator")
60 (description
61 "GNU Bison is a general-purpose parser generator. It can build a
62 deterministic or generalized LR parser from an annotated, context-free
63 grammar. It is versatile enough to have many applications, from parsers for
64 simple tools through complex programming languages.")
65 (license gpl3+)))
66
67 (define-public bison-3.0
68 (package
69 (inherit bison)
70 (version "3.0.5")
71 (source
72 (origin
73 (method url-fetch)
74 (uri (string-append "mirror://gnu/bison/bison-"
75 version ".tar.xz"))
76 (sha256
77 (base32
78 "0f7kjygrckkx8vas2nm673592jif0a9mw5g8207f6hj6h4pfyp07"))))))