gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / acl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
7 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages acl)
25 #:use-module (guix licenses)
26 #:use-module (gnu packages attr)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages perl)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (gnu packages)
33 #:use-module (guix build-system gnu))
34
35 (define-public acl
36 (package
37 (name "acl")
38 (version "2.2.53")
39 (source
40 (origin
41 (method url-fetch)
42 (uri (string-append "mirror://savannah/acl/acl-"
43 version ".tar.gz"))
44 (sha256
45 (base32
46 "1ir6my3w74s6nfbgbqgzj6w570sn0qjf3524zx8xh67lqrjrigh6"))))
47 (build-system gnu-build-system)
48 (arguments
49 `(#:modules ((ice-9 ftw)
50 ,@%gnu-build-system-modules)
51 #:phases
52 (modify-phases %standard-phases
53 ;; XXX After repacking the sources the timestamps are reset to the
54 ;; epoch, which leads to a failure in gzipping the CHANGES file.
55 (add-after 'unpack 'ensure-no-mtimes-pre-1980
56 (lambda _
57 (let ((early-1980 315619200)) ; 1980-01-02 UTC
58 (ftw "." (lambda (file stat flag)
59 (unless (<= early-1980 (stat:mtime stat))
60 (utime file early-1980 early-1980))
61 #t))
62 #t)))
63 (add-after 'build 'patch-exec-bin-sh
64 (lambda _
65 (substitute* "test/run"
66 (("/bin/sh") (which "sh")))
67 #t))
68 (add-before 'check 'patch-tests
69 (lambda _
70 ;; The coreutils do not have an ACL bit to remove from their
71 ;; output, so the sed expression that removes the bit is disabled.
72 (substitute* "test/sbits-restore.test"
73 (("\\| sed.*'") ""))
74 ;; These tests require the existence of a user named "bin", but
75 ;; this user does not exist within Guix's build environment.
76 (substitute* "Makefile.in"
77 ((".*test/misc\\.test.*") "")
78 ((".*test/cp\\.test.*") "")
79 ((".*test/setfacl-X\\.test.*") ""))
80 #t)))))
81 (inputs `(("attr" ,attr)))
82 (native-inputs
83 `(("gettext" ,gettext-minimal)
84 ("perl" ,perl)))
85 (home-page "https://savannah.nongnu.org/projects/acl")
86 (synopsis
87 "Library and tools for manipulating access control lists")
88 (description
89 "Library and tools for manipulating access control lists.")
90 (license (list gpl2+ lgpl2.1+))))