gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / accessibility.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 ng0 <ng0@n0.is>
3 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages accessibility)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix git-download)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system glib-or-gtk)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages xml)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages gstreamer)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages xorg)
35 #:use-module (gnu packages gettext)
36 #:use-module (gnu packages glib)
37 #:use-module (gnu packages pkg-config)
38 #:use-module (gnu packages libusb))
39
40 (define-public florence
41 (package
42 (name "florence")
43 (version "0.6.3")
44 (source
45 (origin
46 (method url-fetch)
47 (uri (string-append "mirror://sourceforge/florence/florence/" version
48 "/florence-" version ".tar.bz2"))
49 (sha256
50 (base32
51 "07h9qm22krlwayhzvc391lr23vicw81s48g7rirvx1fj0zyr4aa2"))))
52 (build-system glib-or-gtk-build-system)
53 (arguments
54 `(#:configure-flags (list "--with-xtst"
55 "--without-docs"
56 "--with-notification")))
57 (inputs
58 `(("libxml2" ,libxml2)
59 ("libglade" ,libglade)
60 ("librsvg" ,librsvg)
61 ("gstreamer" ,gstreamer)
62 ("cairo" ,cairo)
63 ("gtk+" ,gtk+)
64 ("libxtst" ,libxtst)
65 ("libxcomposite" ,libxcomposite)
66 ("libnotify" ,libnotify)))
67 (native-inputs
68 `(("gettext-minimal" ,gettext-minimal)
69 ("intltool" ,intltool)
70 ("pkg-config" ,pkg-config)))
71 (home-page "http://florence.sourceforge.net/")
72 (synopsis "Extensible, scalable virtual keyboard for X11")
73 (description
74 "Florence is an extensible scalable virtual keyboard for X11.
75 It is useful for people who can't use a real hardware keyboard (for
76 example for people with disabilities), but you must be able to use
77 a pointing device (as a mouse, a trackball, a touchscreen or opengazer).
78
79 Florence stays out of your way when you don't need it: it appears on the
80 screen only when you need it. A timer-based auto-click input method is
81 available to help to click.")
82 ;; The documentation is under FDL1.2, but we do not install the
83 ;; documentation.
84 (license license:gpl2+)))
85
86 (define-public footswitch
87 (let ((commit "ca43d53fc2002520cc825d119702afc124303e73")
88 (revision "2"))
89 (package
90 (name "footswitch")
91 (version (git-version "0.1" revision commit))
92 (source (origin
93 (method git-fetch)
94 (uri (git-reference
95 (url "https://github.com/rgerganov/footswitch")
96 (commit commit)))
97 (file-name (git-file-name name version))
98 (sha256
99 (base32
100 "14pyzc4ws1mj859xs9n4x83wzxxvd3bh5bdxzr6nv267xwx1mq68"))))
101 (build-system gnu-build-system)
102 (native-inputs
103 `(("pkg-config" ,pkg-config)))
104 (inputs
105 `(("hidapi" ,hidapi)))
106 (arguments
107 `(#:tests? #f ; no tests
108 #:make-flags (list "CC=gcc")
109 #:phases (modify-phases %standard-phases
110 (delete 'configure)
111 ;; Install target in the Makefile does not work for Guix
112 (replace 'install
113 (lambda* (#:key outputs #:allow-other-keys)
114 (let ((bin (string-append (assoc-ref outputs "out")
115 "/bin")))
116 (install-file "footswitch" bin)
117 (install-file "scythe" bin)
118 #t))))))
119 (home-page "https://github.com/rgerganov/footswitch")
120 (synopsis "Command line utility for PCsensor foot switch")
121 (description
122 "Command line utility for programming foot switches sold by PCsensor.
123 It works for both single pedal devices and three pedal devices. All supported
124 devices have vendorId:productId = 0c45:7403 or 0c45:7404.")
125 (license license:expat))))
126
127 (define-public xmagnify
128 (package
129 (name "xmagnify")
130 (version "0.1.0")
131 (source (origin
132 (method git-fetch)
133 (uri (git-reference
134 (url "https://gitlab.com/amiloradovsky/magnify.git")
135 (commit version)))
136 (file-name (git-file-name name version))
137 (sha256
138 (base32
139 "1ngnp5f5zl3v35vhbdyjpymy6mwrs0476fm5nd7dzkba7n841jdh"))))
140 (build-system gnu-build-system)
141 (arguments
142 `(#:tests? #f ; none included
143 #:make-flags
144 (list "CC=gcc"
145 (string-append "prefix=" (assoc-ref %outputs "out")))
146 #:phases
147 (modify-phases %standard-phases
148 (delete 'configure))))
149 (inputs
150 `(("libX11" ,libx11)))
151 (home-page "https://gitlab.com/amiloradovsky/magnify")
152 (synopsis "Tiny screen magnifier for X11")
153 (description
154 "This program magnifies a screen region by an integer positive factor and
155 draws the result on a window. It is useful as an accessibility tool, which
156 works with every X Window System based GUI (depends only on libX11); or as an
157 assistant for graphic designers, who need to select individual pixels.")
158 ;; Licensed either under Expat or GPLv2+.
159 (license (list license:expat license:gpl2+))))