Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / package-management.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
5 ;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
9 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
10 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
11 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages package-management)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages acl)
31 #:use-module (gnu packages attr)
32 #:use-module (gnu packages avahi)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages backup)
35 #:use-module (gnu packages bdw-gc)
36 #:use-module (gnu packages bison)
37 #:use-module (gnu packages bootstrap) ;for 'bootstrap-guile-origin'
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages cpio)
41 #:use-module (gnu packages crypto)
42 #:use-module (gnu packages curl)
43 #:use-module (gnu packages databases)
44 #:use-module (gnu packages docbook)
45 #:use-module (gnu packages emacs)
46 #:use-module (gnu packages file)
47 #:use-module (gnu packages gettext)
48 #:use-module (gnu packages glib)
49 #:use-module (gnu packages gnome)
50 #:use-module (gnu packages gnupg)
51 #:use-module (gnu packages gnuzilla)
52 #:use-module (gnu packages graphviz)
53 #:use-module (gnu packages guile)
54 #:use-module (gnu packages linux)
55 #:use-module (gnu packages lisp)
56 #:use-module (gnu packages man)
57 #:use-module (gnu packages nettle)
58 #:use-module (gnu packages patchutils)
59 #:use-module (gnu packages perl)
60 #:use-module (gnu packages perl-check)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages popt)
63 #:use-module (gnu packages python)
64 #:use-module (gnu packages python-web)
65 #:use-module (gnu packages serialization)
66 #:use-module (gnu packages ssh)
67 #:use-module (gnu packages texinfo)
68 #:use-module (gnu packages time)
69 #:use-module (gnu packages tls)
70 #:use-module (gnu packages vim)
71 #:use-module (gnu packages web)
72 #:use-module (gnu packages xml)
73 #:use-module (guix build-system emacs)
74 #:use-module (guix build-system gnu)
75 #:use-module (guix build-system meson)
76 #:use-module (guix build-system python)
77 #:use-module (guix download)
78 #:use-module (guix gexp)
79 #:use-module (guix git-download)
80 #:use-module ((guix licenses) #:prefix license:)
81 #:use-module (guix packages)
82 #:use-module (guix utils)
83 #:use-module (ice-9 match)
84 #:use-module (srfi srfi-1))
85
86 (define (boot-guile-uri arch)
87 "Return the URI for the bootstrap Guile tarball for ARCH."
88 (cond ((string=? "armhf" arch)
89 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
90 arch "-linux"
91 "/20150101/guile-2.0.11.tar.xz"))
92 ((string=? "aarch64" arch)
93 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
94 arch "-linux/20170217/guile-2.0.14.tar.xz"))
95 (else
96 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
97 arch "-linux"
98 "/20131110/guile-2.0.9.tar.xz"))))
99
100 (define-public guix
101 ;; Latest version of Guix, which may or may not correspond to a release.
102 ;; Note: the 'update-guix-package.scm' script expects this definition to
103 ;; start precisely like this.
104 (let ((version "0.15.0")
105 (commit "f9a8fce10f2d99efec7cb1dd0f6c5f0df9d1b2df")
106 (revision 6))
107 (package
108 (name "guix")
109
110 (version (if (zero? revision)
111 version
112 (string-append version "-"
113 (number->string revision)
114 "." (string-take commit 7))))
115 (source (origin
116 (method git-fetch)
117 (uri (git-reference
118 (url "https://git.savannah.gnu.org/r/guix.git")
119 (commit commit)))
120 (sha256
121 (base32
122 "1733d5id0h44rrkyj9xw4fcqr1wawcfi8igpgk5wsn1iq4qqwv5f"))
123 (file-name (string-append "guix-" version "-checkout"))))
124 (build-system gnu-build-system)
125 (arguments
126 `(#:configure-flags (list
127 "--localstatedir=/var"
128 "--sysconfdir=/etc"
129 (string-append "--with-bash-completion-dir="
130 (assoc-ref %outputs "out")
131 "/etc/bash_completion.d")
132 (string-append "--with-libgcrypt-prefix="
133 (assoc-ref %build-inputs
134 "libgcrypt"))
135
136 ;; Set 'DOT_USER_PROGRAM' to the empty string so
137 ;; we don't keep a reference to Graphviz, whose
138 ;; closure is pretty big (too big for the GuixSD
139 ;; installation image.)
140 "ac_cv_path_DOT_USER_PROGRAM=dot"
141
142 ;; To avoid problems with the length of shebangs,
143 ;; choose a fixed-width and short directory name
144 ;; for tests.
145 "ac_cv_guix_test_root=/tmp/guix-tests")
146 #:parallel-tests? #f ;work around <http://bugs.gnu.org/21097>
147
148 #:modules ((guix build gnu-build-system)
149 (guix build utils)
150 (srfi srfi-26)
151 (ice-9 popen)
152 (ice-9 rdelim))
153
154 #:phases (modify-phases %standard-phases
155 (replace 'bootstrap
156 (lambda _
157 ;; Make sure 'msgmerge' can modify the PO files.
158 (for-each (lambda (po)
159 (chmod po #o666))
160 (find-files "." "\\.po$"))
161
162 (patch-shebang "build-aux/git-version-gen")
163
164 (call-with-output-file ".tarball-version"
165 (lambda (port)
166 (display ,version port)))
167
168 (invoke "sh" "bootstrap")))
169 (add-before 'check 'copy-bootstrap-guile
170 (lambda* (#:key system inputs #:allow-other-keys)
171 ;; Copy the bootstrap guile tarball in the store used
172 ;; by the test suite.
173 (define (intern tarball)
174 (let ((base (strip-store-file-name tarball)))
175 (copy-file tarball base)
176 (invoke "./test-env" "guix" "download"
177 (string-append "file://" (getcwd)
178 "/" base))
179 (delete-file base)))
180
181
182 (intern (assoc-ref inputs "boot-guile"))
183
184 ;; On x86_64 some tests need the i686 Guile.
185 ,@(if (and (not (%current-target-system))
186 (string=? (%current-system)
187 "x86_64-linux"))
188 '((intern (assoc-ref inputs "boot-guile/i686")))
189 '())
190 #t))
191 (add-after 'unpack 'disable-failing-tests
192 ;; XXX FIXME: These tests fail within the build container.
193 (lambda _
194 (substitute* "tests/syscalls.scm"
195 (("^\\(test-(assert|equal) \"(clone|setns|pivot-root)\"" all)
196 (string-append "(test-skip 1)\n" all)))
197 (substitute* "tests/containers.scm"
198 (("^\\(test-(assert|equal)" all)
199 (string-append "(test-skip 1)\n" all)))
200 (when (file-exists? "tests/guix-environment-container.sh")
201 (substitute* "tests/guix-environment-container.sh"
202 (("guix environment --version")
203 "exit 77\n")))
204 #t))
205 (add-before 'check 'set-SHELL
206 (lambda _
207 ;; 'guix environment' tests rely on 'SHELL' having a
208 ;; correct value, so set it.
209 (setenv "SHELL" (which "sh"))
210 #t))
211 (add-after 'install 'wrap-program
212 (lambda* (#:key inputs outputs #:allow-other-keys)
213 ;; Make sure the 'guix' command finds GnuTLS,
214 ;; Guile-JSON, and Guile-Git automatically.
215 (let* ((out (assoc-ref outputs "out"))
216 (guile (assoc-ref inputs "guile"))
217 (gcrypt (assoc-ref inputs "guile-gcrypt"))
218 (json (assoc-ref inputs "guile-json"))
219 (sqlite (assoc-ref inputs "guile-sqlite3"))
220 (git (assoc-ref inputs "guile-git"))
221 (bs (assoc-ref inputs
222 "guile-bytestructures"))
223 (ssh (assoc-ref inputs "guile-ssh"))
224 (gnutls (assoc-ref inputs "gnutls"))
225 (deps (list gcrypt json sqlite gnutls
226 git bs ssh))
227 (effective
228 (read-line
229 (open-pipe* OPEN_READ
230 (string-append guile "/bin/guile")
231 "-c" "(display (effective-version))")))
232 (path (string-join
233 (map (cut string-append <>
234 "/share/guile/site/"
235 effective)
236 (delete #f deps))
237 ":"))
238 (gopath (string-join
239 (map (cut string-append <>
240 "/lib/guile/" effective
241 "/site-ccache")
242 (delete #f deps))
243 ":")))
244
245 (wrap-program (string-append out "/bin/guix")
246 `("GUILE_LOAD_PATH" ":" prefix (,path))
247 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,gopath)))
248
249 #t))))))
250 (native-inputs `(("pkg-config" ,pkg-config)
251
252 ;; XXX: Keep the development inputs here even though
253 ;; they're unnecessary, just so that 'guix environment
254 ;; guix' always contains them.
255 ("autoconf" ,autoconf-wrapper)
256 ("automake" ,automake)
257 ("gettext" ,gettext-minimal)
258 ("texinfo" ,texinfo)
259 ("graphviz" ,graphviz)
260 ("help2man" ,help2man)
261 ("po4a" ,po4a)))
262 (inputs
263 `(("bzip2" ,bzip2)
264 ("gzip" ,gzip)
265 ("zlib" ,zlib) ;for 'guix publish'
266
267 ("sqlite" ,sqlite)
268 ("libgcrypt" ,libgcrypt)
269
270 ("guile" ,guile-2.2)
271
272 ;; Many tests rely on the 'guile-bootstrap' package, which is why we
273 ;; have it here.
274 ("boot-guile" ,(bootstrap-guile-origin (%current-system)))
275 ;; Some of the tests use "unshare" when it is available.
276 ("util-linux" ,util-linux)
277 ,@(if (and (not (%current-target-system))
278 (string=? (%current-system) "x86_64-linux"))
279 `(("boot-guile/i686" ,(bootstrap-guile-origin "i686-linux")))
280 '())))
281 (propagated-inputs
282 `(("gnutls" ,gnutls)
283 ("guile-gcrypt" ,guile-gcrypt)
284 ("guile-json" ,guile-json)
285 ("guile-sqlite3" ,guile-sqlite3)
286 ("guile-ssh" ,guile-ssh)
287 ("guile-git" ,guile-git)))
288
289 (home-page "https://www.gnu.org/software/guix/")
290 (synopsis "Functional package manager for installed software packages and versions")
291 (description
292 "GNU Guix is a functional package manager for the GNU system, and is
293 also a distribution thereof. It includes a virtual machine image. Besides
294 the usual package management features, it also supports transactional
295 upgrades and roll-backs, per-user profiles, and much more. It is based on
296 the Nix package manager.")
297 (license license:gpl3+)
298 (properties '((ftp-server . "alpha.gnu.org"))))))
299
300 ;; Alias for backward compatibility.
301 (define-public guix-devel guix)
302
303 (define-public guix-daemon
304 ;; This package is for internal consumption: it allows us to quickly build
305 ;; the 'guix-daemon' program and use that in (guix self), used by 'guix
306 ;; pull'.
307 (package
308 (inherit guix)
309 (properties `((hidden? . #t)))
310 (name "guix-daemon")
311
312 ;; Use a minimum set of dependencies.
313 (native-inputs
314 (fold alist-delete (package-native-inputs guix)
315 '("po4a" "graphviz" "help2man")))
316 (inputs
317 `(("gnutls" ,gnutls)
318 ("guile-git" ,guile-git)
319 ("guile-gcrypt" ,guile-gcrypt)
320 ,@(fold alist-delete (package-inputs guix)
321 '("boot-guile" "boot-guile/i686" "util-linux"))))
322
323 (propagated-inputs '())
324
325 (arguments
326 (substitute-keyword-arguments (package-arguments guix)
327 ((#:configure-flags flags '())
328 ;; Pretend we have those libraries; we don't actually need them.
329 `(append ,flags
330 '("guix_cv_have_recent_guile_sqlite3=yes"
331 "guix_cv_have_recent_guile_ssh=yes")))
332 ((#:tests? #f #f)
333 #f)
334 ((#:phases phases '%standard-phases)
335 `(modify-phases ,phases
336 (replace 'build
337 (lambda _
338 (invoke "make" "nix/libstore/schema.sql.hh")
339 (invoke "make" "-j" (number->string
340 (parallel-job-count))
341 "guix-daemon")))
342 (delete 'copy-bootstrap-guile)
343 (replace 'install
344 (lambda* (#:key outputs #:allow-other-keys)
345 (invoke "make" "install-binPROGRAMS"
346 "install-nodist_pkglibexecSCRIPTS")
347
348 ;; We need to tell 'guix-daemon' which 'guix' command to use.
349 ;; Here we use a questionable hack where we hard-code root's
350 ;; current guix, which could be wrong (XXX). Note that scripts
351 ;; like 'guix perform-download' do not run as root so we assume
352 ;; that they have access to /var/guix/profiles/per-user/root.
353 (let ((out (assoc-ref outputs "out")))
354 (substitute* (find-files (string-append out "/libexec"))
355 (("exec \".*/bin/guix\"")
356 "exec /var/guix/profiles/per-user/root/current-guix/bin/guix"))
357 #t)))
358 (delete 'wrap-program)))))))
359
360 (define-public guile2.0-guix
361 (package
362 (inherit guix)
363 (name "guile2.0-guix")
364 (inputs
365 `(("guile" ,guile-2.0)
366 ,@(alist-delete "guile" (package-inputs guix))))
367 (propagated-inputs
368 `(("gnutls" ,gnutls/guile-2.0)
369 ("guile-gcrypt" ,guile2.0-gcrypt)
370 ("guile-json" ,guile2.0-json)
371 ("guile-sqlite3" ,guile2.0-sqlite3)
372 ("guile-ssh" ,guile2.0-ssh)
373 ("guile-git" ,guile2.0-git)))))
374
375 (define-public guix-minimal
376 ;; A version of Guix which is built with the minimal set of dependencies, as
377 ;; outlined in the README "Requirements" section. Intended as a CI job, so
378 ;; marked as hidden.
379 (let ((guix guile2.0-guix))
380 (hidden-package
381 (package
382 (inherit guix)
383 (name "guix-minimal")
384 (inputs
385 `(("guile" ,guile-2.0.13)
386 ,@(alist-delete "guile" (package-inputs guix))))
387 (propagated-inputs
388 (fold alist-delete
389 (package-propagated-inputs guix)
390 '("guile-json" "guile-ssh")))))))
391
392 (define (source-file? file stat)
393 "Return true if FILE is likely a source file, false if it is a typical
394 generated file."
395 (define (wrong-extension? file)
396 (or (string-suffix? "~" file)
397 (member (file-extension file)
398 '("o" "a" "lo" "so" "go"))))
399
400 (match (basename file)
401 ((or ".git" "autom4te.cache" "configure" "Makefile" "Makefile.in" ".libs")
402 #f)
403 ((? wrong-extension?)
404 #f)
405 (_
406 #t)))
407
408 (define-public current-guix
409 (let* ((repository-root (canonicalize-path
410 (string-append (current-source-directory)
411 "/../..")))
412 (select? (delay (or (git-predicate repository-root)
413 source-file?))))
414 (lambda ()
415 "Return a package representing Guix built from the current source tree.
416 This works by adding the current source tree to the store (after filtering it
417 out) and returning a package that uses that as its 'source'."
418 (package
419 (inherit guix)
420 (version (string-append (package-version guix) "+"))
421 (source (local-file repository-root "guix-current"
422 #:recursive? #t
423 #:select? (force select?)))))))
424
425 \f
426 ;;;
427 ;;; Other tools.
428 ;;;
429
430 (define-public nix
431 (package
432 (name "nix")
433 (version "2.0.4")
434 (source (origin
435 (method url-fetch)
436 (uri (string-append "http://nixos.org/releases/nix/nix-"
437 version "/nix-" version ".tar.xz"))
438 (sha256
439 (base32
440 "0ss9svxlh1pvrdmnqjvjyqjmbqmrdbyfarvbb14i9d4bggzl0r8n"))))
441 (build-system gnu-build-system)
442 (native-inputs `(("pkg-config" ,pkg-config)))
443 (inputs `(("curl" ,curl)
444 ("bzip2" ,bzip2)
445 ("libgc" ,libgc)
446 ("libseccomp" ,libseccomp)
447 ("libsodium" ,libsodium)
448 ("openssl" ,openssl)
449 ("sqlite" ,sqlite)
450 ("xz" ,xz)))
451 (home-page "https://nixos.org/nix/")
452 (synopsis "The Nix package manager")
453 (description
454 "Nix is a purely functional package manager. This means that it treats
455 packages like values in purely functional programming languages such as
456 Haskell—they are built by functions that don't have side-effects, and they
457 never change after they have been built. Nix stores packages in the Nix
458 store, usually the directory /nix/store, where each package has its own unique
459 sub-directory.")
460 (license license:lgpl2.1+)))
461
462 (define-public emacs-nix-mode
463 (package
464 (name "emacs-nix-mode")
465 (version "1.2.2")
466 (source
467 (origin
468 (method url-fetch)
469 (uri (string-append "https://github.com/NixOS/nix-mode/archive/v"
470 version ".tar.gz"))
471 (file-name (string-append name "-" version ".tar.gz"))
472 (sha256
473 (base32
474 "06aqz0czznsj8835jqnk794sy2p6pa8kxfqwh0nl5d5vxivria6z"))))
475 (build-system emacs-build-system)
476 (inputs
477 `(("emacs-company" ,emacs-company)
478 ("emacs-mmm-mode" ,emacs-mmm-mode)))
479 (home-page "https://github.com/NixOS/nix-mode")
480 (synopsis "Emacs major mode for editing Nix expressions")
481 (description "@code{nixos-mode} provides an Emacs major mode for editing
482 Nix expressions. It supports syntax highlighting, indenting and refilling of
483 comments.")
484 (license license:lgpl2.1+)))
485
486 (define-public stow
487 (package
488 (name "stow")
489 (version "2.2.2")
490 (source (origin
491 (method url-fetch)
492 (uri (string-append "mirror://gnu/stow/stow-"
493 version ".tar.gz"))
494 (sha256
495 (base32
496 "1pvky9fayms4r6fhns8jd0vavszd7d979w62vfd5n88v614pdxz2"))))
497 (build-system gnu-build-system)
498 (inputs
499 `(("perl" ,perl)))
500 (native-inputs
501 `(("perl-test-simple" ,perl-test-simple)
502 ("perl-test-output" ,perl-test-output)
503 ("perl-capture-tiny" ,perl-capture-tiny)
504 ("perl-io-stringy" ,perl-io-stringy)))
505 (home-page "https://www.gnu.org/software/stow/")
506 (synopsis "Managing installed software packages")
507 (description
508 "GNU Stow is a symlink manager. It generates symlinks to directories
509 of data and makes them appear to be merged into the same directory. It is
510 typically used for managing software packages installed from source, by
511 letting you install them apart in distinct directories and then create
512 symlinks to the files in a common directory such as /usr/local.")
513 (license license:gpl2+)))
514
515 (define-public rpm
516 (package
517 (name "rpm")
518 (version "4.14.2")
519 (source (origin
520 (method url-fetch)
521 (uri (string-append "http://ftp.rpm.org/releases/rpm-"
522 (version-major+minor version) ".x/rpm-"
523 version ".tar.bz2"))
524 (sha256
525 (base32
526 "0armd7dqr8bl0isx8l4xlylm7dikasmxhhcbz336fkp2x30w5jw0"))))
527 (build-system gnu-build-system)
528 (arguments
529 '(#:configure-flags '("--with-external-db" ;use the system's bdb
530 "--enable-python"
531 "--without-lua")
532 #:phases (modify-phases %standard-phases
533 (add-before 'configure 'set-nss-library-path
534 (lambda* (#:key inputs #:allow-other-keys)
535 (let ((nss (assoc-ref inputs "nss")))
536 (setenv "LIBRARY_PATH"
537 (string-append (getenv "LIBRARY_PATH") ":"
538 nss "/lib/nss"))
539 #t))))))
540 (native-inputs
541 `(("pkg-config" ,pkg-config)))
542 (inputs
543 `(("python" ,python-2)
544 ("xz" ,xz)
545 ("bdb" ,bdb)
546 ("popt" ,popt)
547 ("nss" ,nss)
548 ("nspr" ,nspr)
549 ("libarchive" ,libarchive)
550 ("nettle" ,nettle) ;XXX: actually a dependency of libarchive
551 ("file" ,file)
552 ("bzip2" ,bzip2)
553 ("zlib" ,zlib)
554 ("cpio" ,cpio)))
555 (home-page "http://rpm.org/")
556 (synopsis "The RPM Package Manager")
557 (description
558 "The RPM Package Manager (RPM) is a command-line driven package
559 management system capable of installing, uninstalling, verifying, querying,
560 and updating computer software packages. Each software package consists of an
561 archive of files along with information about the package like its version, a
562 description. There is also a library permitting developers to manage such
563 transactions from C or Python.")
564
565 ;; The whole is GPLv2+; librpm itself is dual-licensed LGPLv2+ | GPLv2+.
566 (license license:gpl2+)))
567
568 (define-public diffoscope
569 (package
570 (name "diffoscope")
571 (version "102")
572 (source (origin
573 (method url-fetch)
574 (uri (pypi-uri name version))
575 (sha256
576 (base32
577 "0v2z98xx7n4viw12yq83flpb9ir5ahy1gn44pic0i3dam18xhcm6"))))
578 (build-system python-build-system)
579 (arguments
580 `(#:phases (modify-phases %standard-phases
581 ;; setup.py mistakenly requires python-magic from PyPi, even
582 ;; though the Python bindings of `file` are sufficient.
583 ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
584 (add-after 'unpack 'dependency-on-python-magic
585 (lambda _
586 (substitute* "setup.py"
587 (("'python-magic',") ""))))
588 (add-after 'unpack 'embed-tool-references
589 (lambda* (#:key inputs #:allow-other-keys)
590 (substitute* "diffoscope/comparators/utils/compare.py"
591 (("\\['xxd',")
592 (string-append "['" (which "xxd") "',")))
593 (substitute* "diffoscope/comparators/elf.py"
594 (("@tool_required\\('readelf'\\)") "")
595 (("get_tool_name\\('readelf'\\)")
596 (string-append "'" (which "readelf") "'")))
597 (substitute* "diffoscope/comparators/directory.py"
598 (("@tool_required\\('stat'\\)") "")
599 (("@tool_required\\('getfacl'\\)") "")
600 (("\\['stat',")
601 (string-append "['" (which "stat") "',"))
602 (("\\['getfacl',")
603 (string-append "['" (which "getfacl") "',")))
604 #t))
605 (add-before 'check 'delete-failing-test
606 (lambda _
607 (delete-file "tests/test_tools.py") ;this requires /sbin to be on the path
608 #t)))))
609 (inputs `(("rpm" ,rpm) ;for rpm-python
610 ("python-file" ,python-file)
611 ("python-debian" ,python-debian)
612 ("python-libarchive-c" ,python-libarchive-c)
613 ("python-tlsh" ,python-tlsh)
614 ("acl" ,acl) ;for getfacl
615 ("colordiff" ,colordiff)
616 ("xxd" ,xxd)
617
618 ;; Below are modules used for tests.
619 ("python-pytest" ,python-pytest)
620 ("python-chardet" ,python-chardet)))
621 (home-page "https://diffoscope.org/")
622 (synopsis "Compare files, archives, and directories in depth")
623 (description
624 "Diffoscope tries to get to the bottom of what makes files or directories
625 different. It recursively unpacks archives of many kinds and transforms
626 various binary formats into more human readable forms to compare them. It can
627 compare two tarballs, ISO images, or PDFs just as easily.")
628 (license license:gpl3+)))
629
630 (define-public python-anaconda-client
631 (package
632 (name "python-anaconda-client")
633 (version "1.6.3")
634 (source
635 (origin
636 (method url-fetch)
637 (uri (string-append "https://github.com/Anaconda-Platform/"
638 "anaconda-client/archive/" version ".tar.gz"))
639 (file-name (string-append name "-" version ".tar.gz"))
640 (sha256
641 (base32
642 "1wv4wi6k5jz7rlwfgvgfdizv77x3cr1wa2aj0k1595g7fbhkjhz2"))))
643 (build-system python-build-system)
644 (propagated-inputs
645 `(("python-pyyaml" ,python-pyyaml)
646 ("python-requests" ,python-requests)
647 ("python-clyent" ,python-clyent)))
648 (native-inputs
649 `(("python-pytz" ,python-pytz)
650 ("python-dateutil" ,python-dateutil)
651 ("python-mock" ,python-mock)
652 ("python-coverage" ,python-coverage)
653 ("python-pillow" ,python-pillow)))
654 (arguments
655 `(#:phases
656 (modify-phases %standard-phases
657 ;; This is needed for some tests.
658 (add-before 'check 'set-up-home
659 (lambda* _ (setenv "HOME" "/tmp") #t))
660 (add-before 'check 'remove-network-tests
661 (lambda* _
662 ;; Remove tests requiring a network connection
663 (let ((network-tests '("tests/test_upload.py"
664 "tests/test_authorizations.py"
665 "tests/test_login.py"
666 "tests/test_whoami.py"
667 "utils/notebook/tests/test_data_uri.py"
668 "utils/notebook/tests/test_base.py"
669 "utils/notebook/tests/test_downloader.py"
670 "inspect_package/tests/test_conda.py")))
671 (with-directory-excursion "binstar_client"
672 (for-each delete-file network-tests)))
673 #t)))))
674 (home-page "https://github.com/Anaconda-Platform/anaconda-client")
675 (synopsis "Anaconda Cloud command line client library")
676 (description
677 "Anaconda Cloud command line client library provides an interface to
678 Anaconda Cloud. Anaconda Cloud is useful for sharing packages, notebooks and
679 environments.")
680 (license license:bsd-3)))
681
682 (define-public python2-anaconda-client
683 (package-with-python2 python-anaconda-client))
684
685 (define-public python-conda
686 (package
687 (name "python-conda")
688 (version "4.3.16")
689 (source
690 (origin
691 (method url-fetch)
692 (uri (string-append "https://github.com/conda/conda/archive/"
693 version ".tar.gz"))
694 (file-name (string-append name "-" version ".tar.gz"))
695 (sha256
696 (base32
697 "1jq8hyrc5npb5sf4vw6s6by4602yj8f79vzpbwdfgpkn02nfk1dv"))))
698 (build-system python-build-system)
699 (arguments
700 `(#:phases
701 (modify-phases %standard-phases
702 (add-before 'build 'create-version-file
703 (lambda _
704 (with-output-to-file "conda/.version"
705 (lambda () (display ,version)))
706 #t))
707 (add-before 'check 'remove-failing-tests
708 (lambda _
709 ;; These tests require internet/network access
710 (let ((network-tests '("test_cli.py"
711 "test_create.py"
712 "test_export.py"
713 "test_fetch.py"
714 "test_history.py"
715 "test_info.py"
716 "test_install.py"
717 "test_priority.py"
718 "conda_env/test_cli.py"
719 "conda_env/test_create.py"
720 "conda_env/specs/test_notebook.py"
721 "conda_env/utils/test_notebooks.py"
722 "core/test_index.py"
723 "core/test_repodata.py")))
724 (with-directory-excursion "tests"
725 (for-each delete-file network-tests)
726
727 ;; FIXME: This test creates a file, then deletes it and tests
728 ;; that the file was deleted. For some reason it fails when
729 ;; building with guix, but does not when you run it in the
730 ;; directory left when you build with the --keep-failed
731 ;; option
732 (delete-file "gateways/disk/test_delete.py")
733 #t))))
734 (replace 'check
735 (lambda _
736 (setenv "HOME" "/tmp")
737 (zero? (system* "py.test")))))))
738 (native-inputs
739 `(("python-ruamel.yaml" ,python-ruamel.yaml)
740 ("python-requests" ,python-requests)
741 ("python-pycosat" ,python-pycosat)
742 ("python-pytest" ,python-pytest)
743 ("python-responses" ,python-responses)
744 ("python-pyyaml" ,python-pyyaml)
745 ("python-anaconda-client" ,python-anaconda-client)))
746 (home-page "https://github.com/conda/conda")
747 (synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
748 (description
749 "Conda is a cross-platform, Python-agnostic binary package manager. It
750 is the package manager used by Anaconda installations, but it may be used for
751 other systems as well. Conda makes environments first-class citizens, making
752 it easy to create independent environments even for C libraries. Conda is
753 written entirely in Python.
754
755 This package provides Conda as a library.")
756 (license license:bsd-3)))
757
758 (define-public python2-conda
759 (let ((base (package-with-python2
760 (strip-python2-variant python-conda))))
761 (package (inherit base)
762 (native-inputs
763 `(("python2-enum34" ,python2-enum34)
764 ,@(package-native-inputs base))))))
765
766 (define-public conda
767 (package (inherit python-conda)
768 (name "conda")
769 (arguments
770 (substitute-keyword-arguments (package-arguments python-conda)
771 ((#:phases phases)
772 `(modify-phases ,phases
773 (replace 'build
774 (lambda* (#:key outputs #:allow-other-keys)
775 ;; This test fails when run before installation.
776 (delete-file "tests/test_activate.py")
777
778 ;; Fix broken defaults
779 (substitute* "conda/base/context.py"
780 (("return sys.prefix")
781 (string-append "return \"" (assoc-ref outputs "out") "\""))
782 (("return (prefix_is_writable\\(self.root_prefix\\))" _ match)
783 (string-append "return False if self.root_prefix == self.conda_prefix else "
784 match)))
785
786 ;; The util/setup-testing.py is used to build conda in
787 ;; application form, rather than the default, library form.
788 ;; With this, we are able to run commands like `conda --help`
789 ;; directly on the command line
790 (zero? (system* "python" "utils/setup-testing.py" "build_py"))))
791 (replace 'install
792 (lambda* (#:key inputs outputs #:allow-other-keys)
793 (let* ((out (assoc-ref outputs "out"))
794 (target (string-append out "/lib/python"
795 ((@@ (guix build python-build-system)
796 get-python-version)
797 (assoc-ref inputs "python"))
798 "/site-packages/")))
799 ;; The installer aborts if the target directory is not on
800 ;; PYTHONPATH.
801 (setenv "PYTHONPATH"
802 (string-append target ":" (getenv "PYTHONPATH")))
803
804 ;; And it aborts if the directory doesn't exist.
805 (mkdir-p target)
806 (zero? (system* "python" "utils/setup-testing.py" "install"
807 (string-append "--prefix=" out))))))
808 ;; The "activate" and "deactivate" scripts don't need wrapping.
809 ;; They also break when they are renamed.
810 (add-after 'wrap 'undo-wrap
811 (lambda* (#:key outputs #:allow-other-keys)
812 (with-directory-excursion (string-append (assoc-ref outputs "out") "/bin/")
813 (delete-file "deactivate")
814 (rename-file ".deactivate-real" "deactivate")
815 (delete-file "activate")
816 (rename-file ".activate-real" "activate")
817 #t)))))))
818 (description
819 "Conda is a cross-platform, Python-agnostic binary package manager. It
820 is the package manager used by Anaconda installations, but it may be used for
821 other systems as well. Conda makes environments first-class citizens, making
822 it easy to create independent environments even for C libraries. Conda is
823 written entirely in Python.")))
824
825 (define-public gwl
826 (package
827 (name "gwl")
828 (version "0.1.1")
829 (source (origin
830 (method url-fetch)
831 (uri (string-append "https://www.guixwl.org/releases/gwl-"
832 version ".tar.gz"))
833 (sha256
834 (base32
835 "06pm967mq1wyggx7l0nfapw5s0k5qc5r9lawk2v3db868br779a7"))))
836 (build-system gnu-build-system)
837 (native-inputs
838 `(("autoconf" ,autoconf)
839 ("automake" ,automake)
840 ("pkg-config" ,pkg-config)))
841 (inputs
842 `(("guile" ,guile-2.2)))
843 (propagated-inputs
844 `(("guix" ,guix)
845 ("guile-commonmark" ,guile-commonmark)))
846 (home-page "https://www.guixwl.org")
847 (synopsis "Workflow management extension for GNU Guix")
848 (description "This project provides two subcommands to GNU Guix and
849 introduces two record types that provide a workflow management extension built
850 on top of GNU Guix.")
851 ;; The Scheme modules in guix/ and gnu/ are licensed GPL3+,
852 ;; the web interface modules in gwl/ are licensed AGPL3+,
853 ;; and the fonts included in this package are licensed OFL1.1.
854 (license (list license:gpl3+ license:agpl3+ license:silofl1.1))))
855
856 (define-public gcab
857 (package
858 (name "gcab")
859 (version "1.1")
860 (source (origin
861 (method url-fetch)
862 (uri (string-append "mirror://gnome/sources/" name "/"
863 version "/" name "-" version ".tar.xz"))
864 (sha256
865 (base32
866 "0l19sr6pg0cfcddmi5n79d08mjjbhn427ip5jlsy9zddq9r24aqr"))
867 ;; gcab 1.1 has a hard dependency on git — even when building
868 ;; from a tarball. Remove it early so ‘guix environment gcab’
869 ;; can actually build what ‘guix build --source gcab’ returns.
870 (modules '((guix build utils)))
871 (snippet
872 '(begin
873 (substitute* "meson.build"
874 (("git_version = .*$") "git_version = []\n"))
875 #t))))
876 (build-system meson-build-system)
877 (native-inputs
878 `(("glib:bin" ,glib "bin") ; for glib-mkenums
879 ("intltool" ,intltool)
880 ("pkg-config" ,pkg-config)
881 ("vala" ,vala)))
882 (inputs
883 `(("glib" ,glib)
884 ("zlib" ,zlib)))
885 (arguments
886 `(#:configure-flags
887 ;; XXX This ‘documentation’ is for developers, and fails informatively:
888 ;; Error in gtkdoc helper script: 'gtkdoc-mkhtml' failed with status 5
889 (list "-Ddocs=false"
890 "-Dintrospection=false")))
891 (home-page "https://wiki.gnome.org/msitools") ; no dedicated home page
892 (synopsis "Microsoft Cabinet file manipulation library")
893 (description
894 "The libgcab library provides GObject functions to read, write, and modify
895 Microsoft cabinet (.@dfn{CAB}) files.")
896 (license (list license:gpl2+ ; tests/testsuite.at
897 license:lgpl2.1+)))) ; the rest
898
899 (define-public msitools
900 (package
901 (name "msitools")
902 (version "0.98")
903 (source (origin
904 (method url-fetch)
905 (uri (string-append "mirror://gnome/sources/" name "/"
906 version "/" name "-" version ".tar.xz"))
907 (sha256
908 (base32
909 "19wb3n3nwkpc6bjr0q3f1znaxsfaqgjbdxxnbx8ic8bb5b49hwac"))))
910 (build-system gnu-build-system)
911 (native-inputs
912 `(("pkg-config" ,pkg-config)))
913 (inputs
914 `(("gcab" ,gcab)
915 ("glib" ,glib)
916 ("libgsf" ,libgsf)
917 ("libxml2" ,libxml2)
918 ("uuid" ,util-linux)))
919 (home-page "https://wiki.gnome.org/msitools")
920 (synopsis "Windows Installer file manipulation tool")
921 (description
922 "msitools is a collection of command-line tools to inspect, extract, build,
923 and sign Windows@tie{}Installer (.@dfn{MSI}) files. It aims to be a solution
924 for packaging and deployment of cross-compiled Windows applications.")
925 (license license:lgpl2.1+)))
926
927 (define-public libostree
928 (package
929 (name "libostree")
930 (version "2018.7")
931 (source (origin
932 (method url-fetch)
933 (uri (string-append
934 "https://github.com/ostreedev/ostree/releases/download/v"
935 version "/libostree-" version ".tar.xz"))
936 (sha256
937 (base32
938 "1nc310lv36psxn5yslkxlgi9gjxwqpwqzkg2pldgpwrlv6gkagj8"))))
939 (build-system gnu-build-system)
940 (arguments
941 '(#:phases
942 (modify-phases %standard-phases
943 (add-before 'check 'pre-check
944 (lambda _
945 ;; Don't try to use the non-existing '/var/tmp' as test
946 ;; directory.
947 (setenv "TEST_TMPDIR" (getenv "TMPDIR"))
948 #t)))
949 ;; XXX: fails with:
950 ;; tap-driver.sh: internal error getting exit status
951 ;; tap-driver.sh: fatal: I/O or internal error
952 #:tests? #f))
953 (native-inputs
954 `(("attr" ,attr) ; for tests
955 ("bison" ,bison)
956 ("glib:bin" ,glib "bin") ; for 'glib-mkenums'
957 ("gobject-introspection" ,gobject-introspection)
958 ("pkg-config" ,pkg-config)
959 ("xsltproc" ,libxslt)))
960 (inputs
961 `(("avahi" ,avahi)
962 ("docbook-xml" ,docbook-xml-4.2)
963 ("docbook-xsl" ,docbook-xsl)
964 ("e2fsprogs" ,e2fsprogs)
965 ("fuse" ,fuse)
966 ("glib" ,glib)
967 ("gpgme" ,gpgme)
968 ("libarchive" ,libarchive)
969 ("libsoup" ,libsoup)
970 ("nettle" ,nettle) ; required by 'libarchive.la'
971 ("util-linux" ,util-linux)))
972 (home-page "https://ostree.readthedocs.io/en/latest/")
973 (synopsis "Operating system and container binary deployment and upgrades")
974 (description
975 "@code{libostree} is both a shared library and suite of command line
976 tools that combines a \"git-like\" model for committing and downloading
977 bootable filesystem trees, along with a layer for deploying them and managing
978 the bootloader configuration.")
979 (license license:lgpl2.0+)))