gnu: zile: Use 'modify-phases' syntax.
[jackhill/guix/guix.git] / gnu / packages / zile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages zile)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix packages)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages bdw-gc)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages man)
29 #:use-module (gnu packages ncurses)
30 #:use-module (gnu packages bash)
31 #:use-module (gnu packages pkg-config))
32
33 (define-public zile
34 (package
35 (name "zile")
36 (version "2.4.13")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/zile/zile-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "03mcg0bxkzprlsx8y6h22w924pzx4a9zr7zm3g11j8j3x9lz75f7"))))
44 (build-system gnu-build-system)
45 (arguments
46 '(#:phases
47 (modify-phases %standard-phases
48 (add-before 'configure 'patch-/bin/sh
49 (lambda* (#:key inputs #:allow-other-keys)
50 (let ((bash (assoc-ref inputs "bash")))
51 ;; Refer to the actual shell.
52 (substitute* '("lib/spawni.c" "src/funcs.c")
53 (("/bin/sh")
54 (string-append bash "/bin/sh")))
55 #t))))))
56 (inputs
57 `(("boehm-gc" ,libgc)
58 ("ncurses" ,ncurses)
59 ("bash" ,bash)))
60 (native-inputs
61 `(("perl" ,perl)
62 ("help2man" ,help2man)
63 ("pkg-config" ,pkg-config)))
64 (home-page "https://www.gnu.org/software/zile/")
65 (synopsis "Lightweight Emacs clone")
66 (description
67 "GNU Zile is a lightweight Emacs clone. It usage is similar to the
68 default Emacs configuration, but it carries a much lighter feature set.")
69 (license gpl3+)))