gnu: openscad: Add patch to fix build.
[jackhill/guix/guix.git] / gnu / packages / patches / vboot-utils-skip-test-workbuf.patch
1 This patch was copied from Debian.
2
3 Description: skip the workbuf test if VB2_WORKBUF_ALIGN different from 16
4 Author: Sophie Brun <sophie@freexian.com>
5 Last-Update: 2015-12-03
6 ---
7 This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
8 --- a/tests/vb2_common_tests.c
9 +++ b/tests/vb2_common_tests.c
10 @@ -70,6 +70,11 @@ static void test_workbuf(void)
11 /* NOTE: There are several magic numbers below which assume that
12 * VB2_WORKBUF_ALIGN == 16 */
13
14 + /* Skip the tests if VB2_WORKBUF_ALIGN != 16 */
15 + if (VB2_WORKBUF_ALIGN != 16) {
16 + return;
17 + }
18 +
19 /* Init */
20 vb2_workbuf_init(&wb, p0, 64);
21 TEST_EQ(vb2_offset_of(p0, wb.buf), 0, "Workbuf init aligned");