gnu: openscad: Add patch to fix build.
[jackhill/guix/guix.git] / gnu / packages / patches / extundelete-e2fsprogs-1.44.patch
1 From: Tobias Geerinckx-Rice <me@tobias.gr>
2 Date: Thu, 16 Aug 2018 21:12:30 +0200
3 Subject: extundelete: Fix build with e2fsprogs 1.44.
4
5 The ‘inode.i_file_acl’ field was replaced with ‘inode.i_size_high’. I'm
6 not sure the field name is still accurate or useful, so don't print it
7 at all.
8
9 Based on this[0] patch by ‘conikost’[1].
10
11 [0]: https://sourceforge.net/p/extundelete/tickets/5/
12 [1]: https://sourceforge.net/u/conikost
13
14 --- a/src/insertionops.cc 2012-12-30 18:23:32.000000000 +0100
15 +++ b/src/insertionops.cc 2018-05-07 22:58:13.065868723 +0200
16 @@ -33,7 +33,6 @@
17 os << "File flags: " << inode.i_flags << std::endl;
18 os << "File version (for NFS): " << inode.i_generation << std::endl;
19 os << "File ACL: " << inode.i_file_acl << std::endl;
20 - os << "Directory ACL: " << inode.i_dir_acl << std::endl;
21 os << "Fragment address: " << inode.i_faddr << std::endl;
22 os << "Direct blocks: ";
23 for (int n = 0; n < EXT2_NDIR_BLOCKS; n++)