container: Gracefully report mount errors in the child process.
[jackhill/guix/guix.git] / gnu / packages / yubico.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages yubico)
21 #:use-module (gnu packages)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages man)
28 #:use-module (gnu packages curl))
29
30 (define-public libyubikey
31 (package
32 (name "libyubikey")
33 (version "1.13")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append
37 "https://developers.yubico.com/yubico-c/Releases/"
38 name "-" version ".tar.gz"))
39 (sha256
40 (base32
41 "009l3k2zyn06dbrlja2d4p2vfnzjhlcqxi88v02mlrnb17mx1v84"))))
42 (build-system gnu-build-system)
43 (synopsis "Development kit for the YubiKey authentication device")
44 (description
45 "This package contains a C library and command-line tools that make up
46 the low-level development kit for the Yubico YubiKey authentication device.")
47 (home-page "https://developers.yubico.com/yubico-c/")
48 (license bsd-2)))
49
50 (define-public ykclient
51 (package
52 (name "ykclient")
53 (version "2.15")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append
57 "https://developers.yubico.com/yubico-c-client/Releases/"
58 name "-" version ".tar.gz"))
59 (sha256
60 (base32
61 "05jhx9waj3pl120ddnwap1v3bjrnbfhvf3lxs2xmhpcmwzpwsqgl"))))
62 (build-system gnu-build-system)
63
64 ;; There's just one test, and it requires network access to access
65 ;; yubico.com, so skip it.
66 (arguments '(#:tests? #f))
67
68 (native-inputs `(("pkg-config" ,pkg-config)
69 ("help2man" ,help2man)))
70 (inputs `(("curl" ,curl)))
71 (synopsis "C library to validate one-time-password YubiKeys")
72 (description
73 "YubiKey C Client Library (libykclient) is a C library used to validate a
74 one-time-password (OTP) YubiKey against Yubico’s servers. See the Yubico
75 website for more information about Yubico and the YubiKey.")
76 (home-page "https://developers.yubico.com/yubico-c-client/")
77 (license bsd-2)))