container: Gracefully report mount errors in the child process.
[jackhill/guix/guix.git] / gnu / packages / terminals.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages terminals)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix build utils)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix download)
24 #:use-module (guix packages)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages glib)
28 #:use-module (gnu packages gnome)
29 #:use-module (gnu packages gtk)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages wm))
32
33 (define-public tilda
34 (package
35 (name "tilda")
36 (version "1.3.1")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "https://github.com/lanoxx/tilda/archive/"
40 "tilda-" version ".tar.gz"))
41 (sha256
42 (base32
43 "1nh0kw8f6srriglj55gmir1hvakcwrak1wcydz3vpnmwipgy6jib"))))
44 (build-system gnu-build-system)
45 (arguments
46 `(#:phases (modify-phases %standard-phases
47 (add-before 'patch-source-shebangs 'autogen
48 (lambda _ ; Avoid running ./configure.
49 (substitute* "autogen.sh"
50 (("^.*\\$srcdir/configure.*") ""))
51 (zero? (system* "sh" "autogen.sh")))))))
52 (native-inputs
53 `(("autoconf" ,autoconf)
54 ("automake" ,automake)
55 ("gettext" ,gnu-gettext)
56 ("pkg-config" ,pkg-config)))
57 (inputs
58 `(("glib" ,glib "bin")
59 ("gtk+" ,gtk+)
60 ("libconfuse" ,libconfuse)
61 ("vte" ,vte)))
62 (synopsis "GTK+-based drop-down terminal")
63 (description "Tilda is a terminal emulator similar to normal terminals like
64 gnome-terminal (GNOME) or Konsole (KDE), with the difference that it drops down
65 from the edge of a screen when a certain configurable hotkey is pressed. This
66 is similar to the built-in consoles in some applications. Tilda is highly
67 configureable through a graphical wizard.")
68 (home-page "https://github.com/lanoxx/tilda")
69 (license license:gpl2+)))