container: Gracefully report mount errors in the child process.
[jackhill/guix/guix.git] / gnu / packages / mate.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Fabian Harfert <fhmgufs@web.de>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mate)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages glib)
28 #:use-module (gnu packages gtk)
29 #:use-module (gnu packages gnome)
30 #:use-module (gnu packages xorg)
31 #:use-module (gnu packages xdisorg)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages xml)
34 #:use-module (gnu packages python))
35
36 (define-public mate-icon-theme
37 (package
38 (name "mate-icon-theme")
39 (version "1.12.0")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append "http://pub.mate-desktop.org/releases/"
43 (version-major+minor version) "/"
44 name "-" version ".tar.xz"))
45 (sha256
46 (base32
47 "0d91rvl9rw3xl8hmdcbb6xvi880kfmh2ra5chhrjimrjqgl57qkp"))))
48 (build-system gnu-build-system)
49 (native-inputs
50 `(("pkg-config" ,pkg-config)
51 ("intltool" ,intltool)
52 ("gtk+" ,gtk+)
53 ("icon-naming-utils" ,icon-naming-utils)))
54 (home-page "http://mate-desktop.org/")
55 (synopsis "The MATE desktop environment icon theme")
56 (description
57 "This package contains the default icon theme used by the MATE desktop.")
58 (license license:lgpl3+)))
59
60 (define-public mate-themes
61 (package
62 (name "mate-themes")
63 (version "1.12.2")
64 (source (origin
65 (method url-fetch)
66 (uri (string-append "http://pub.mate-desktop.org/releases/"
67 (version-major+minor version) "/"
68 name "-gtk"
69 (version-major+minor (package-version gtk+))
70 "-" version ".tar.xz"))
71 (sha256
72 (base32
73 "0kyrlgs5azzj60gnxx2n9qszcligxn959wr42wr0iqnrpiygk5nf"))))
74 (build-system gnu-build-system)
75 (native-inputs
76 `(("pkg-config" ,pkg-config)
77 ("intltool" ,intltool)))
78 (inputs
79 `(("gtk+" ,gtk+-2)
80 ("gdk-pixbuf" ,gdk-pixbuf)
81 ("gtk-engines" ,gtk-engines)
82 ("murrine" ,murrine)))
83 (home-page "http://mate-desktop.org/")
84 (synopsis
85 "Official themes for the MATE desktop")
86 (description
87 "This package includes the standard themes for the MATE desktop, for
88 example Menta, TraditionalOk, GreenLaguna or BlackMate.")
89 (license (list license:lgpl2.1+ license:cc-by-sa3.0 license:gpl3+
90 license:gpl2+))))
91
92 (define-public mate-desktop
93 (package
94 (name "mate-desktop")
95 (version "1.12.1")
96 (source (origin
97 (method url-fetch)
98 (uri (string-append "http://pub.mate-desktop.org/releases/"
99 (version-major+minor version) "/"
100 name "-" version ".tar.xz"))
101 (sha256
102 (base32
103 "00ssrzm07xyrjra075jhir1f8iy382lla7923fhic29lap26mffr"))))
104 (build-system gnu-build-system)
105 (native-inputs
106 `(("pkg-config" ,pkg-config)
107 ("intltool" ,intltool)
108 ("glib:bin" ,glib "bin")
109 ("gobject-introspection" ,gobject-introspection)
110 ("yelp-tools" ,yelp-tools)))
111 ;;("gtk-doc" ,gtk-doc))) ; add back in when gtk-doc builds
112 (inputs
113 `(("libxrandr" ,libxrandr)))
114 (propagated-inputs
115 `(("dconf" ,dconf)
116 ("gtk+" ,gtk+-2)
117 ("startup-notification" ,startup-notification)))
118 (home-page "http://mate-desktop.org/")
119 (synopsis "Library with common API for various MATE modules")
120 (description
121 "This package contains a public API shared by several applications on the
122 desktop and the mate-about program.")
123 (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.1+))))
124
125 (define-public libmateweather
126 (package
127 (name "libmateweather")
128 (version "1.12.1")
129 (source (origin
130 (method url-fetch)
131 (uri (string-append "http://pub.mate-desktop.org/releases/"
132 (version-major+minor version) "/"
133 name "-" version ".tar.xz"))
134 (sha256
135 (base32
136 "0qrq6z6knybixnxmsvkw58hm033m91inf523mbvzgv2r822fpakl"))))
137 (build-system gnu-build-system)
138 (arguments
139 `(#:configure-flags
140 `(,(string-append "--with-zoneinfo-dir="
141 (assoc-ref %build-inputs "tzdata")
142 "/share/zoneinfo"))
143 #:phases
144 (modify-phases %standard-phases
145 (add-before
146 'check 'pre-check
147 (lambda* (#:key inputs #:allow-other-keys)
148 (substitute* "data/check-timezones.sh"
149 (("/usr/share/zoneinfo/zone.tab")
150 (string-append (assoc-ref inputs "tzdata")
151 "/share/zoneinfo/zone.tab")))
152 #t)))))
153 (native-inputs
154 `(("pkg-config" ,pkg-config)
155 ("intltool" ,intltool)
156 ("glib:bin" ,glib "bin")))
157 (inputs
158 `(("dconf" ,dconf)
159 ("tzdata" ,tzdata)))
160 (propagated-inputs
161 `(("gtk+" ,gtk+-2)
162 ("gdk-pixbuf" ,gdk-pixbuf)
163 ("libxml2" ,libxml2)
164 ("libsoup" ,libsoup)))
165 (home-page "http://mate-desktop.org/")
166 (synopsis "MATE library for weather information from the Internet")
167 (description
168 "This library provides acess to weather information from the internet for
169 the MATE desktop environment.")
170 (license license:lgpl2.1+)))
171
172 (define-public mate-menus
173 (package
174 (name "mate-menus")
175 (version "1.12.0")
176 (source (origin
177 (method url-fetch)
178 (uri (string-append "http://pub.mate-desktop.org/releases/"
179 (version-major+minor version) "/"
180 name "-" version ".tar.xz"))
181 (sha256
182 (base32
183 "1i4m3fj0vd85zyhqhm8x9yr0h5i08aa4l99zqvbk59ncj6z3bdxh"))))
184 (build-system gnu-build-system)
185 (arguments
186 `(#:phases
187 (modify-phases %standard-phases
188 (add-after
189 'unpack 'fix-introspection-install-dir
190 (lambda* (#:key outputs #:allow-other-keys)
191 (let ((out (assoc-ref outputs "out")))
192 (substitute* '("configure")
193 (("`\\$PKG_CONFIG --variable=girdir gobject-introspection-1.0`")
194 (string-append "\"" out "/share/gir-1.0/\""))
195 (("\\$\\(\\$PKG_CONFIG --variable=typelibdir gobject-introspection-1.0\\)")
196 (string-append out "/lib/girepository-1.0/")))))))))
197 (native-inputs
198 `(("pkg-config" ,pkg-config)
199 ("intltool" ,intltool)
200 ("gobject-introspection" ,gobject-introspection)))
201 (inputs
202 `(("python" ,python-2)))
203 (propagated-inputs
204 `(("glib" ,glib)))
205 (home-page "http://mate-desktop.org/")
206 (synopsis "Freedesktop menu specification implementation for MATE")
207 (description
208 "The package contains an implementation of the freedesktop menu
209 specification, the MATE menu layout configuration files, .directory files and
210 assorted menu related utility programs.")
211 (license (list license:gpl2+ license:lgpl2.0+))))