container: Gracefully report mount errors in the child process.
[jackhill/guix/guix.git] / gnu / packages / databases.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2012, 2014, 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
5 ;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
6 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
7 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
8 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
9 ;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
10 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
11 ;;; Copyright © 2016 Nils Gillmann <niasterisk@grrlz.net>
12 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages databases)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages avahi)
33 #:use-module (gnu packages bash)
34 #:use-module (gnu packages boost)
35 #:use-module (gnu packages gettext)
36 #:use-module (gnu packages glib)
37 #:use-module (gnu packages perl)
38 #:use-module (gnu packages language)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages tls)
41 #:use-module (gnu packages compression)
42 #:use-module (gnu packages ncurses)
43 #:use-module (gnu packages readline)
44 #:use-module (gnu packages emacs)
45 #:use-module (gnu packages check)
46 #:use-module (gnu packages algebra)
47 #:use-module (gnu packages curl)
48 #:use-module (gnu packages cyrus-sasl)
49 #:use-module (gnu packages gnupg)
50 #:use-module (gnu packages python)
51 #:use-module (gnu packages pcre)
52 #:use-module (gnu packages pkg-config)
53 #:use-module (gnu packages rdf)
54 #:use-module (gnu packages xml)
55 #:use-module (gnu packages bison)
56 #:use-module (gnu packages jemalloc)
57 #:use-module ((guix licenses)
58 #:select (gpl2 gpl3 gpl3+ lgpl2.1+ lgpl3+ x11-style non-copyleft
59 bsd-2 bsd-3 public-domain))
60 #:use-module (guix packages)
61 #:use-module (guix download)
62 #:use-module (guix build-system gnu)
63 #:use-module (guix build-system perl)
64 #:use-module (guix build-system cmake)
65 #:use-module (guix utils)
66 #:use-module (srfi srfi-26)
67 #:use-module (ice-9 match))
68
69 (define-public 4store
70 (package
71 (name "4store")
72 (version "1.1.6")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append "https://github.com/garlik/4store/archive/v"
76 version ".tar.gz"))
77 (file-name (string-append name "-" version ".tar.gz"))
78 (sha256
79 (base32 "004fmcf1w75zhc1x3zc6kc97j4jqn2v5nhk6yb3z3cpfrhzi9j50"))
80 (patches (list (search-patch "4store-fix-buildsystem.patch")))))
81 (build-system gnu-build-system)
82 (native-inputs
83 `(("perl" ,perl)
84 ("python" ,python-2)
85 ("autoconf" ,autoconf)
86 ("automake" ,automake)
87 ("gettext" ,gnu-gettext)
88 ("libtool" ,libtool)
89 ("pkg-config" ,pkg-config)))
90 (inputs
91 `(("glib" ,glib)
92 ("rasqal" ,rasqal)
93 ("libxml2" ,libxml2)
94 ("raptor2" ,raptor2)
95 ("readline" ,readline)
96 ("avahi" ,avahi)
97 ("pcre" ,pcre)
98 ("cyrus-sasl" ,cyrus-sasl)
99 ("openssl" ,openssl)
100 ("util-linux" ,util-linux)))
101 (arguments
102 `(#:phases
103 (modify-phases %standard-phases
104 (add-before 'configure 'generate-configure
105 (lambda _
106 (zero? (system* "./autogen.sh")))))))
107 ;; http://www.4store.org has been down for a while now.
108 (home-page "https://github.com/garlik/4store")
109 (synopsis "Clustered RDF storage and query engine")
110 (description "4store is a RDF/SPARQL store written in C, supporting
111 either single machines or networked clusters.")
112 (license gpl3+)))
113
114 (define-public gdbm
115 (package
116 (name "gdbm")
117 (version "1.11")
118 (source (origin
119 (method url-fetch)
120 (uri (string-append "mirror://gnu/gdbm/gdbm-"
121 version ".tar.gz"))
122 (sha256
123 (base32
124 "1hz3jgh3pd4qzp6jy0l8pd8x01g9abw7csnrlnj1a2sxy122z4cd"))))
125 (arguments `(#:configure-flags '("--enable-libgdbm-compat")))
126 (build-system gnu-build-system)
127 (home-page "http://www.gnu.org/software/gdbm/")
128 (synopsis
129 "Hash library of database functions compatible with traditional dbm")
130 (description
131 "GDBM is a library for manipulating hashed databases. It is used to
132 store key/value pairs in a file in a manner similar to the Unix dbm library
133 and provides interfaces to the traditional file format.")
134 (license gpl3+)))
135
136 (define-public bdb
137 (package
138 (name "bdb")
139 (version "5.3.21")
140 (source (origin
141 (method url-fetch)
142 (uri (string-append "http://download.oracle.com/berkeley-db/db-" version
143 ".tar.gz"))
144 (sha256 (base32
145 "1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
146 (build-system gnu-build-system)
147 (outputs '("out" ; programs, libraries, headers
148 "doc")) ; 94 MiB of HTML docs
149 (arguments
150 '(#:tests? #f ; no check target available
151 #:phases
152 (alist-replace
153 'configure
154 (lambda* (#:key outputs #:allow-other-keys)
155 (let ((out (assoc-ref outputs "out"))
156 (doc (assoc-ref outputs "doc")))
157 ;; '--docdir' is not honored, so we need to patch.
158 (substitute* "dist/Makefile.in"
159 (("docdir[[:blank:]]*=.*")
160 (string-append "docdir = " doc "/share/doc/bdb")))
161
162 (zero?
163 (system* "./dist/configure"
164 (string-append "--prefix=" out)
165 (string-append "CONFIG_SHELL=" (which "bash"))
166 (string-append "SHELL=" (which "bash"))
167
168 ;; The compatibility mode is needed by some packages,
169 ;; notably iproute2.
170 "--enable-compat185"
171
172 ;; The following flag is needed so that the inclusion
173 ;; of db_cxx.h into C++ files works; it leads to
174 ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
175 "--enable-cxx"))))
176 %standard-phases)))
177 (synopsis "Berkeley database")
178 (description
179 "Berkeley DB is an embeddable database allowing developers the choice of
180 SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
181 (license (non-copyleft "file://LICENSE"
182 "See LICENSE in the distribution."))
183 (home-page
184 "http://www.oracle.com/us/products/database/berkeley-db/overview/index.html")))
185
186 (define-public mysql
187 (package
188 (name "mysql")
189 (version "5.7.12")
190 (source (origin
191 (method url-fetch)
192 (uri (list (string-append
193 "http://dev.mysql.com/get/Downloads/MySQL-"
194 (version-major+minor version) "/"
195 name "-" version ".tar.gz")
196 (string-append
197 "http://downloads.mysql.com/archives/get/file/"
198 name "-" version ".tar.gz")))
199 (sha256
200 (base32
201 "11qwbid666fspq143ymi86yva2b01lybaqh26k92rciasav3r11j"))))
202 (build-system cmake-build-system)
203 (arguments
204 '(#:configure-flags
205 '("-DBUILD_CONFIG=mysql_release"
206 "-DWITH_SSL=system"
207 "-DWITH_ZLIB=system"
208 "-DDEFAULT_CHARSET=utf8"
209 "-DDEFAULT_COLLATION=utf8_general_ci"
210 "-DMYSQL_DATADIR=/var/lib/mysql"
211 "-DMYSQL_UNIX_ADDR=/run/mysqld/mysqld.sock"
212 "-DINSTALL_INFODIR=share/mysql/docs"
213 "-DINSTALL_MANDIR=share/man"
214 "-DINSTALL_PLUGINDIR=lib/mysql/plugin"
215 "-DINSTALL_SCRIPTDIR=bin"
216 "-DINSTALL_INCLUDEDIR=include/mysql"
217 "-DINSTALL_DOCREADMEDIR=share/mysql/docs"
218 "-DINSTALL_SUPPORTFILESDIR=share/mysql"
219 "-DINSTALL_MYSQLSHAREDIR=share/mysql"
220 "-DINSTALL_DOCDIR=share/mysql/docs"
221 "-DINSTALL_SHAREDIR=share/mysql"
222 ;; Get rid of test data.
223 "-DINSTALL_MYSQLTESTDIR="
224 "-DINSTALL_SQLBENCHDIR=")
225 #:phases (modify-phases %standard-phases
226 (add-after
227 'unpack 'patch-boost-version
228 (lambda _
229 ;; Mysql wants boost-1.59.0 specifically
230 (substitute* "cmake/boost.cmake"
231 (("59") "60"))))
232 (add-after
233 'install 'remove-extra-binaries
234 (lambda* (#:key outputs #:allow-other-keys)
235 (let ((out (assoc-ref outputs "out")))
236 ;; Remove the 3 *_embedded files, which weigh in at
237 ;; 14 MiB each.
238 (for-each delete-file
239 (find-files (string-append out "/bin")
240 "_embedded$"))
241 #t))))))
242 (native-inputs
243 `(("bison" ,bison)
244 ("perl" ,perl)))
245 (inputs
246 `(("boost" ,boost)
247 ("libaio" ,libaio)
248 ("ncurses" ,ncurses)
249 ("openssl" ,openssl)
250 ("zlib" ,zlib)))
251 (home-page "http://www.mysql.com/")
252 (synopsis "Fast, easy to use, and popular database")
253 (description
254 "MySQL is a fast, reliable, and easy to use relational database
255 management system that supports the standardized Structured Query
256 Language.")
257 (license gpl2)))
258
259 (define-public mariadb
260 (package
261 (name "mariadb")
262 (version "10.1.12")
263 (source (origin
264 (method url-fetch)
265 (uri (string-append "https://downloads.mariadb.org/f/"
266 name "-" version "/source/"
267 name "-" version ".tar.gz"))
268 (sha256
269 (base32
270 "1rzlc2ns84x540asbkgdp9562haxhlszfpdqh64i9pz4q1m4cpvr"))))
271 (build-system cmake-build-system)
272 (arguments
273 '(#:configure-flags
274 '("-DBUILD_CONFIG=mysql_release"
275 "-DDEFAULT_CHARSET=utf8"
276 "-DDEFAULT_COLLATION=utf8_general_ci"
277 "-DMYSQL_DATADIR=/var/lib/mysql"
278 "-DMYSQL_UNIX_ADDR=/run/mysqld/mysqld.sock"
279 "-DINSTALL_INFODIR=share/mysql/docs"
280 "-DINSTALL_MANDIR=share/man"
281 "-DINSTALL_PLUGINDIR=lib/mysql/plugin"
282 "-DINSTALL_SCRIPTDIR=bin"
283 "-DINSTALL_INCLUDEDIR=include/mysql"
284 "-DINSTALL_DOCREADMEDIR=share/mysql/docs"
285 "-DINSTALL_SUPPORTFILESDIR=share/mysql/support-files"
286 "-DINSTALL_MYSQLSHAREDIR=share/mysql"
287 "-DINSTALL_DOCDIR=share/mysql/docs"
288 "-DINSTALL_SHAREDIR=share/mysql")
289 #:phases
290 (modify-phases %standard-phases
291 (add-before
292 'configure 'pre-configure
293 (lambda _
294 (setenv "CONFIG_SHELL" (which "sh"))
295 #t))
296 (add-after
297 'install 'post-install
298 (lambda* (#:key outputs #:allow-other-keys)
299 (let* ((out (assoc-ref outputs "out"))
300 (test (assoc-ref outputs "test")))
301 (substitute* (string-append out "/bin/mysql_install_db")
302 (("basedir=\"\"")
303 (string-append "basedir=\"" out "\"")))
304 ;; Remove unneeded files for testing.
305 (with-directory-excursion out
306 (for-each delete-file-recursively
307 '("data" "mysql-test" "sql-bench"
308 "share/man/man1/mysql-test-run.pl.1")))))))))
309 (native-inputs
310 `(("bison" ,bison)
311 ("perl" ,perl)))
312 (inputs
313 `(("jemalloc" ,jemalloc)
314 ("libaio" ,libaio)
315 ("libxml2" ,libxml2)
316 ("ncurses" ,ncurses)
317 ("openssl" ,openssl)
318 ("pcre" ,pcre)
319 ("zlib" ,zlib)))
320 (home-page "https://mariadb.org/")
321 (synopsis "SQL database server")
322 (description
323 "MariaDB is a multi-user and multi-threaded SQL database server, designed
324 as a drop-in replacement of MySQL.")
325 (license gpl2)))
326
327 (define-public postgresql
328 (package
329 (name "postgresql")
330 (version "9.5.3")
331 (source (origin
332 (method url-fetch)
333 (uri (string-append "https://ftp.postgresql.org/pub/source/v"
334 version "/postgresql-" version ".tar.bz2"))
335 (sha256
336 (base32
337 "1d500d2qsdzysnis6qi84xchnz5xh8kx8sjfmkbsijwaqlfw11bk"))))
338 (build-system gnu-build-system)
339 (arguments
340 `(#:phases
341 (modify-phases %standard-phases
342 (add-before 'configure 'patch-/bin/sh
343 (lambda _
344 ;; Refer to the actual shell.
345 (substitute* '("src/bin/pg_ctl/pg_ctl.c"
346 "src/bin/psql/command.c")
347 (("/bin/sh") (which "sh")))
348 #t)))))
349 (inputs
350 `(("readline" ,readline)
351 ("zlib" ,zlib)))
352 (home-page "http://www.postgresql.org/")
353 (synopsis "Powerful object-relational database system")
354 (description
355 "PostgreSQL is a powerful object-relational database system. It is fully
356 ACID compliant, has full support for foreign keys, joins, views, triggers, and
357 stored procedures (in multiple languages). It includes most SQL:2008 data
358 types, including INTEGER, NUMERIC, BOOLEAN, CHAR, VARCHAR, DATE, INTERVAL, and
359 TIMESTAMP. It also supports storage of binary large objects, including
360 pictures, sounds, or video.")
361 (license (x11-style "file://COPYRIGHT"))))
362
363 (define-public recutils
364 (package
365 (name "recutils")
366 (version "1.7")
367 (source (origin
368 (method url-fetch)
369 (uri (string-append "mirror://gnu/recutils/recutils-"
370 version ".tar.gz"))
371 (sha256
372 (base32
373 "0cdwa4094x3yx7vn98xykvnlp9rngvd58d19vs3vh5hrvggccg93"))))
374 (build-system gnu-build-system)
375
376 ;; Running tests in parallel leads to test failures and crashes in
377 ;; torture/utils.
378 (arguments '(#:parallel-tests? #f
379 #:configure-flags
380 (list (string-append "--with-bash-headers="
381 (assoc-ref %build-inputs "bash:include")
382 "/include/bash"))))
383
384 (native-inputs `(("emacs" ,emacs-minimal)
385 ("bc" ,bc)
386 ("bash:include" ,bash "include")
387 ("libuuid" ,util-linux)))
388
389 ;; TODO: Add more optional inputs.
390 (inputs `(("curl" ,curl)
391 ("libgcrypt" ,libgcrypt)
392 ("check" ,check)))
393 (synopsis "Manipulate plain text files as databases")
394 (description
395 "GNU Recutils is a set of tools and libraries for creating and
396 manipulating text-based, human-editable databases. Despite being text-based,
397 databases created with Recutils carry all of the expected features such as
398 unique fields, primary keys, time stamps and more. Many different field
399 types are supported, as is encryption.")
400 (license gpl3+)
401 (home-page "http://www.gnu.org/software/recutils/")))
402
403 (define-public sqlite
404 (package
405 (name "sqlite")
406 (version "3.10.0")
407 (source (origin
408 (method url-fetch)
409 ;; TODO: Download from sqlite.org once this bug :
410 ;; http://lists.gnu.org/archive/html/bug-guile/2013-01/msg00027.html
411 ;; has been fixed.
412 (uri (let ((numeric-version
413 (match (string-split version #\.)
414 ((first-digit other-digits ...)
415 (string-append first-digit
416 (string-pad-right
417 (string-concatenate
418 (map (cut string-pad <> 2 #\0)
419 other-digits))
420 6 #\0))))))
421 (list
422 (string-append
423 "https://fossies.org/linux/misc/sqlite-autoconf-"
424 numeric-version ".tar.gz")
425 (string-append
426 "http://distfiles.gentoo.org/distfiles/"
427 "/sqlite-autoconf-" numeric-version ".tar.gz"))
428
429 ;; XXX: As of 2015-09-08, SourceForge is squatting the URL
430 ;; below, returning 200 and showing an advertising page.
431 ;; (string-append
432 ;; "mirror://sourceforge/sqlite.mirror/SQLite%20" version
433 ;; "/sqlite-autoconf-" numeric-version ".tar.gz")
434 ))
435 (sha256
436 (base32
437 "0hhhv6si0pyf5i8bv7a71953m0b4gk6s3j2h09caf7vif0njkk23"))))
438 (build-system gnu-build-system)
439 (inputs `(("readline" ,readline)))
440 (arguments
441 `(#:configure-flags
442 ;; Add -DSQLITE_SECURE_DELETE and -DSQLITE_ENABLE_UNLOCK_NOTIFY to
443 ;; CFLAGS. GNU Icecat will refuse to use the system SQLite unless these
444 ;; options are enabled.
445 '("CFLAGS=-O2 -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_UNLOCK_NOTIFY")))
446 (home-page "http://www.sqlite.org/")
447 (synopsis "The SQLite database management system")
448 (description
449 "SQLite is a software library that implements a self-contained, serverless,
450 zero-configuration, transactional SQL database engine. SQLite is the most
451 widely deployed SQL database engine in the world. The source code for SQLite
452 is in the public domain.")
453 (license public-domain)))
454
455 (define-public tdb
456 (package
457 (name "tdb")
458 (version "1.3.9")
459 (source (origin
460 (method url-fetch)
461 (uri (string-append "https://www.samba.org/ftp/tdb/tdb-"
462 version ".tar.gz"))
463 (sha256
464 (base32
465 "1ll4q17scax1arg12faj8p25jq1f7q9irc3pwla0ziymwqkgf0bi"))))
466 (build-system gnu-build-system)
467 (arguments
468 '(#:phases (alist-replace
469 'configure
470 (lambda* (#:key outputs #:allow-other-keys)
471 (let ((out (assoc-ref outputs "out")))
472 ;; The 'configure' script is a wrapper for Waf and
473 ;; doesn't recognize things like '--enable-fast-install'.
474 (zero? (system* "./configure"
475 (string-append "--prefix=" out)))))
476 %standard-phases)))
477 (native-inputs
478 `(;; TODO: Build the documentation.
479 ;; ("docbook-xsl" ,docbook-xsl)
480 ;; ("libxml2" ,libxml2)
481 ;; ("libxslt" ,libxslt)
482 ("python" ,python-2))) ;for the Waf build system
483 (home-page "http://tdb.samba.org/")
484 (synopsis "Trivial database")
485 (description
486 "TDB is a Trivial Database. In concept, it is very much like GDBM,
487 and BSD's DB except that it allows multiple simultaneous writers and uses
488 locking internally to keep writers from trampling on each other. TDB is also
489 extremely small.")
490 (license lgpl3+)))
491
492 (define-public perl-dbi
493 (package
494 (name "perl-dbi")
495 (version "1.631")
496 (source (origin
497 (method url-fetch)
498 (uri (string-append
499 "mirror://cpan/authors/id/T/TI/TIMB/DBI-"
500 version ".tar.gz"))
501 (sha256
502 (base32
503 "04fmrnchhwi7jx4niaiv93vmi343hdm3xj04w9zr2m9hhqh782np"))))
504 (build-system perl-build-system)
505 (synopsis "Database independent interface for Perl")
506 (description "This package provides an database interface for Perl.")
507 (home-page "http://search.cpan.org/~timb/DBI-1.631/DBI.pm")
508 (license (package-license perl))))
509
510 (define-public perl-dbix-class
511 (package
512 (name "perl-dbix-class")
513 (version "0.082810")
514 (source
515 (origin
516 (method url-fetch)
517 (uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
518 "DBIx-Class-" version ".tar.gz"))
519 (sha256
520 (base32
521 "1zlsswk8j2k024gwhdhia8ksrmb8065n98dahkk8c0r69wv85n04"))))
522 (build-system perl-build-system)
523 (native-inputs
524 `(("perl-dbd-sqlite" ,perl-dbd-sqlite)
525 ("perl-file-temp" ,perl-file-temp)
526 ("perl-package-stash" ,perl-package-stash)
527 ("perl-test-deep" ,perl-test-deep)
528 ("perl-test-exception" ,perl-test-exception)
529 ("perl-test-warn" ,perl-test-warn)))
530 (propagated-inputs
531 `(("perl-class-accessor-grouped" ,perl-class-accessor-grouped)
532 ("perl-class-c3-componentised" ,perl-class-c3-componentised)
533 ("perl-class-inspector" ,perl-class-inspector)
534 ("perl-config-any" ,perl-config-any)
535 ("perl-context-preserve" ,perl-context-preserve)
536 ("perl-data-dumper-concise" ,perl-data-dumper-concise)
537 ("perl-data-page" ,perl-data-page)
538 ("perl-dbi" ,perl-dbi)
539 ("perl-devel-globaldestruction" ,perl-devel-globaldestruction)
540 ("perl-hash-merge" ,perl-hash-merge)
541 ("perl-module-find" ,perl-module-find)
542 ("perl-moo" ,perl-moo)
543 ("perl-mro-compat" ,perl-mro-compat)
544 ("perl-namespace-clean" ,perl-namespace-clean)
545 ("perl-path-class" ,perl-path-class)
546 ("perl-scalar-list-utils" ,perl-scalar-list-utils)
547 ("perl-scope-guard" ,perl-scope-guard)
548 ("perl-sql-abstract" ,perl-sql-abstract)
549 ("perl-sub-name" ,perl-sub-name)
550 ("perl-text-balanced" ,perl-text-balanced)
551 ("perl-try-tiny" ,perl-try-tiny)))
552 (home-page "http://search.cpan.org/dist/DBIx-Class")
553 (synopsis "Extensible and flexible object <-> relational mapper")
554 (description "An SQL to OO mapper with an object API inspired by
555 Class::DBI (with a compatibility layer as a springboard for porting) and a
556 resultset API that allows abstract encapsulation of database operations. It
557 aims to make representing queries in your code as perl-ish as possible while
558 still providing access to as many of the capabilities of the database as
559 possible, including retrieving related records from multiple tables in a
560 single query, \"JOIN\", \"LEFT JOIN\", \"COUNT\", \"DISTINCT\", \"GROUP BY\",
561 \"ORDER BY\" and \"HAVING\" support.")
562 (license (package-license perl))))
563
564 (define-public perl-dbix-class-cursor-cached
565 (package
566 (name "perl-dbix-class-cursor-cached")
567 (version "1.001002")
568 (source
569 (origin
570 (method url-fetch)
571 (uri (string-append "mirror://cpan/authors/id/A/AR/ARCANEZ/"
572 "DBIx-Class-Cursor-Cached-" version ".tar.gz"))
573 (sha256
574 (base32
575 "19r7jr6pknxiirrybq0cd0lnr76xiw05arnfqgk9nrhp6c7vvil0"))))
576 (build-system perl-build-system)
577 (native-inputs
578 `(("perl-cache-cache" ,perl-cache-cache)
579 ("perl-dbd-sqlite" ,perl-dbd-sqlite)))
580 (propagated-inputs
581 `(("perl-carp-clan" ,perl-carp-clan)
582 ("perl-dbix-class" ,perl-dbix-class)))
583 (home-page "http://search.cpan.org/dist/DBIx-Class-Cursor-Cached")
584 (synopsis "Cursor with built-in caching support")
585 (description "DBIx::Class::Cursor::Cached provides a cursor class with
586 built-in caching support.")
587 (license (package-license perl))))
588
589 (define-public perl-dbix-class-introspectablem2m
590 (package
591 (name "perl-dbix-class-introspectablem2m")
592 (version "0.001001")
593 (source
594 (origin
595 (method url-fetch)
596 (uri (string-append "mirror://cpan/authors/id/G/GR/GRODITI/"
597 "DBIx-Class-IntrospectableM2M-" version ".tar.gz"))
598 (sha256
599 (base32
600 "0p9zx1yc1f6jg583l206wilsni2v8mlngc2vf2q8yn10pmy4y6wm"))))
601 (build-system perl-build-system)
602 (propagated-inputs
603 `(("perl-dbix-class" ,perl-dbix-class)))
604 (home-page "http://search.cpan.org/dist/DBIx-Class-IntrospectableM2M")
605 (synopsis "Introspect many-to-many relationships")
606 (description "Because the many-to-many relationships are not real
607 relationships, they can not be introspected with DBIx::Class. Many-to-many
608 relationships are actually just a collection of convenience methods installed
609 to bridge two relationships. This DBIx::Class component can be used to store
610 all relevant information about these non-relationships so they can later be
611 introspected and examined.")
612 (license (package-license perl))))
613
614 (define-public perl-dbix-class-schema-loader
615 (package
616 (name "perl-dbix-class-schema-loader")
617 (version "0.07042")
618 (source
619 (origin
620 (method url-fetch)
621 (uri (string-append "mirror://cpan/authors/id/I/IL/ILMARI/"
622 "DBIx-Class-Schema-Loader-" version ".tar.gz"))
623 (sha256
624 (base32
625 "0sb48as7azmj6s4acxh98wcvcik7lxm7dcjz1c3wdrkrbmbbz0jf"))))
626 (build-system perl-build-system)
627 (native-inputs
628 `(("perl-config-any" ,perl-config-any)
629 ("perl-config-general" ,perl-config-general)
630 ("perl-dbd-sqlite" ,perl-dbd-sqlite)
631 ("perl-dbix-class-introspectablem2m" ,perl-dbix-class-introspectablem2m)
632 ("perl-moose" ,perl-moose)
633 ("perl-moosex-markasmethods" ,perl-moosex-markasmethods)
634 ("perl-moosex-nonmoose" ,perl-moosex-nonmoose)
635 ("perl-namespace-autoclean" ,perl-namespace-autoclean)
636 ("perl-test-deep" ,perl-test-deep)
637 ("perl-test-differences" ,perl-test-differences)
638 ("perl-test-exception" ,perl-test-exception)
639 ("perl-test-pod" ,perl-test-pod)
640 ("perl-test-warn" ,perl-test-warn)))
641 (propagated-inputs
642 `(("perl-class-unload" ,perl-class-unload)
643 ("perl-class-inspector" ,perl-class-inspector)
644 ("perl-class-accessor-grouped" ,perl-class-accessor-grouped)
645 ("perl-class-c3-componentised" ,perl-class-c3-componentised)
646 ("perl-carp-clan" ,perl-carp-clan)
647 ("perl-data-dump" ,perl-data-dump)
648 ("perl-dbix-class" ,perl-dbix-class)
649 ("perl-hash-merge" ,perl-hash-merge)
650 ("perl-list-moreutils" ,perl-list-moreutils)
651 ("perl-lingua-en-inflect-phrase" ,perl-lingua-en-inflect-phrase)
652 ("perl-lingua-en-inflect-number" ,perl-lingua-en-inflect-number)
653 ("perl-lingua-en-tagger" ,perl-lingua-en-tagger)
654 ("perl-namespace-clean" ,perl-namespace-clean)
655 ("perl-mro-compat" ,perl-mro-compat)
656 ("perl-scope-guard" ,perl-scope-guard)
657 ("perl-string-camelcase" ,perl-string-camelcase)
658 ("perl-string-toidentifier-en" ,perl-string-toidentifier-en)
659 ("perl-sub-name" ,perl-sub-name)
660 ("perl-try-tiny" ,perl-try-tiny)))
661 (arguments `(#:tests? #f)) ;TODO: t/20invocations.t fails
662 (home-page "http://search.cpan.org/dist/DBIx-Class-Schema-Loader")
663 (synopsis "Create a DBIx::Class::Schema based on a database")
664 (description "DBIx::Class::Schema::Loader automates the definition of a
665 DBIx::Class::Schema by scanning database table definitions and setting up the
666 columns, primary keys, unique constraints and relationships.")
667 (license (package-license perl))))
668
669 (define-public perl-dbd-pg
670 (package
671 (name "perl-dbd-pg")
672 (version "3.5.1")
673 (source
674 (origin
675 (method url-fetch)
676 (uri (string-append "mirror://cpan/authors/id/T/TU/TURNSTEP/"
677 "DBD-Pg-" version ".tar.gz"))
678 (sha256
679 (base32
680 "0z0kf1kjgbi5f6nr63i2fnrx7629d9lvxg1q8sficwb3zdf1ggzx"))))
681 (build-system perl-build-system)
682 (native-inputs
683 `(("perl-dbi" ,perl-dbi)))
684 (propagated-inputs
685 `(("perl-dbi" ,perl-dbi)
686 ("postgresql" ,postgresql)))
687 (home-page "http://search.cpan.org/dist/DBD-Pg")
688 (synopsis "DBI PostgreSQL interface")
689 (description "")
690 (license (package-license perl))))
691
692 (define-public perl-dbd-mysql
693 (package
694 (name "perl-dbd-mysql")
695 (version "4.033")
696 (source
697 (origin
698 (method url-fetch)
699 (uri (string-append "mirror://cpan/authors/id/C/CA/CAPTTOFU/"
700 "DBD-mysql-" version ".tar.gz"))
701 (sha256
702 (base32
703 "0769xakykps0cx368g4vaips4w3bjk383rianiavq7sq6g6bp66c"))))
704 (build-system perl-build-system)
705 ;; Tests require running MySQL server
706 (arguments `(#:tests? #f))
707 (propagated-inputs
708 `(("perl-dbi" ,perl-dbi)
709 ("mysql" ,mysql)))
710 (home-page "http://search.cpan.org/dist/DBD-mysql")
711 (synopsis "DBI MySQL interface")
712 (description "This package provides a MySQL driver for the Perl5
713 @dfn{Database Interface} (DBI).")
714 (license (package-license perl))))
715
716 (define-public perl-dbd-sqlite
717 (package
718 (name "perl-dbd-sqlite")
719 (version "1.42")
720 (source (origin
721 (method url-fetch)
722 (uri (string-append
723 "mirror://cpan/authors/id/I/IS/ISHIGAKI/DBD-SQLite-"
724 version ".tar.gz"))
725 (sha256
726 (base32
727 "14x9cjsc8dz8ad1nad0bqiq9cbk1rjfb8h5y0rpk3pdl38y6afxb"))))
728 (build-system perl-build-system)
729 (inputs `(("sqlite" ,sqlite)))
730 (propagated-inputs `(("perl-dbi" ,perl-dbi)))
731 (synopsis "SQlite interface for Perl")
732 (description "DBD::SQLite is a Perl DBI driver for SQLite, that includes
733 the entire thing in the distribution. So in order to get a fast transaction
734 capable RDBMS working for your Perl project you simply have to install this
735 module, and nothing else.")
736 (license (package-license perl))
737 (home-page "http://search.cpan.org/~ishigaki/DBD-SQLite/lib/DBD/SQLite.pm")))
738
739 (define-public perl-sql-abstract
740 (package
741 (name "perl-sql-abstract")
742 (version "1.81")
743 (source
744 (origin
745 (method url-fetch)
746 (uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
747 "SQL-Abstract-" version ".tar.gz"))
748 (sha256
749 (base32
750 "17sgwq3mvqjhv3b77cnvrq60xgp8harjhlnvpwmxc914rqc5ckaz"))))
751 (build-system perl-build-system)
752 (native-inputs
753 `(("perl-test-deep" ,perl-test-deep)
754 ("perl-test-exception" ,perl-test-exception)
755 ("perl-test-warn" ,perl-test-warn)))
756 (propagated-inputs
757 `(("perl-hash-merge" ,perl-hash-merge)
758 ("perl-moo" ,perl-moo)
759 ("perl-mro-compat" ,perl-mro-compat)
760 ("perl-text-balanced" ,perl-text-balanced)))
761 (home-page "http://search.cpan.org/dist/SQL-Abstract")
762 (synopsis "Generate SQL from Perl data structures")
763 (description "This module was inspired by the excellent DBIx::Abstract.
764 While based on the concepts used by DBIx::Abstract, the concepts used have
765 been modified to make the SQL easier to generate from Perl data structures.
766 The underlying idea is for this module to do what you mean, based on the data
767 structures you provide it, so that you don't have to modify your code every
768 time your data changes.")
769 (license (package-license perl))))
770
771 (define-public perl-sql-splitstatement
772 (package
773 (name "perl-sql-splitstatement")
774 (version "1.00020")
775 (source
776 (origin
777 (method url-fetch)
778 (uri (string-append "mirror://cpan/authors/id/E/EM/EMAZEP/"
779 "SQL-SplitStatement-" version ".tar.gz"))
780 (sha256
781 (base32
782 "0bqg45k4c9qkb2ypynlwhpvzsl4ssfagmsalys18s5c79ps30z7p"))))
783 (build-system perl-build-system)
784 (native-inputs
785 `(("perl-test-exception" ,perl-test-exception)))
786 (propagated-inputs
787 `(("perl-class-accessor" ,perl-class-accessor)
788 ("perl-list-moreutils" ,perl-list-moreutils)
789 ("perl-regexp-common" ,perl-regexp-common)
790 ("perl-sql-tokenizer" ,perl-sql-tokenizer)))
791 (home-page "http://search.cpan.org/dist/SQL-SplitStatement")
792 (synopsis "Split SQL code into atomic statements")
793 (description "This module tries to split any SQL code, even including
794 non-standard extensions, into the atomic statements it is composed of.")
795 (license (package-license perl))))
796
797 (define-public perl-sql-tokenizer
798 (package
799 (name "perl-sql-tokenizer")
800 (version "0.24")
801 (source
802 (origin
803 (method url-fetch)
804 (uri (string-append "mirror://cpan/authors/id/I/IZ/IZUT/"
805 "SQL-Tokenizer-" version ".tar.gz"))
806 (sha256
807 (base32
808 "1qa2dfbzdlr5qqdam9yn78z5w3al5r8577x06qan8wv58ay6ka7s"))))
809 (build-system perl-build-system)
810 (home-page "http://search.cpan.org/dist/SQL-Tokenizer")
811 (synopsis "SQL tokenizer")
812 (description "SQL::Tokenizer is a tokenizer for SQL queries. It does not
813 claim to be a parser or query verifier. It just creates sane tokens from a
814 valid SQL query.")
815 (license (package-license perl))))
816
817 (define-public unixodbc
818 (package
819 (name "unixodbc")
820 (version "2.3.4")
821 (source (origin
822 (method url-fetch)
823 (uri
824 (string-append
825 "ftp://ftp.unixodbc.org/pub/unixODBC/unixODBC-"
826 version ".tar.gz"))
827 (sha256
828 (base32 "0f8y88rcc2akjvjv5y66yx7k0ms9h1s0vbcfy25j93didflhj59f"))))
829 (build-system gnu-build-system)
830 (synopsis "Data source abstraction library")
831 (description "Unixodbc is a library providing an API with which to access
832 data sources. Data sources include SQL Servers and any software with an ODBC
833 Driver.")
834 (license lgpl2.1+)
835 ;; COPYING contains copy of lgpl2.1 - but copyright notices just say "LGPL"
836 (home-page "http://www.unixodbc.org")))
837
838 (define-public unqlite
839 (package
840 (name "unqlite")
841 (version "1.1.6")
842 (source (origin
843 (method url-fetch)
844 ;; Contains bug fixes against the official release, and has an
845 ;; autotooled build system.
846 (uri (string-append "https://github.com/aidin36/tocc/releases/"
847 "download/v1.0.0/"
848 "unqlite-unofficial-" version ".tar.gz"))
849 (sha256
850 (base32
851 "1sbpvhg15gadq0mpcy16q7k3rkg4b4dicpnn5xifpkpn02sqik3s"))))
852 (build-system gnu-build-system)
853 (arguments `(#:tests? #f)) ;No check target
854 (home-page "http://www.unqlite.org")
855 (synopsis "In-memory key/value and document store")
856 (description
857 "UnQLite is an in-process software library which implements a
858 self-contained, serverless, zero-configuration, transactional NoSQL
859 database engine. UnQLite is a document store database similar to
860 MongoDB, Redis, CouchDB, etc. as well as a standard Key/Value store
861 similar to BerkeleyDB, LevelDB, etc.")
862 (license bsd-2)))
863
864 (define-public redis
865 (package
866 (name "redis")
867 (version "3.2.0")
868 (source (origin
869 (method url-fetch)
870 (uri (string-append "http://download.redis.io/releases/redis-"
871 version".tar.gz"))
872 (sha256
873 (base32
874 "0ql7zp061xr66a1dzpa6a0ijm8zm133dd364va7q5h8avkrim7wq"))))
875 (build-system gnu-build-system)
876 (arguments
877 '(#:tests? #f ; tests related to master/slave and replication fail
878 #:phases (modify-phases %standard-phases
879 (delete 'configure))
880 #:make-flags `("CC=gcc"
881 "MALLOC=libc"
882 ,(string-append "PREFIX="
883 (assoc-ref %outputs "out")))))
884 (synopsis "Key-value cache and store")
885 (description "Redis is an advanced key-value cache and store. Redis
886 supports many data structures including strings, hashes, lists, sets, sorted
887 sets, bitmaps and hyperloglogs.")
888 (home-page "http://redis.io/")
889 (license bsd-3)))
890
891 (define-public kyotocabinet
892 (package
893 (name "kyotocabinet")
894 (version "1.2.76")
895 (source (origin
896 (method url-fetch)
897 (uri (string-append "http://fallabs.com/kyotocabinet/pkg/"
898 name "-" version ".tar.gz"))
899 (sha256
900 (base32
901 "0g6js20x7vnpq4p8ghbw3mh9wpqksya9vwhzdx6dnlf354zjsal1"))))
902 (build-system gnu-build-system)
903 (arguments
904 `(#:configure-flags
905 (list
906 (string-append "LDFLAGS=-Wl,-rpath="
907 (assoc-ref %outputs "out") "/lib"))))
908 (inputs `(("zlib" ,zlib)))
909 (home-page "http://fallabs.com/kyotocabinet/")
910 (synopsis
911 "Kyoto Cabinet is a modern implementation of the DBM database")
912 (description
913 "Kyoto Cabinet is a standalone file-based database that supports Hash
914 and B+ Tree data storage models. It is a fast key-value lightweight
915 database and supports many programming languages. It is a NoSQL database.")
916 (license gpl3+)))
917
918 (define-public wiredtiger
919 (package
920 (name "wiredtiger")
921 (version "2.8.0")
922 (source (origin
923 (method url-fetch)
924 (uri (string-append
925 "http://source.wiredtiger.com/releases/wiredtiger-"
926 version ".tar.bz2"))
927 (sha256
928 (base32
929 "1qh7y5paisdxq19jgg81ld7i32lz920n5k30hdpxnr8ll9c4hgjr"))))
930 (build-system gnu-build-system)
931 (arguments
932 '(#:configure-flags '("--enable-lz4" "--enable-zlib")
933 #:phases
934 (modify-phases %standard-phases
935 (add-before 'check 'disable-test/fops
936 (lambda _
937 ;; XXX: timed out after 3600 seconds of silence
938 (substitute* "Makefile"
939 (("test/fops") ""))
940 #t)))))
941 (inputs
942 `(("lz4" ,lz4)
943 ("zlib" ,zlib)))
944 (home-page "http://source.wiredtiger.com/")
945 (synopsis "NoSQL data engine")
946 (description
947 "WiredTiger is an extensible platform for data management. It supports
948 row-oriented storage (where all columns of a row are stored together),
949 column-oriented storage (where columns are stored in groups, allowing for
950 more efficient access and storage of column subsets) and log-structured merge
951 trees (LSM), for sustained throughput under random insert workloads.")
952 (license gpl3) ; or GPL-2
953 ;; configure.ac: WiredTiger requires a 64-bit build.
954 (supported-systems '("x86_64-linux" "mips64el-linux"))))