Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / calendar.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
4 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
5 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
7 ;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages calendar)
25 #:use-module (gnu packages)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build utils)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system cmake)
32 #:use-module (guix build-system python)
33 #:use-module (gnu packages base)
34 #:use-module (gnu packages databases)
35 #:use-module (gnu packages dav)
36 #:use-module (gnu packages freedesktop)
37 #:use-module (gnu packages icu4c)
38 #:use-module (gnu packages perl)
39 #:use-module (gnu packages python)
40 #:use-module (srfi srfi-26))
41
42 (define-public libical
43 (package
44 (name "libical")
45 (version "2.0.0")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append
49 "https://github.com/libical/libical/releases/download/v"
50 version "/libical-" version ".tar.gz"))
51 (sha256
52 (base32
53 "1njn2kr0rrjqv5g3hdhpdzrhankyj4fl1bgn76z3g4n1b7vi2k35"))))
54 (build-system cmake-build-system)
55 (arguments
56 '(#:tests? #f ; test suite appears broken
57 #:configure-flags
58 (list (string-append "-DCMAKE_INSTALL_LIBDIR="
59 (assoc-ref %outputs "out") "/lib"))
60 #:phases
61 (modify-phases %standard-phases
62 (add-before 'configure 'patch-paths
63 (lambda _
64 (let ((tzdata (assoc-ref %build-inputs "tzdata")))
65 (substitute* "src/libical/icaltz-util.c"
66 (("\\\"/usr/share/zoneinfo\\\",")
67 (string-append "\"" tzdata "/share/zoneinfo\""))
68 (("\\\"/usr/lib/zoneinfo\\\",") "")
69 (("\\\"/etc/zoneinfo\\\",") "")
70 (("\\\"/usr/share/lib/zoneinfo\\\"") "")))
71 #t)))))
72 (native-inputs
73 `(("perl" ,perl)))
74 (inputs
75 `(("icu4c" ,icu4c)
76 ("tzdata" ,tzdata)))
77 (home-page "https://libical.github.io/libical/")
78 (synopsis "iCalendar protocols and data formats implementation")
79 (description
80 "Libical is an implementation of the iCalendar protocols and protocol
81 data units.")
82 (license lgpl2.1)))
83
84 (define-public khal
85 (package
86 (name "khal")
87 (version "0.9.8")
88 (source (origin
89 (method url-fetch)
90 (uri (pypi-uri "khal" version))
91 (sha256
92 (base32
93 "1blx3gxnv7sj302biqphfw7i6ilzl2xlmvzp130n3113scg9w17y"))))
94 (build-system python-build-system)
95 (arguments
96 `(#:phases (modify-phases %standard-phases
97 ;; Building the manpage requires khal to be installed.
98 (add-after 'install 'manpage
99 (lambda* (#:key inputs outputs #:allow-other-keys)
100 ;; Make installed package available for running the tests
101 (add-installed-pythonpath inputs outputs)
102 (and
103 (zero? (system* "make" "--directory=doc/" "man"))
104 (install-file
105 "doc/build/man/khal.1"
106 (string-append (assoc-ref outputs "out") "/share/man/man1")))))
107 (replace 'check
108 (lambda* (#:key inputs #:allow-other-keys)
109 ;; The tests require us to choose a timezone.
110 (setenv "TZ"
111 (string-append (assoc-ref inputs "tzdata")
112 "/share/zoneinfo/Zulu"))
113 (zero? (system* "py.test" "tests" "-k"
114 (string-append
115 ;; These tests are known to fail in when not
116 ;; running in a TTY:
117 ;; https://github.com/pimutils/khal/issues/683
118 "not test_printics_read_from_stdin "
119 "and not test_import_from_stdin"))))))))
120 (native-inputs
121 ;; XXX Uses tmpdir_factory, introduced in pytest 2.8.
122 `(("python-pytest" ,python-pytest-3.0)
123 ("python-pytest-cov" ,python-pytest-cov)
124 ("python-setuptools-scm" ,python-setuptools-scm)
125 ;; Required for tests
126 ("python-freezegun" ,python-freezegun)
127 ("tzdata" ,tzdata)
128 ("vdirsyncer" ,vdirsyncer)
129 ;; Required to build manpage
130 ("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)
131 ("python-sphinx" ,python-sphinx)))
132 (inputs
133 `(("sqlite" ,sqlite)))
134 (propagated-inputs
135 `(("python-configobj" ,python-configobj)
136 ("python-dateutil" ,python-dateutil)
137 ("python-icalendar" ,python-icalendar)
138 ("python-tzlocal" ,python-tzlocal)
139 ("python-urwid" ,python-urwid)
140 ("python-pyxdg" ,python-pyxdg)))
141 (synopsis "Console calendar program")
142 (description "Khal is a standards based console calendar program,
143 able to synchronize with CalDAV servers through vdirsyncer.")
144 (home-page "http://lostpackets.de/khal/")
145 (license expat)))
146
147 (define-public remind
148 (package
149 (name "remind")
150 (version "3.1.15")
151 (source
152 (origin
153 (method url-fetch)
154 (uri (string-append "https://www.roaringpenguin.com/files/download/"
155 "remind-"
156 (string-join (map (cut string-pad <> 2 #\0)
157 (string-split version #\.))
158 ".")
159 ".tar.gz"))
160 (sha256
161 (base32
162 "1hcfcxz5fjzl7606prlb7dgls5kr8z3wb51h48s6qm8ang0b9nla"))))
163 (build-system gnu-build-system)
164 (arguments
165 '(#:tests? #f)) ;no "check" target
166 (home-page "http://www.roaringpenguin.com/products/remind/")
167 (synopsis "Sophisticated calendar and alarm program")
168 (description
169 "Remind allows you to remind yourself of upcoming events and appointments.
170 Each reminder or alarm can consist of a message sent to standard output, or a
171 program to be executed. It also features: sophisticated date calculation,
172 moon phases, sunrise/sunset, Hebrew calendar, alarms, PostScript output and
173 proper handling of holidays.")
174 (license gpl2)))
175
176 (define-public libhdate
177 (package
178 (name "libhdate")
179 (version "1.6.02")
180 (source
181 (origin
182 (method url-fetch)
183 (uri (string-append "mirror://sourceforge/libhdate/libhdate/libhdate-"
184 version "/" name "-" version ".tar.bz2"))
185 (sha256
186 (base32
187 "0qkpq412p78znw8gckwcx3l0wcss9s0dgw1pvjb1ih2pxf6hm4rw"))))
188 (build-system gnu-build-system)
189 (home-page "http://libhdate.sourceforge.net/")
190 (synopsis "Library to use Hebrew dates")
191 (description "LibHdate is a small library for the Hebrew calendar and times
192 of day, written in C, and including bindings for C++, pascal, perl, php, python,
193 and ruby. It includes two illustrative command-line programs, @code{hcal} and
194 @code{hdate}, and some snippets and scripts written in the binding languages.")
195 (license gpl3+)))