gnu: rsync: Fix cross-compilation.
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages rsync)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages acl)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages popt)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix git-download)
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system gnu))
36
37
38 (define-public rsync
39 (package
40 (name "rsync")
41 (version "3.1.3")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "https://rsync.samba.org/ftp/rsync/src/rsync-"
45 version ".tar.gz"))
46 (sha256
47 (base32
48 "1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
49 (build-system gnu-build-system)
50 (native-inputs
51 `(("perl" ,perl)))
52 (inputs
53 `(("acl" ,acl)))
54 (synopsis "Remote (and local) file copying tool")
55 (description
56 "Rsync is a fast and versatile file copying tool. It can copy locally,
57 to/from another host over any remote shell, or to/from a remote rsync daemon.
58 Its delta-transfer algorithm reduces the amount of data sent over the network
59 by sending only the differences between the source files and the existing
60 files in the destination.")
61 (license license:gpl3+)
62 (home-page "https://rsync.samba.org/")))
63
64 (define-public librsync
65 (package
66 (name "librsync")
67 (version "2.2.1")
68 (source (origin
69 (method git-fetch)
70 (uri (git-reference
71 (url "https://github.com/librsync/librsync.git")
72 (commit (string-append "v" version))))
73 (file-name (git-file-name name version))
74 (sha256
75 (base32
76 "08wdlxsa9zg2pyasz1lwg70d5psi4amv81v4yxwffx67ndzb9yp5"))))
77 (build-system cmake-build-system)
78 (inputs
79 `(("popt" ,popt)))
80 (native-inputs
81 `(("which" ,which)
82 ("perl" ,perl)))
83 (home-page "http://librsync.sourceforge.net/")
84 (synopsis "Implementation of the rsync remote-delta algorithm")
85 (description
86 "Librsync is a free software library that implements the rsync
87 remote-delta algorithm. This algorithm allows efficient remote updates of a
88 file, without requiring the old and new versions to both be present at the
89 sending end. The library uses a \"streaming\" design similar to that of zlib
90 with the aim of allowing it to be embedded into many different applications.")
91 (license license:lgpl2.1+)))
92
93 (define-public librsync-0.9
94 (package
95 (inherit librsync)
96 (version "0.9.7")
97 (source (origin
98 (method url-fetch)
99 (uri (string-append "mirror://sourceforge/librsync/librsync/"
100 version "/librsync-" version ".tar.gz"))
101 (sha256
102 (base32
103 "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
104 (build-system gnu-build-system)
105 (arguments '(#:configure-flags '("--enable-shared")))
106 (inputs '())))