gnu: Add apache-parent-pom-13.
[jackhill/guix/guix.git] / gnu / packages / maven-parent-pom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages maven-parent-pom)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix git-download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system ant)
25 #:use-module (gnu packages java))
26
27 (define (make-apache-parent-pom version hash)
28 (hidden-package
29 (package
30 (name "apache-parent-pom")
31 (version version)
32 (source (origin
33 (method git-fetch)
34 (uri (git-reference
35 (url "https://github.com/apache/maven-apache-parent")
36 (commit (string-append "apache-" version))))
37 (file-name (git-file-name name version))
38 (sha256 (base32 hash))))
39 (build-system ant-build-system)
40 (arguments
41 `(#:tests? #f
42 #:phases
43 (modify-phases %standard-phases
44 (delete 'configure)
45 (delete 'build)
46 (replace 'install
47 (install-pom-file "pom.xml")))))
48 (home-page "https://apache.org/")
49 (synopsis "Apache parent pom")
50 (description "This package contains the Apache parent POM.")
51 (license license:asl2.0))))
52
53 (define-public apache-parent-pom-13
54 (make-apache-parent-pom
55 "13" "1cfxaz1jy8fbn06sb648qpiq23swpbj3kb5ya7f9g9jmya5fy09z"))