gnu: Ceph: Update to 14.2.5.
[jackhill/guix/guix.git] / gnu / packages / patches / audiofile-CVE-2018-17095.patch
1 From 822b732fd31ffcb78f6920001e9b1fbd815fa712 Mon Sep 17 00:00:00 2001
2 From: Wim Taymans <wtaymans@redhat.com>
3 Date: Thu, 27 Sep 2018 12:11:12 +0200
4 Subject: [PATCH] SimpleModule: set output chunk framecount after pull
5
6 After pulling the data, set the output chunk to the amount of
7 frames we pulled so that the next module in the chain has the correct
8 frame count.
9
10 Fixes #50 and #51
11 ---
12 libaudiofile/modules/SimpleModule.cpp | 1 +
13 1 file changed, 1 insertion(+)
14
15 diff --git a/libaudiofile/modules/SimpleModule.cpp b/libaudiofile/modules/SimpleModule.cpp
16 index 2bae1eb..e87932c 100644
17 --- a/libaudiofile/modules/SimpleModule.cpp
18 +++ b/libaudiofile/modules/SimpleModule.cpp
19 @@ -26,6 +26,7 @@
20 void SimpleModule::runPull()
21 {
22 pull(m_outChunk->frameCount);
23 + m_outChunk->frameCount = m_inChunk->frameCount;
24 run(*m_inChunk, *m_outChunk);
25 }
26